Home » Infrastructure » Linux » libclntsh.so.10.1: cannot open error...
libclntsh.so.10.1: cannot open error... [message #236055] Tue, 08 May 2007 16:59 Go to next message
shaseeb
Messages: 113
Registered: April 2007
Location: Madison, WI
Senior Member
I am Running RHEL 4 and I'm trying to start the listener and I'm getting the following error:



[root@rh-staging Apache]# lsnrctl start LSNR_FPRCQA

LSNRCTL for Linux: Version 10.2.0.3.0 - Production on 08-MAY-2007 16:17:15

Copyright (c) 1991, 2006, Oracle. All rights reserved.

Starting /opt/app/oracle/product/10.2.0/db_1/bin/tnslsnr: please wait...

/opt/app/oracle/product/10.2.0/db_1/bin/tnslsnr: error while loading shared libraries: libclntsh.so.10.1: cannot open shared object file: No such file or directory
TNS-12547: TNS:lost contact
TNS-12560: TNS:protocol adapter error
TNS-00517: Lost contact
Linux Error: 32: Broken pipe
Re: libclntsh.so.10.1: cannot open error... [message #236056 is a reply to message #236055] Tue, 08 May 2007 20:44 Go to previous messageGo to next message
BlackSwan
Messages: 25050
Registered: January 2009
Location: SoCal
Senior Member
Such an error is symptomatic that LD_LIBRARY_PATH is not properly defined.
Re: libclntsh.so.10.1: cannot open error... [message #236305 is a reply to message #236056] Wed, 09 May 2007 09:24 Go to previous messageGo to next message
shaseeb
Messages: 113
Registered: April 2007
Location: Madison, WI
Senior Member
Yes, I got it. It was not set in the environment.

THanks
Re: libclntsh.so.10.1: cannot open error... [message #381206 is a reply to message #236055] Thu, 15 January 2009 15:34 Go to previous messageGo to next message
tbball99
Messages: 1
Registered: January 2009
Location: Toronto
Junior Member
I'm facing the exact same error (can't get the listener started in general) but LD_LIBRARY_PATH has been set and the library file is in the folder.

LD_LIBRARY_PATH=/u01/app/oracle/product/10.2.0/db_1/lib32
ORACLE_HOME=/u01/app/oracle/product/10.2.0/db_1

(I also tried lib instead of lib32, with the same result.)

Any suggestions would be appreciated.
Re: libclntsh.so.10.1: cannot open error... [message #381209 is a reply to message #236055] Thu, 15 January 2009 17:28 Go to previous messageGo to next message
BlackSwan
Messages: 25050
Registered: January 2009
Location: SoCal
Senior Member
>LD_LIBRARY_PATH has been set and the library file is in the folder.
So you say. Please provide proof.

You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/
So we can help you.

Are OS & Oracle 32 or 64 bit s/w?


Re: libclntsh.so.10.1: cannot open error... [message #524190 is a reply to message #381209] Thu, 22 September 2011 03:20 Go to previous messageGo to next message
makarim
Messages: 3
Registered: September 2011
Location: Indonesia
Junior Member

I have a same problem with this...

library path has been set.

u using IBM Xeon 64 bit, os RHELL 5.7 Oracle 10.2g.

help please..
Re: libclntsh.so.10.1: cannot open error... [message #524196 is a reply to message #524190] Thu, 22 September 2011 03:34 Go to previous messageGo to next message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
>library path has been set.

So you say. Oracle seems to think otherwise, so Please provide proof.

You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/

So we can help you.
Re: libclntsh.so.10.1: cannot open error... [message #524205 is a reply to message #524196] Thu, 22 September 2011 04:05 Go to previous messageGo to next message
makarim
Messages: 3
Registered: September 2011
Location: Indonesia
Junior Member

this my error code :

[root@server ~]# rpm -Uvh oracle-instantclient11.2-basic-11.2.0.2.0.x86_64.rpm
Preparing... ########################################### [100%]
package oracle-instantclient11.2-basic-11.2.0.2.0-1.x86_64 is already installed
[root@server ~]# rpm -Uvh php-oci8-5.1.6-1.el5.x86_64.rpm
warning: php-oci8-5.1.6-1.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies:
libclntsh.so.10.1()(64bit) is needed by php-oci8-5.1.6-1.el5.x86_64
oracle-instantclient = 10.2.0.3 is needed by php-oci8-5.1.6-1.el5.x86_64
[root@server ~]#
Re: libclntsh.so.10.1: cannot open error... [message #524217 is a reply to message #524205] Thu, 22 September 2011 04:26 Go to previous messageGo to next message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
Ah, so it is actually a completely DIFFERENT problem.

php-oci8-5.1.6 seems to need oracle-instantclient-10.2.0.3. So either use a newer php-oci or an older oracle. They have to match.

Re: libclntsh.so.10.1: cannot open error... [message #524311 is a reply to message #524217] Thu, 22 September 2011 22:24 Go to previous message
makarim
Messages: 3
Registered: September 2011
Location: Indonesia
Junior Member

okay, i will try it first...
Previous Topic: Oracle- 11G(linux.x64_11gR2) installation issue
Next Topic: Enterprise Manager error
Goto Forum:
  


Current Time: Sun Dec 11 08:22:06 CST 2016

Total time taken to generate the page: 0.16176 seconds