Home » RDBMS Server » Server Administration » Insert into MS Access using Oracle Heterogeneous Services inserts null into memo fields
icon5.gif  Insert into MS Access using Oracle Heterogeneous Services inserts null into memo fields [message #235007] Thu, 03 May 2007 13:39
Messages: 5
Registered: May 2007
Junior Member
Hi all,

I am connecting to MS Access 97 DB using heterogeneous services through a DB link in Oracle DB.

I am selecting various datatype columns from Oracle table using a cursor. Inside the cursor loop I am inserting the cursor fields into Access DB. The issue is:

All fields such as number,character or date are well inserted into corresponding Access text, number and date columns. However, any kind of field that is to be inserted into a memo type column in Access is inserted as null. e.g.:

"insert into mytable@access_db (memo_column) values (cursor.field1);"

I tried data conversion functions such as to_char or tried to assign selected field values into various variables such as long, char, varchar2, or varchar and thenn insert into Access. Nothing has worked.

On the other hand if tried to insert a literal into Access memo type column using something like "insert into mytable@access_db (memo_column) values ('trial');" it inserts the values.

How can I prevent this from happening. Is it because of ODBC connection, Access or Oracle. I have used coldfusion form to select from Oracle and insert into access and it worked fine. But I'd like to create packages that would do data manipulation to insert into Access. Any suggestions are highly appreciated Smile
Previous Topic: UNDO segments needed recovery
Next Topic: Oracle 10g Install on Windows - password file
Goto Forum:

Current Time: Mon Oct 24 00:53:27 CDT 2016

Total time taken to generate the page: 0.07468 seconds