Home » SQL & PL/SQL » SQL & PL/SQL » error while running sql query
error while running sql query [message #234434] Tue, 01 May 2007 10:17 Go to next message
jinga
Messages: 115
Registered: January 2003
Senior Member
While running an sql query (that has start with connect by ), we are getting this error.

the query is below

select * from 
(select a.tree_version_sid tree_version_sid, 
a.higher_index_sid higher_index_sid,
(b.tree_id||b.TREE_CYCLE_CODE||b.VERSION_NUM||b.tree_category||b.TREE_EXP_FLAG||b.TREE_TYPE) tree_code,
a.ppi_index_code index_code,
a.official_pub_title index_title,
a.INDEX_BASE_PERIOD_N index_base_date,
a.off_index_value_n off_index_value_n, a.PUB_STATUS_FLAG_N pub_status_flag_n,a.ppi_index_sid ppi_index_sid  
from ixrev_index_data a, tree_version b
where a.tree_version_sid = b.tree_version_sid and
      a.job_sid = 4 and
      a.tree_category in ('20','43','23')) 
connect by prior PPI_INDEX_SID = HIGHER_INDEX_SID and 
prior tree_version_sid = tree_version_sid
start with HIGHER_INDEX_SID is null



ERROR at line 1:
ORA-00600: internal error code, arguments: [qesmmCValStat4], [3], [1], [], [],
[], [], []

This error does not come in our development environment. But comes in our test environment.


I am wondering if any one could help me understand what might be the reason


Thanks
Re: error while running sql query [message #234440 is a reply to message #234434] Tue, 01 May 2007 10:36 Go to previous messageGo to next message
Michel Cadot
Messages: 63801
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ORA-00600 means Oracle encountered an internal bug.
It depends on your (full) version.
The standard action is to call Oracle support.
You can try to rewrite your query.

Regards
Michel
Re: error while running sql query [message #234525 is a reply to message #234440] Wed, 02 May 2007 00:45 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
Check Metalink. There are some references to this errorcode.
Especially Note 360811.1 (bug 4926357) seems to apply.
This is fixed in 9.2.0.8 (if you're on 9.2)
Re: error while running sql query [message #426426 is a reply to message #234434] Thu, 15 October 2009 06:47 Go to previous messageGo to next message
nathalia_ferrete
Messages: 1
Registered: October 2009
Location: Brasil
Junior Member
Have u found any solution to this error?

Tks,
Nathália.
Re: error while running sql query [message #426427 is a reply to message #426426] Thu, 15 October 2009 06:50 Go to previous message
JRowbottom
Messages: 5933
Registered: June 2006
Location: Sunny North Yorkshire, ho...
Senior Member
Quote:
Check Metalink. There are some references to this errorcode.
Especially Note 360811.1 (bug 4926357) seems to apply.
This is fixed in 9.2.0.8 (if you're on 9.2)


Which part of Frank's reply did you not see?
Information on Metalink is restricted by license from being redistributed - if you don't have a support contract, then you just can't get the information.

You could try rewriting your query - start with removing the unneccessary inline view
Previous Topic: how to attach a file?
Next Topic: Update statement using 2 tables
Goto Forum:
  


Current Time: Sat Sep 24 21:27:26 CDT 2016

Total time taken to generate the page: 0.14170 seconds