Home » Infrastructure » Windows » oa-12500
oa-12500 [message #234416] Tue, 01 May 2007 09:41 Go to next message
miraijaz
Messages: 15
Registered: October 2006
Junior Member
hi all,
I am getting error ora-12500, listener is running and service is up. the user can connect after trying it several times or restarting the application. the users are connected mostly through JDBC.

please help, thanks in advance
Re: oa-12500 [message #234473 is a reply to message #234416] Tue, 01 May 2007 13:26 Go to previous messageGo to next message
orausern
Messages: 817
Registered: December 2005
Senior Member
Sometimes I came across such errors, and in those cases, there was a problem with the oracle installation etc- but this may not be true in your case.just this is out of my experience.

Oracle documentation says:

"TNS-12500 TNS:listener failed to start a dedicated server process

Cause: The process of starting up a dedicated server process failed. The executable could not be found or the environment may be set up incorrectly.

Action: Turn on tracing at the ADMIN level and re-execute the operation. Verify that the Oracle Server executable is present and has execute permissions enabled. Ensure that the Oracle environment is specified correctly in LISTENER.ORA. The Oracle Protocol Adapter that is being called may not be installed on the local hard drive. Check that the correct Protocol Adapter are successfully linked. If the error persists, contact Oracle Support Services."

so if problem persists you can open a SR with Oracle Support.

Re: oa-12500 [message #235342 is a reply to message #234416] Sat, 05 May 2007 02:59 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

http://dbataj.blogspot.com/2007/03/ora-12500.html
Re: oa-12500 [message #235354 is a reply to message #235342] Sat, 05 May 2007 04:52 Go to previous messageGo to next message
miraijaz
Messages: 15
Registered: October 2006
Junior Member
hi taj
i went to the link you mentioned earlier.

90% times i get windows error: 233 (no process is on the other end of the pipe)

10% it is windows error: 109

could you please probide more information on these errors. futhermore, when i go to task manager i could not see any oracle.exe process running even though i am having administrator priviliges on the server.

please inform me how i can know the owner who has installed the oracle and the owners of the oracle services (listener and service ). someone mentioned that they should have the same owner. i will be thankful to you if you provide me more details.

regards
aijaz
Re: oa-12500 [message #235828 is a reply to message #235354] Tue, 08 May 2007 02:02 Go to previous messageGo to next message
miraijaz
Messages: 15
Registered: October 2006
Junior Member
any body with some solutions, please help
Re: oa-12500 [message #235831 is a reply to message #235354] Tue, 08 May 2007 02:05 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
Are you check event viewer for windows error number.
check and post here


regards
Taj
Re: oa-12500 [message #235839 is a reply to message #235831] Tue, 08 May 2007 02:33 Go to previous messageGo to next message
miraijaz
Messages: 15
Registered: October 2006
Junior Member
nothing is mentioned in the event viewer about 233 and 109. why oracle.exe is not shown in the task manager.
Re: oa-12500 [message #235841 is a reply to message #235839] Tue, 08 May 2007 02:39 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

database is open ... if not then oracle.exe is not showing in task manager.

Note: if oracle database services is stop.


regards
Taj



Re: oa-12500 [message #235842 is a reply to message #235841] Tue, 08 May 2007 02:42 Go to previous messageGo to next message
miraijaz
Messages: 15
Registered: October 2006
Junior Member
yes oracle is up and running services are up and running. this is a production database 24X7
user are connected to it but sometimes some users get the error TNS-12500
Re: oa-12500 [message #235848 is a reply to message #235842] Tue, 08 May 2007 02:50 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

for more info you have to enable tracing and check log file.

listener.log


Regards
Taj
Re: oa-12500 [message #235862 is a reply to message #235848] Tue, 08 May 2007 03:31 Go to previous message
miraijaz
Messages: 15
Registered: October 2006
Junior Member
listener.log has

03-MAY-2007 11:55:06 * (CONNECT_DATA=(SID=webp)(CID=(PROGRAM=)(HOST=__jdbc__)(USER=oracle))) * (ADDRESS=(PROTOCOL=tcp)(HOST=172.17.16.79)(PORT=2797)) * establish * webp * 12500
TNS-12500: TNS:listener failed to start a dedicated server process
TNS-12560: TNS:protocol adapter error
TNS-00530: Protocol adapter error
32-bit Windows Error: 233: Unknown error
------------------
trace file has
ntnwr: failed to write 113 bytes
ntn2err: error: handle=296, op=6, nt[0]=530, nt[1]=0
nspsend: transport write error
nscon: error sending NSPTRF packet
nserror: nsres: id=7, op=67, ns=12571, ns2=12560; nt[0]=530, nt[1]=0, nt[2]=0; ora[0]=0, ora[1]=0, ora[2]=0
ntnrd: failed to read 2064 bytes
ntn2err: error: handle=296, op=5, nt[0]=507, nt[1]=109
nserror: nsres: id=7, op=68, ns=12537, ns2=12560; nt[0]=507, nt[1]=109, nt[2]=0; ora[0]=0, ora[1]=0, ora[2]=0
nserror: nsres: id=3, op=68, ns=12612, ns2=0; nt[0]=0, nt[1]=0, nt[2]=0; ora[0]=0, ora[1]=0, ora[2]=0
ntt2err: soc 296 error - operation=5, ntresnt[0]=524, ntresnt[1]=997, ntresnt[2]=0
ntt2err: soc 296 error - operation=5, ntresnt[0]=517, ntresnt[1]=54, ntresnt[2]=0
nserror: nsres: id=1, op=78, ns=12612, ns2=0; nt[0]=0, nt[1]=0, nt[2]=0; ora[0]=0, ora[1]=0, ora[2]=0
ntnrd: failed to read 8208 bytes
ntn2err: error: handle=300, op=5, nt[0]=524, nt[1]=997
-----------
regards
aijaz

Previous Topic: ora-37002 failed to initialize OLAP
Next Topic: 9i SWITCH OVER
Goto Forum:
  


Current Time: Sat Dec 03 22:05:54 CST 2016

Total time taken to generate the page: 0.17091 seconds