Home » Developer & Programmer » Forms » Form is not committing
Form is not committing [message #233904] Sat, 28 April 2007 01:22 Go to next message
santoshbahir123
Messages: 4
Registered: April 2007
Location: Bangalore
Junior Member
Hi,

I have a form with a block on it. when I entering the new records in the block and saving it, one message is displayed,
"FRM-40400: Transaction Complete: 1 records applied and saved."

but actually no record is saved.

please advise me if anybody knows the reason for the same.

Thanks,
Santosh

[Updated on: Sat, 28 April 2007 01:43]

Report message to a moderator

Re: Form is not committing [message #233980 is a reply to message #233904] Sat, 28 April 2007 12:46 Go to previous messageGo to next message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
How do you know records are not saved? How did you check it? Did you connect to the same schema using Forms and tool you checked this out? Did you query the same table?
Re: Form is not committing [message #234007 is a reply to message #233904] Sat, 28 April 2007 22:48 Go to previous messageGo to next message
santoshbahir123
Messages: 4
Registered: April 2007
Location: Bangalore
Junior Member
Yes, I am querying the same table in the same schema and I am getting no records saved.
Re: Form is not committing [message #234053 is a reply to message #234007] Sun, 29 April 2007 04:15 Go to previous messageGo to next message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
You are talking about a very common process in Oracle Forms Developer - insert a record and save it into a table. It just ... works, there's nothing unusual in it. UNLESS you have added / changed something that prevents it to be done.

Is there hidden code? KEY-COMMIT / POST-INSERT / some other trigger which inserts and deletes a record? A database trigger which deletes record as soon as it gets inserted? Something else?

Once again: by default, it works, always.
Re: Form is not committing [message #234072 is a reply to message #234053] Sun, 29 April 2007 07:16 Go to previous messageGo to next message
santoshbahir123
Messages: 4
Registered: April 2007
Location: Bangalore
Junior Member
Yes, it was happening beacuse I had written key-commit trigger and there was not explicit commit in it. I added it and it is working fine now..Smile
thanks to all of yoy for your response.
Re: Form is not committing [message #622237 is a reply to message #234072] Sat, 23 August 2014 04:58 Go to previous messageGo to next message
kilimanjaro
Messages: 134
Registered: May 2009
Location: Tanzania
Senior Member
Hello friend

How did you add explicit commit on it?I facing the same problem.

Thank you.
Re: Form is not committing [message #622238 is a reply to message #622237] Sat, 23 August 2014 05:04 Go to previous message
kilimanjaro
Messages: 134
Registered: May 2009
Location: Tanzania
Senior Member
ohh
I got it.Thank you.
Previous Topic: Update trigger
Next Topic: error in trigger KEY-NEXT-ITEM
Goto Forum:
  


Current Time: Sat Dec 03 03:58:22 CST 2016

Total time taken to generate the page: 0.11152 seconds