Home » RDBMS Server » Enterprise Manager » dbconsole failed to start
dbconsole failed to start [message #233476] Thu, 26 April 2007 04:55 Go to next message
kamragulshan
Messages: 63
Registered: May 2005
Location: Delhi
Member
Hi All,

When i am trying to start dbconsole, it throughs error:


oracle@aaa:aaa:>emctl status dbconsole
Oracle Enterprise Manager 10g Database Control Release 10.1.0.4
Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
http://aaa:5500/em/console/aboutApplication
EM Daemon is not running.
------------------------------------------------------------------
Logs are generated in directory /software/oracle/product/10.1.0.2/aaa_aaa/sysman/log
oracle@aaa:aaa:>emctl stop dbconsole


Oracle Enterprise Manager 10g Database Control Release 10.1.0.4
Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
http://aaa:5500/em/console/aboutApplication
Stopping Oracle Enterprise Manager 10g Database Control ...
... Stopped.
oracle@aaa:aaa:>emctl start dbconsole
Oracle Enterprise Manager 10g Database Control Release 10.1.0.4
Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
http://aaa:5500/em/console/aboutApplication
Starting Oracle Enterprise Manager 10g Database Control ............................................................................................. failed.
------------------------------------------------------------------
Logs are generated in directory /software/oracle/product/10.1.0.2/aaa_aaa/sysman/log


Please help to resolve the error.

Thanx

Gulshan
Re: dbconsole failed to start [message #233804 is a reply to message #233476] Fri, 27 April 2007 09:17 Go to previous messageGo to next message
dba_bng
Messages: 13
Registered: April 2007
Junior Member
Did you try the following...

$emctl start dbconsole
Re: dbconsole failed to start [message #233971 is a reply to message #233476] Sat, 28 April 2007 10:48 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
Can you please post below files.
emagent.trc
emoms.trc
Location : $ORACLE_HOME/hostname.domainname/sysman/log

regards
Taj


Re: dbconsole failed to start [message #234180 is a reply to message #233971] Mon, 30 April 2007 05:37 Go to previous messageGo to next message
kamragulshan
Messages: 63
Registered: May 2005
Location: Delhi
Member
Plz find the contents of emoms.trc file

2007-04-30 10:30:02,980 [JobWorker 388:Thread-12] ERROR em.jobs executeCommand.159 - UpdateARUTables: Oracle MetaLink credentials are incorrect or missing. Click Patching Setup to set required parameters.
2007-04-30 14:57:54,041 [EMUI_14_57_52_/console/database/instance/sitemap] ERROR perf.sitemap initializeGeneral.327 - Failed to initialize object: ORA-20206:
ORA-06512: at "SYSMAN.EMD_DATABASE", line 1144
ORA-01403: no data found
ORA-06512: at line 1

2007-04-30 14:58:08,360 [EMUI_14_58_08_/console/database/instance/sitemap] ERROR perf.sitemap initializeGeneral.327 - Failed to initialize object: ORA-20206:
ORA-06512: at "SYSMAN.EMD_DATABASE", line 1144
ORA-01403: no data found
ORA-06512: at line 1

2007-04-30 14:58:34,063 [EMUI_14_58_33_/console/database/stgAdv/problems] ERROR adm.misc logException.2419 - oracle.sysman.emSDK.emd.comm.CommException: Exception in sending Request :: null
at oracle.sysman.emSDK.emd.comm.EMDClient.getResponseForRequest_(EMDClient.java:1319)
at oracle.sysman.emSDK.emd.comm.EMDClient.getResponseForRequest(EMDClient.java:1212)
at oracle.sysman.emSDK.emd.comm.EMDClient.getActiveTargetCollection(EMDClient.java:2930)
at oracle.sysman.emo.util.stgAdv.StgConfigBean.initAgentData(StgConfigBean.java:250)
at oracle.sysman.emo.util.stgAdv.StgConfigBean.refreshData(StgConfigBean.java:205)
at oracle.sysman.db.util.stgAdv.ProblemsController.onEvent(ProblemsController.java:205)
at oracle.sysman.db.adm.DBController.handleEvent(DBController.java:2166)
at oracle.sysman.db.util.stgAdv.ProblemsController.handleEvent(ProblemsController.java:178)
at oracle.sysman.emSDK.svlt.PageHandler.handleRequest(PageHandler.java:376)
at oracle.sysman.db.util.UtilControllerResolver.handleRequest(UtilControllerResolver.java:128)
at oracle.sysman.emSDK.svlt.EMServlet.myDoGet(EMServlet.java:688)
at oracle.sysman.emSDK.svlt.EMServlet.doGet(EMServlet.java:291)
at oracle.sysman.eml.app.Console.doGet(Console.java:285)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.evermind.server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:65)
at oracle.sysman.emSDK.svlt.EMRedirectFilter.doFilter(EMRedirectFilter.java:101)
at com.evermind.server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:16)
at oracle.sysman.db.adm.inst.HandleRepDownFilter.doFilter(HandleRepDownFilter.java:133)
at com.evermind.server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:20)
at oracle.sysman.eml.app.ContextInitFilter.doFilter(ContextInitFilter.java:269)
at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:600)
at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:317)
at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:790)
at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:270)
at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:112)
at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:186)
at java.lang.Thread.run(Thread.java:534)


There is nothing special in emagent.trc files as the contents of the file are too old.

So please suggest to resolve the problem



Re: dbconsole failed to start [message #234195 is a reply to message #234180] Mon, 30 April 2007 07:27 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
You have to also post emagent.trc file.
anyway do something like
1.what is ACCOUNT_STATUS of SYSMAN, DBSNMP user account.
if LOCK then unlock first.

if still problem exists then recreate new repository ...


Regards
Taj
Re: dbconsole failed to start [message #311012 is a reply to message #234195] Thu, 03 April 2008 04:24 Go to previous messageGo to next message
sunpraveen
Messages: 2
Registered: October 2006
Junior Member
Hi,

I am also facing the same issue. Is the error resolved? If so, can you please let us know the resolution?

Thanks in advance,

Regards,

Praveen
Re: dbconsole failed to start [message #311502 is a reply to message #311012] Fri, 04 April 2008 11:44 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Did you check what Taj mentinoed??
Re: dbconsole failed to start [message #316276 is a reply to message #233476] Thu, 24 April 2008 07:56 Go to previous messageGo to next message
gulspurv
Messages: 1
Registered: April 2008
Location: Denmark
Junior Member
Hi

Same problem here. I cloned the base to make a testbase and EM on the testbase didn't work. Solved it by recreating EM repository on the testbase as Taj mentioned:

c:\> emca -deconfig all db -repos drop
c:\> emca -config all db -repos create

The agents adress is by default {ORACLE_HOME} = [drive letter]\oracle\product\10.2.0\db_1
Re: dbconsole failed to start [message #316427 is a reply to message #233476] Fri, 25 April 2008 02:06 Go to previous messageGo to next message
sunpraveen
Messages: 2
Registered: October 2006
Junior Member
Yes, I was also able to solve the problem. The issue was that the instance was a clone of production and it had some binaries missing like emagent and emdctl.

Copied the same from production and relinked them.

Then dropped the repository and recreated it.

Thanks all for your suggestions.

Regards,

Praveen

Re: dbconsole failed to start [message #436853 is a reply to message #233476] Tue, 29 December 2009 00:30 Go to previous message
vdhan
Messages: 2
Registered: December 2009
Location: Chennai
Junior Member
Your problem is solved in the following blogpost

oracledba-vinod.blogspot.com/2009/05/oem-dbconsole-start-failed.html

Thanks
Vdhan
Previous Topic: How To Add Shell Scripts already written to 10g Grid
Next Topic: Cannot connect to database
Goto Forum:
  


Current Time: Fri Jul 11 09:48:29 CDT 2014

Total time taken to generate the page: 0.09681 seconds