Home » Infrastructure » Unix » ORA-12547: TNS:lost contact
ORA-12547: TNS:lost contact [message #229550] Mon, 09 April 2007 02:11 Go to next message
alaa_h
Messages: 2
Registered: April 2007
Junior Member
OS: UNIX AIX 5.3
Oracle release: 9.2.0.1


I tried to install the patches of 9.2.0.8.

- I've one DB.
- I download the patches file from metalink.
- I installed the patches without any error messages through installing and in the same ORACLE_HOME

But

- When I tried to upgrade DB by using "dbua"

it shows me this error msg:

ERROR:
ORA-12547: TNS:lost contact


- If I connect to DB using SQL*PLUS, it shows me this error msg:

Enter user-name:
exec(): 0509-036 Cannot load program oracle because of the following errors:
0509-130 Symbol resolution failed for /u01/app/oracle/product/9.2.0/lib/libjox9.a[shr.o] because:
0509-136 Symbol sltsini (number 424) is not exported from
dependent module oracle.
0509-136 Symbol sltspsdestroy (number 425) is not exported from
dependent module oracle.
0509-136 Symbol sltspsinit (number 426) is not exported from
dependent module oracle.
0509-136 Symbol sltspspost (number 427) is not exported from
dependent module oracle.
0509-136 Symbol sltspswait (number 428) is not exported from
dependent module oracle.
0509-136 Symbol sltstcl (number 429) is not exported from
dependent module oracle.
0509-136 Symbol sltster (number 430) is not exported from
dependent module oracle.
0509-136 Symbol sltstgh (number 431) is not exported from
dependent module oracle.
0509-136 Symbol sltstkill (number 432) is not exported from
dependent module oracle.
0509-136 Symbol sltstspawn (number 433) is not exported from
dependent module oracle.
0509-192 Examine .loader section symbols with the
'dump -Tv' command.
ERROR:
ORA-12547: TNS:lost contact

-----
export LD_LIBRARY_PATH=$ORACLE_HOME/lib:$ORACLE_HOME/rdbms/lib
export LIBPATH=$ORACLE_HOME/lib:$ORACLE_HOME/rdbms/lib

Question:

Does anyone know how we can solve this?
Re: ORA-12547: TNS:lost contact [message #229592 is a reply to message #229550] Mon, 09 April 2007 05:55 Go to previous messageGo to next message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
- When I tried to upgrade DB by using "dbua"


Why don't you upgrate the database with ..

startup migrate
spool patch.log
@?/rdbms/admin/catpatch.sql
spool off


.. like it is described in detail in the README of the patchset? I havent seen "dbua" mentioned in that (not even with a grep)

Also, have you done all the preinstallation tasks and reviewed the known preinstallation issues from the README?

Have you installed the patch according to chapter 6.1 of the README? Have you run the $ORACLE_HOME/root.sh at the appropriate point?

To resolve it either remove the pathset (chapter 8 of the readme) or try to reinstall it (chapter 9 of the readme)

Im' crossing my fingers four you just in case. Wink
Re: ORA-12547: TNS:lost contact [message #229626 is a reply to message #229550] Mon, 09 April 2007 07:20 Go to previous messageGo to next message
alaa_h
Messages: 2
Registered: April 2007
Junior Member
>When you run "runInstall" it will start Oracle Universal Installer"

> dbua is to upgrade DB after installing patches.

How can I use:

startup migrate
spool patch.log
@?/rdbms/admin/catpatch.sql
spool off

Since I am not able to connect to Sql*Plus?

[Updated on: Mon, 09 April 2007 07:27]

Report message to a moderator

Re: ORA-12547: TNS:lost contact [message #229834 is a reply to message #229626] Tue, 10 April 2007 02:43 Go to previous messageGo to next message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
So have you followed the instructions to install the patchset, or have you just started the installer?

Especially the part about shutting down all DBs and Oracle processes, and unloading the kernel / library modules from memory with /usr/sbin/slibclean as root BEFORE starting "runInstall"?

Are there any error messages in the installer logfile that libraries couldn't be updated or any other errors?

Is there a backup from before the patch?

You could either try installing the patch again from the start, or restore the old version and start over from there.
Re: ORA-12547: TNS:lost contact [message #229840 is a reply to message #229834] Tue, 10 April 2007 02:46 Go to previous messageGo to next message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
Oh, one thing you could try, it it was an error during the link process of the patch :

$ORACLE_HOME/bin/relink all


as oracle user.

Re: ORA-12547: TNS:lost contact [message #229922 is a reply to message #229840] Tue, 10 April 2007 05:51 Go to previous messageGo to next message
tahpush
Messages: 961
Registered: August 2006
Location: Stockholm/Sweden
Senior Member

I have noticed that OP has submitted this on Metalink
docid:698191.994
Also seen some advice that running "/usr/sbin/slibclean" as root, would solve the connect issue

[Updated on: Tue, 10 April 2007 05:54]

Report message to a moderator

Re: ORA-12547: TNS:lost contact [message #230362 is a reply to message #229922] Wed, 11 April 2007 12:08 Go to previous message
harshad.gohil
Messages: 157
Registered: April 2007
Location: USA
Senior Member
Seems the best option is to "relink all" with oracle user.
and start migrating your db with the command line.
Previous Topic: How to load data from a .csv file, having different name, on daily basis using sqlldr
Next Topic: error plz help me
Goto Forum:
  


Current Time: Sun Dec 11 07:59:44 CST 2016

Total time taken to generate the page: 0.11092 seconds