Home » Infrastructure » Windows » ora-00604 and ora-01009
ora-00604 and ora-01009 [message #228646] Tue, 03 April 2007 09:48 Go to next message
parvinder.infogen
Messages: 10
Registered: February 2007
Location: New Delhi
Junior Member

Can anybody help?
I have installed oracle 10g developer suite on Windows Vista.
I made neccesary changes in tnsnames.ora
but when try to connect form builder with database
I got error ora-00604 for recursive sql

Forms 6i works fine on same platform.
Can anybody solve this problem.
I have also tried by changing NLS_lang in registry. It have not worked

Thanks

Re: ora-00604 and ora-01009 [message #228661 is a reply to message #228646] Tue, 03 April 2007 10:10 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
got error ora-00604 for recursive sql


Are you getting any other error with ORA-00604. if not then you should go for metalink site.
becuase ORA-006XX better handle by Oracle Support.



regards
Taj
Re: ora-00604 and ora-01009 [message #228662 is a reply to message #228661] Tue, 03 April 2007 10:15 Go to previous messageGo to next message
parvinder.infogen
Messages: 10
Registered: February 2007
Location: New Delhi
Junior Member

Thanks Sir, I will try for solution at metalink
Re: ora-00604 and ora-01009 [message #257423 is a reply to message #228662] Wed, 08 August 2007 05:54 Go to previous messageGo to next message
princetn
Messages: 3
Registered: August 2007
Junior Member
I have the same problem, ora-00604 and ora-01009 when I try to connect from Forms builder (OS=Vista professional).

I istalled the server ora 10g and works fine on vista and also I installed Developer suite 10g and fomrs works fine but only the connection to the DB is not possible.


So please if there is someone who bypassed that could share his idea.


Thanks in advance
Best regards.
Re: ora-00604 and ora-01009 [message #257438 is a reply to message #257423] Wed, 08 August 2007 06:38 Go to previous messageGo to next message
Michel Cadot
Messages: 64121
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ora-00604: error occurred at recursive SQL level %s
 *Cause:  An error occurred while processing a recursive SQL statement
           (a statement applying to internal dictionary tables).
 *Action: If the situation described in the next error on the stack
           can be corrected, do so; otherwise contact Oracle Support.

ora-01009: missing mandatory parameter
 *Cause:
 *Action:

Post the statement you're executing when you got the error.

Regars
Michel
Re: ora-00604 and ora-01009 [message #257452 is a reply to message #257438] Wed, 08 August 2007 07:06 Go to previous messageGo to next message
princetn
Messages: 3
Registered: August 2007
Junior Member
Yes,

you have reason.
You can find attached the print screen of the error accured.

Re: ora-00604 and ora-01009 [message #257906 is a reply to message #228646] Thu, 09 August 2007 08:59 Go to previous messageGo to next message
MarcL
Messages: 455
Registered: November 2006
Location: Connecticut, USA
Senior Member
It's smelling more and more like an Oracle bug. What did your metalink search turn up ?
Re: ora-00604 and ora-01009 [message #258086 is a reply to message #257906] Fri, 10 August 2007 02:53 Go to previous messageGo to next message
princetn
Messages: 3
Registered: August 2007
Junior Member
MarcL wrote on Thu, 09 August 2007 08:59
It's smelling more and more like an Oracle bug. What did your metalink search turn up ?


Nothing, my bro. and that why I am posting here. The only response is that forms ora 10g is not certified vista yet.

So, please if someone have succeeded on working with Forms ora 10g with Vista and specialy can connect to DB could share how did you overcome this.
Re: ora-00604 and ora-01009 [message #291678 is a reply to message #258086] Sat, 05 January 2008 20:36 Go to previous messageGo to next message
manijan
Messages: 1
Registered: January 2008
Location: Toronto
Junior Member
I am also trying to connect Oracle 10g to developer suite 10g on vista but unable to make connection between database and forms.

Is there any solution available ?

  • Attachment: error.jpg
    (Size: 11.20KB, Downloaded 1087 times)
Re: ora-00604 and ora-01009 [message #291694 is a reply to message #291678] Sun, 06 January 2008 00:41 Go to previous messageGo to next message
Michel Cadot
Messages: 64121
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Search for any trigger on logon.
If you are not the DBA ask your DBA.

Regards
Michel
Re: ora-00604 and ora-01009 [message #331774 is a reply to message #228646] Sat, 05 July 2008 08:31 Go to previous messageGo to next message
mjjugs
Messages: 1
Registered: June 2006
Junior Member
Hi I too cannot connect the oracle business suite to the 10g database.
Has there been any fix to the problem: ora-00604: error occurred at recursive SQL level?

[Updated on: Sat, 05 July 2008 08:37]

Report message to a moderator

Re: ora-00604 and ora-01009 [message #331782 is a reply to message #228646] Sat, 05 July 2008 08:44 Go to previous messageGo to next message
BlackSwan
Messages: 25042
Registered: January 2009
Location: SoCal
Senior Member
Please read & follow Posting Guidelines below
http://www.orafaq.com/forum/t/88153/0/
Re: ora-00604 and ora-01009 [message #331784 is a reply to message #331774] Sat, 05 July 2008 09:20 Go to previous messageGo to next message
Michel Cadot
Messages: 64121
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
Has there been any fix to the problem: ora-00604: error occurred at recursive SQL level?

Find the root cause of this error.

Regards
Michel
Re: ora-00604 and ora-01009 [message #353299 is a reply to message #331784] Mon, 13 October 2008 04:58 Go to previous messageGo to next message
geordi
Messages: 1
Registered: October 2008
Location: Muscat,Sultanate of Oman
Junior Member
I installed 10g developer suite on Windows Vista and installaed 10g express database.
I am getting the error ora-00604 and ora-01009 when I try to connect from Forms builder 10g.
Forms 6i works fine.
Does anyone have a solution for this issue,please help.
Re: ora-00604 and ora-01009 [message #395103 is a reply to message #353299] Tue, 31 March 2009 05:40 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Dear User,

Check the above Micheal reply...
Re: ora-00604 and ora-01009 [message #395105 is a reply to message #395103] Tue, 31 March 2009 05:43 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


Taj.

It's looks like old thread (last update Mon, 13 October 2008 15:28).

Why your replying now !

Babu
Re: ora-00604 and ora-01009 [message #395107 is a reply to message #395105] Tue, 31 March 2009 05:46 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Sorry Guys,

I didn't check the date before reply...
Re: ora-00604 and ora-01009 [message #447508 is a reply to message #291694] Mon, 15 March 2010 10:21 Go to previous messageGo to next message
kojot
Messages: 27
Registered: December 2009
Location: Poland
Junior Member
Michel Cadot wrote on Sun, 06 January 2008 00:41
Search for any trigger on logon.
If you are not the DBA ask your DBA.

Regards
Michel


Could you give me some more specified information about it ?
I've bought Windows 7 Pro. and I've got the same problem with connecting to the database from Forms Builder.
Re: ora-00604 and ora-01009 [message #447516 is a reply to message #447508] Mon, 15 March 2010 11:36 Go to previous messageGo to next message
Michel Cadot
Messages: 64121
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Which part do you want more information?
Asking your DBA? I think you can pick upi the phone.
Finding logon triggers? If you are not a DBA I don't think you are able to find the useful information in Oracle dictionary assuming if you have privileges enough to search for.

Regards
Michel
Re: ora-00604 and ora-01009 [message #447521 is a reply to message #228646] Mon, 15 March 2010 12:38 Go to previous messageGo to next message
kojot
Messages: 27
Registered: December 2009
Location: Poland
Junior Member
I am administrator of my database Smile but I'm a student and I'm learning oracle, thats why I asked you for help to find those triggers.

Anyway, the problem is solved. I did install dev suit in version 10.1.2.0.2 and it works pretty fine wihtout any problems.

Thank you for your help.

Regards,
Wojtek.
Re: ora-00604 and ora-01009 [message #447522 is a reply to message #447521] Mon, 15 March 2010 12:41 Go to previous message
Michel Cadot
Messages: 64121
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
For your information, you can find information about triggers in DBA_TRIGGERS view.

Regards
Michel

[Updated on: Mon, 15 March 2010 12:42]

Report message to a moderator

Previous Topic: oracle 10g ERROR: 12560
Next Topic: Install oracle 9i in window 7 problem unable to run setup.exe for oracle(64 bit window 7)
Goto Forum:
  


Current Time: Wed Dec 07 03:21:30 CST 2016

Total time taken to generate the page: 0.08584 seconds