Home » RDBMS Server » Server Administration » ORA-12560: TNS:protocol adapter error ???
icon5.gif  ORA-12560: TNS:protocol adapter error ??? [message #225688] Wed, 21 March 2007 00:07 Go to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Hi All,

I have installed Oracle Database 10G Express Edition on Windows XP.

I am trying to create a database by following this URL:
http://www.adp-gmbh.ch/ora/admin/creatingdbmanually.html

I dont know why but when issue following command it gives my ORA-12560: TNS:protocol adapter error:
connect sys/MYSECRETPASSWORD as sysdba (MYSECRETPASSWORD was replace with original password).

I have checked that service is created.

Does anyone faced this problem ever? What causes this error and what is the solution for it?

Thanks in advance

Naimish R. Dave
Re: ORA-12560: TNS:protocol adapter error ??? [message #225689 is a reply to message #225688] Wed, 21 March 2007 00:09 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Here is my initSID.ora file, its in %Oracle_Home%\database folder.


db_name = DIABOS10

db_files = 1020

control_files = (D:\ora\ctl1DIABOS10.ora, C:\ora\ctl2DIABOS10.ora)

undo_management = auto

db_block_size = 8192

db_file_multiblock_read_count = 16

# Number of buffers in the buffer cache.
db_block_buffers = 550

# Size in bytes of the shared pool
shared_pool_size = 9000000

#Name of another parameter file included for startup.
#ifile

log_checkpoint_interval = 8000

processes = 100

dml_locks = 200

log_buffer = 1M

sequence_cache_entries = 30

sequence_cache_hash_buckets = 23

#audit_trail = true
#timed_statistics = true

background_dump_dest = D:\oraclexe\app\oracle\product\10.2.0\server\RDBMS\trace

user_dump_dest = D:\oraclexe\app\oracle\product\10.2.0\server\RDBMS\trace

#size in bytes of oracle database blocks

compatible = 10.2.0.1.0

sort_area_size = 65536

log_checkpoint_timeout = 0

#Enable or disable automatic archiving if the database is in ARCHIVELOG mode.
#log_archive_start

#Default filename format used for archived logs.
#LOG_ARCHIVE_FORMAT

#Location of archived redo log files.
#log_archive_dest

remote_login_passwordfile = shared

#Maximum size in OS blocks of the trace files
max_dump_file_size = 10240

#Rollback segments allocated to this instance. Refer to the Oracle8 tuning
#manual for information and guidelines on determining the number and size of
#rollback segments based on the anticipated number of concurrent transactions.
#rollback_segments

Re: ORA-12560: TNS:protocol adapter error ??? [message #225699 is a reply to message #225689] Wed, 21 March 2007 01:14 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
Are you check OracleService<sid> is start ?

if not start first
on command prompt
c:\>net start OracleService<sid>

regards
Taj
icon5.gif  Re: ORA-12560: TNS:protocol adapter error ??? [message #225767 is a reply to message #225688] Wed, 21 March 2007 06:16 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Thanks Mohhamad Taj,

I tried to issue following command but its throwing error no. 183 (i.e. Cannot create the file when that file already exists):

net start OracleServiceDIABOS10

Thanks in advance,

Naimish R. Dave
icon5.gif  Re: ORA-12560: TNS:protocol adapter error ??? [message #225774 is a reply to message #225688] Wed, 21 March 2007 06:53 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
What does it means by "Cannot create the file when that file already exists", Which file its refering to ???

Re: ORA-12560: TNS:protocol adapter error ??? [message #225875 is a reply to message #225774] Wed, 21 March 2007 15:56 Go to previous messageGo to next message
salaku
Messages: 9
Registered: March 2007
Junior Member
dis you set the ORACLE_SID right

set ORACLE_SID=<SID>

or you can set it up as a environment variable using

1. Go to:
My Computer > right click > Properties > Advanced > Env variables > System

2. Add new variable

3. Enter ORACLE_SID as the variable name

4. Enter the database sid as the value
icon5.gif  Re: ORA-12560: TNS:protocol adapter error ??? [message #226634 is a reply to message #225688] Mon, 26 March 2007 00:14 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Hi,

This is the output when I fired 'oradim' command on command prompt.

D:\oraclexe\app\oracle\admin\oraXE>set ORACLE_SID=oraXE

D:\oraclexe\app\oracle\admin\oraXE>oradim -new -sid %ORACLE_SID% -intpwd hitkhit -startmode M

Instance created.
DIM-00019: create service error
O/S-Error: (OS 1062) The service has not been started.


I checked for this service on services console and it is there !!!

What should be the reason of this error?

I am following this url: http://devtime.blogspot.com/2006/01/creating-oracle-xe-database-manually.html

Naimish R. Dave
Re: ORA-12560: TNS:protocol adapter error ??? [message #226640 is a reply to message #226634] Mon, 26 March 2007 00:47 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

D:\oraclexe\app\oracle\admin\oraXE>oradim -new -sid %ORACLE_SID% -intpwd hitkhit -startmode M
Instance created.
DIM-00019: create service error
O/S-Error: (OS 1062) The service has not been started.


Its mean service is already created...

regards
Taj
Re: ORA-12560: TNS:protocol adapter error ??? [message #226643 is a reply to message #225688] Mon, 26 March 2007 01:30 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member


Finally I got Database Created message Cool

But now problem is that in Services console it still shows OracleServiceXE service running ! Service that I created just now (i.e. OracleServiceoraXE ) is not running !

How to connect with my newly created database (i.e. oraXE)?
What will be the User name and password to connect it and how to connect it?

(I have followed all the steps mentioned in article successfully.)

Naimish R. Dave
Re: ORA-12560: TNS:protocol adapter error ??? [message #227168 is a reply to message #225688] Tue, 27 March 2007 08:15 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Anyone helping me ?
Re: ORA-12560: TNS:protocol adapter error ??? [message #227171 is a reply to message #227168] Tue, 27 March 2007 08:17 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
You cann't create more than one database on single computer on XE
The third limit is that only a single XE database can run on any given computer.


http://www.oracle.com/technology/pub/articles/cunningham-database-xe.html
regards
Taj

[Updated on: Tue, 27 March 2007 08:20]

Report message to a moderator

Re: ORA-12560: TNS:protocol adapter error ??? [message #228266 is a reply to message #225688] Mon, 02 April 2007 05:59 Go to previous messageGo to next message
babai_74_cal
Messages: 6
Registered: April 2007
Location: Kolkata
Junior Member
Oracle classify this as a ‘generic protocol adapter error’.It indicates that Oracle client does not know what instance to connect to or what TNS alias to use.
Can you please check the status of the Oracle services that is created. Is it Started or Stopped? If it is stopped then start it manually i.e.
c:\Net start Oracleservice<Sid>
Then try to connect to the database.
2. Set the Oracle sid i.e.
c:\>Set oracle_sid=<SID_NAME>
Then Connect It.
3.If the database SID is changed without recreating the service then this can lead to this error. To recreate the service:
A)oradimxx -delete -sid <old-sid>
b)oradimxx -new -sid <SID> -intpwd <Password>
Then Connect the database

[Updated on: Mon, 02 April 2007 06:13]

Report message to a moderator

Re: ORA-12560: TNS:protocol adapter error ??? [message #228268 is a reply to message #228266] Mon, 02 April 2007 06:10 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Appreciate your contributions, but if you read over the previous replies, you would have noticed that this solution was already proposed.
Re: ORA-12560: TNS:protocol adapter error ??? [message #228800 is a reply to message #227171] Wed, 04 April 2007 04:40 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Hi,

Mohammad Taj wrote on Tue, 27 March 2007 08:17
Hi,
You cann't create more than one database on single computer on XE
The third limit is that only a single XE database can run on any given computer.


http://www.oracle.com/technology/pub/articles/cunningham-database-xe.html
regards
Taj


I have read this article and they have mentioned that we cannot run multiple instance of Oracle database, and here in my cas I dont want multiple instance to run on single computer, I want only one instance and that should be of my newly created database.

I have already created a new database on same computer. The only thing I dont is how to connect this newly created database ?

I have created a service for it and and when I try to run it manually or using Net command it throws above protocol error.

I hope you are getting my point.

Thanks in advance and sorry for late reply,

Naimish R. Dave
Re: ORA-12560: TNS:protocol adapter error ??? [message #228856 is a reply to message #228800] Wed, 04 April 2007 07:18 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,


When you install Oracle XE that time OracleServiceXE ( default) database creation is done.

After that you cann't create another database like ORAXE

DIM-00019: create service error
O/S-Error: (OS 1062) The service has not been started.

When you got above error it is becuase of you already have XE database.

Now you got "TNS-PROTOCOL ADAPTOR ERROR".
You should check Database Service is start "OracleServiceORAXE"

Regards
Taj
Re: ORA-12560: TNS:protocol adapter error ??? [message #229092 is a reply to message #225688] Thu, 05 April 2007 05:57 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Hi,

First of all thank you very much for guiding me.

Finally I have stopped OracleServiceXE (default) service and started OracleSerivceoraXE service (new database).

Now only one problem left is that How to connect with oraXE database? Which user should I use to connect it ?

I have tried all with system and sys and its not working. I have not created any default user while creating orXE database Sad.

Following is the database creation script:
create database oraXE
logfile group 1 ('C:\oraclexe\oradata\oraXE\redo1.log') size 10M,
group 2 ('C:\oraclexe\oradata\oraXE\redo2.log') size 10M,
group 3 ('C:\oraclexe\oradata\oraXE\redo3.log') size 10M
character set WE8ISO8859P1
national character set utf8
datafile 'C:\oraclexe\oradata\oraXE\system.dbf'
size 50M
autoextend on
next 10M maxsize unlimited
extent management local
sysaux datafile 'C:\oraclexe\oradata\oraXE\sysaux.dbf'
size 10M
autoextend on
next 10M
maxsize unlimited
undo tablespace undo
datafile 'C:\oraclexe\oradata\oraXE\undo.dbf'
size 10M
autoextend on
default temporary tablespace temp
tempfile 'C:\oraclexe\oradata\oraXE\temp.dbf'
size 10M
autoextend on;


Thanks in advance

Naimish
Re: ORA-12560: TNS:protocol adapter error ??? [message #229093 is a reply to message #225688] Thu, 05 April 2007 05:59 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Sorry forgot to mention that I am getting following error while connecting with oraXE database.

Enter user-name: system
Enter password:
ERROR:
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
Re: ORA-12560: TNS:protocol adapter error ??? [message #229098 is a reply to message #229093] Thu, 05 April 2007 06:18 Go to previous messageGo to next message
shanthkumaar
Messages: 156
Registered: February 2007
Location: india,chennai
Senior Member

hi,

Causes of ORA-27101

Unable to locate shared memory realm.

So it may be one of this

1. You may have modified your Database Parmaters (SGA Size or some other related parameter).

Action: Restore original parameters that you may have changed (manually or throught the wizard).

2. Your database instance pointer is gone. i.e. ORACLE_SID

Action: Check your environmental variables looking for the ORACLE_SID parameter. On Unix, you can type "echo $ORACLE_SID" and if it returns blank, then it has not been set. On a Windows server, right mouse click (RMC) on My Computer, select properties, select Advance Tab, click on the Environment Variable button. Look throught both sets of lists to see if ORACLE_SID is defined. In both cases if they are blank or not assigned, set it to your Oracle SID assigned to the database (this is assigned at creation time. The default sid for the first database created is ORCL).

Hope this helps!

regards
shanth.
Re: ORA-12560: TNS:protocol adapter error ??? [message #229100 is a reply to message #229098] Thu, 05 April 2007 06:44 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
shanthkumaar wrote on Thu, 05 April 2007 06:18
hi,

Causes of ORA-27101

Unable to locate shared memory realm.

So it may be one of this

1. You may have modified your Database Parmaters (SGA Size or some other related parameter).

Action: Restore original parameters that you may have changed (manually or throught the wizard).

2. Your database instance pointer is gone. i.e. ORACLE_SID

Action: Check your environmental variables looking for the ORACLE_SID parameter. On Unix, you can type "echo $ORACLE_SID" and if it returns blank, then it has not been set. On a Windows server, right mouse click (RMC) on My Computer, select properties, select Advance Tab, click on the Environment Variable button. Look throught both sets of lists to see if ORACLE_SID is defined. In both cases if they are blank or not assigned, set it to your Oracle SID assigned to the database (this is assigned at creation time. The default sid for the first database created is ORCL).

Hope this helps!

regards
shanth.


Hi,

I have checked ORACLE_SID and its having correct value, i.e. oraXE (database name).

Now I am not sure about Database Parmaters, (As long I know I have not changed any settings. Can you tell me how to check it ?

Thanks in advance

Naimish
Re: ORA-12560: TNS:protocol adapter error ??? [message #229102 is a reply to message #229098] Thu, 05 April 2007 07:16 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,

ORA-27101
It is not because of SGA ( shared pool ) parameter.

when ORA-27100 will get then it is becuase of SGA parameter.

@OP you are getting 1034 + 27101
You have to first connect with "SYSDBA" privs and startup
your database.
like
SQL>conn "/ as sysdba"
SQL>startup 


Regards
Taj


Re: ORA-12560: TNS:protocol adapter error ??? [message #229104 is a reply to message #229100] Thu, 05 April 2007 07:19 Go to previous messageGo to next message
shanthkumaar
Messages: 156
Registered: February 2007
Location: india,chennai
Senior Member

hi,

iam wrong about the SGA parameters

you have to connect using sqlplus /nolog

check this link.

hope it is of some help to you.

sorry was little slow................ Mad

@ taj>> yes Taj i was wrong i just saw it was not so.
thanks for clarifying too

regards,
shanth.

[Updated on: Thu, 05 April 2007 07:21]

Report message to a moderator

Re: ORA-12560: TNS:protocol adapter error ??? [message #229228 is a reply to message #225688] Fri, 06 April 2007 02:08 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Hi,

Thanks Taj and Shant, You both are right

I think that now I am about to start my database.

I have one more query Razz , Where should I specify that my initoraXE.ora file is on xxx location?

I am getting following error while trying to startup database.

SQL> connect / as SysDBA
Connected to an idle instance.
SQL> startup
ORA-01078: failure in processing system parameters
LRM-00109: could not open parameter file 'D:\ORACLEXE\APP\ORACLE\PRODUCT\10.2.0\
SERVER\DATABASE\INITORAXE.ORA'

Thanks in advance

Naimish R. Dave
Re: ORA-12560: TNS:protocol adapter error ??? [message #229365 is a reply to message #229228] Fri, 06 April 2007 23:46 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,

LRM-00109: could not open parameter file 'D:\ORACLEXE\APP\ORACLE\PRODUCT\10.2.0\
SERVER\DATABASE\INITORAXE.ORA'


You should check your "$ORACLE_HOME/database/spfile<sid>.ora"
"$ORACLE_HOME/database/init<sid>.ora"

Regards
Taj
Re: ORA-12560: TNS:protocol adapter error ??? [message #229506 is a reply to message #225688] Mon, 09 April 2007 01:00 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Hi,

Sad

This is what I got !!!

SQL> connect / as sysdba;
Connected to an idle instance.
SQL> startup
ORACLE instance started.

Total System Global Area 113246208 bytes
Fixed Size 1286028 bytes
Variable Size 58720372 bytes
Database Buffers 50331648 bytes
Redo Buffers 2908160 bytes
Database mounted.
ORA-01092: ORACLE instance terminated. Disconnection forced

Now what does this mean?

(This is very frustrating, can't Oracle give some easy way to create database (just like SQL Server) ???)

Thanks in advance,

Naimish Dave
Re: ORA-12560: TNS:protocol adapter error ??? [message #229509 is a reply to message #229506] Mon, 09 April 2007 01:08 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,

ORA-01092: ORACLE instance terminated. Disconnection forced

Check you alert<sid>.log file... for above error and post last few contents from alert<sid>.log.

In Oracle Manaully database is very simple process.
but you have to follow step by step.


regards
Taj
Re: ORA-12560: TNS:protocol adapter error ??? [message #229514 is a reply to message #225688] Mon, 09 April 2007 01:22 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Hi,

I think above error started after running catalog.sql, catproc.sql and pupbld.sql scripts, before issuing this script I was able to startup database !!!

Re: ORA-12560: TNS:protocol adapter error ??? [message #229516 is a reply to message #229514] Mon, 09 April 2007 01:24 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,


I think above error started after running catalog.sql, catproc.sql and pupbld.sql scripts, before issuing this script I was able to startup database !!!


Please you should check alert<sid>log file because it is generic error ... more reason behind this error.

Regards
Taj
Re: ORA-12560: TNS:protocol adapter error ??? [message #229594 is a reply to message #225688] Mon, 09 April 2007 05:58 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Starting ORACLE instance (normal)
LICENSE_MAX_SESSION = 0
LICENSE_SESSIONS_WARNING = 0
Picked latch-free SCN scheme 2
Using LOG_ARCHIVE_DEST_1 parameter default value as D:\oraclexe\app\oracle\product\10.2.0\server\RDBMS
Autotune of undo retention is turned on.
IMODE=BR
ILAT =10
LICENSE_MAX_USERS = 0
SYS auditing is disabled
ksdpec: called for event 13740 prior to event group initialization
Starting up ORACLE RDBMS Version: 10.2.0.1.0.
System parameters with non-default values:
control_files = D:\ORACLEXE\ORADATA\ORAXE\CONTROL01.CTL, D:\ORACLEXE\ORADATA\ORAXE\CONTROL02.CTL, D:\ORACLEXE\ORADATA\ORAXE\CONTROL03.CTL
db_block_size = 8192
undo_management = AUTO
db_name = oraXE
Mon Apr 09 11:22:51 2007
WARNING:Shared I/O Pool created with size=0 set size=0
PMON started with pid=2, OS id=2192
PSP0 started with pid=3, OS id=2212
MMAN started with pid=4, OS id=2216
DBW0 started with pid=5, OS id=2064
LGWR started with pid=6, OS id=440
CKPT started with pid=7, OS id=416
SMON started with pid=8, OS id=444
RECO started with pid=9, OS id=2424
MMON started with pid=10, OS id=448
Mon Apr 09 11:22:51 2007
Oracle Data Guard is not available in this edition of Oracle.
Mon Apr 09 11:22:51 2007
ALTER DATABASE MOUNT
MMNL started with pid=11, OS id=2240
Mon Apr 09 11:22:55 2007
Setting recovery target incarnation to 1
Mon Apr 09 11:22:55 2007
Successful mount of redo thread 1, with mount id 4168534603
Mon Apr 09 11:22:55 2007
Database mounted in Exclusive Mode
Completed: ALTER DATABASE MOUNT
Mon Apr 09 11:22:55 2007
ALTER DATABASE OPEN
Mon Apr 09 11:22:55 2007
Beginning crash recovery of 1 threads
Mon Apr 09 11:22:55 2007
Started redo scan
Mon Apr 09 11:22:56 2007
Completed redo scan
1 redo blocks read, 0 data blocks need recovery
Mon Apr 09 11:22:56 2007
Started redo application at
Thread 1: logseq 9, block 2, scn 103414
Mon Apr 09 11:22:56 2007
Recovery of Online Redo Log: Thread 1 Group 3 Seq 9 Reading mem 0
Mem# 0 errs 0: D:\ORACLEXE\ORADATA\ORAXE\REDO3.LOG
Mon Apr 09 11:22:56 2007
Completed redo application
Mon Apr 09 11:22:56 2007
Completed crash recovery at
Thread 1: logseq 9, block 3, scn 123416
0 data blocks read, 0 data blocks written, 1 redo blocks read
Mon Apr 09 11:22:56 2007
Thread 1 advanced to log sequence 10
Thread 1 opened at log sequence 10
Current log# 1 seq# 10 mem# 0: D:\ORACLEXE\ORADATA\ORAXE\REDO1.LOG
Successful open of redo thread 1
Mon Apr 09 11:22:56 2007
SMON: enabling cache recovery
Mon Apr 09 11:22:56 2007
Errors in file d:\oraclexe\app\oracle\product\10.2.0\server\rdbms\trace\oraxe_ora_1196.trc:
ORA-00704: bootstrap process failure
ORA-39700: database must be opened with UPGRADE option

Mon Apr 09 11:22:56 2007
Error 704 happened during db open, shutting down database
USER: terminating instance due to error 704
Mon Apr 09 11:22:57 2007
Errors in file d:\oraclexe\app\oracle\product\10.2.0\server\rdbms\trace\oraxe_pmon_2192.trc:
ORA-00704: bootstrap process failure

Mon Apr 09 11:22:57 2007
Errors in file d:\oraclexe\app\oracle\product\10.2.0\server\rdbms\trace\oraxe_reco_2424.trc:
ORA-00704: bootstrap process failure

Mon Apr 09 11:22:57 2007
Errors in file d:\oraclexe\app\oracle\product\10.2.0\server\rdbms\trace\oraxe_lgwr_440.trc:
ORA-00704: bootstrap process failure

Mon Apr 09 11:22:57 2007
Errors in file d:\oraclexe\app\oracle\product\10.2.0\server\rdbms\trace\oraxe_mman_2216.trc:
ORA-00704: bootstrap process failure

Mon Apr 09 11:22:57 2007
Errors in file d:\oraclexe\app\oracle\product\10.2.0\server\rdbms\trace\oraxe_psp0_2212.trc:
ORA-00704: bootstrap process failure

Mon Apr 09 11:22:57 2007
Errors in file d:\oraclexe\app\oracle\product\10.2.0\server\rdbms\trace\oraxe_ckpt_416.trc:
ORA-00704: bootstrap process failure

Mon Apr 09 11:22:57 2007
Errors in file d:\oraclexe\app\oracle\product\10.2.0\server\rdbms\trace\oraxe_smon_444.trc:
ORA-00704: bootstrap process failure

Mon Apr 09 11:22:58 2007
Errors in file d:\oraclexe\app\oracle\product\10.2.0\server\rdbms\trace\oraxe_dbw0_2064.trc:
ORA-00704: bootstrap process failure

Instance terminated by USER, pid = 1196
ORA-1092 signalled during: ALTER DATABASE OPEN...

[Updated on: Mon, 09 April 2007 06:02]

Report message to a moderator

Re: ORA-12560: TNS:protocol adapter error ??? [message #229622 is a reply to message #229594] Mon, 09 April 2007 07:15 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
Actually your not doing upgrade so above problem due to other reason...

Try
shutdown abort;
startup

regards
Taj
Re: ORA-12560: TNS:protocol adapter error ??? [message #231404 is a reply to message #225688] Mon, 16 April 2007 23:38 Go to previous messageGo to next message
naimish_hit
Messages: 34
Registered: March 2007
Member
Hi,

Thanks for your help,

Finally I got started my database but not with

shutdown abot;
startup

but I issued following and it worked !!!
startup upgrade

(In alert_oraxe.log it was indicating that updgrade failed)

Only one thing I did not understand that I was creating new database (not upgrading) then why oracle complained that "ORA-39700: database must be opened with UPGRADE option"!!!

Regards,

Naimish
Re: ORA-12560: TNS:protocol adapter error ??? [message #252317 is a reply to message #225688] Wed, 18 July 2007 10:48 Go to previous messageGo to next message
DAYA KIRAN
Messages: 2
Registered: July 2007
Location: ANDRA PRADESH
Junior Member

ANY BODY HELP ME FRIENDS,
I JUST INSTALED ORACLE8i RELEASED EDITION, WHEN I ENTERD SCOTT\TIGER USERNAME ,PASSWORD THEN THE FORM DISPLY ORA-2560 TNS PROTOCOL ADAPTER ERROR, PLS ANYBODY KNOW THE SOLUTION?
REPLY ME PLSSSSSSSSSSSSSSS.

[Updated on: Wed, 18 July 2007 10:51]

Report message to a moderator

Re: ORA-12560: TNS:protocol adapter error ??? [message #252362 is a reply to message #252317] Wed, 18 July 2007 12:50 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
post the lsnrctl status output?
try to connect as sys like ' / as sysdba'
Re: ORA-12560: TNS:protocol adapter error ??? [message #252368 is a reply to message #225688] Wed, 18 July 2007 13:03 Go to previous messageGo to next message
BlackSwan
Messages: 25042
Registered: January 2009
Location: SoCal
Senior Member
DreamzZ,
Responding to thread thief again/still?
Re: ORA-12560: TNS:protocol adapter error ??? [message #252371 is a reply to message #252368] Wed, 18 July 2007 13:09 Go to previous message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Embarassed
ops did i make mistake again ? Wink

Wed, 18 July 2007 09:48
Previous Topic: insufficient privileges
Next Topic: Invalid object in the OLAPSYS schema after upgrade from 10.2.0.1 to 10.2.0.3
Goto Forum:
  


Current Time: Wed Dec 07 07:10:21 CST 2016

Total time taken to generate the page: 0.19175 seconds