Home » Fusion Middleware & Colab Suite » Weblogic & Application Server » OPMN Crashes every two days - 10.1.2.2.0 AS
OPMN Crashes every two days - 10.1.2.2.0 AS [message #224873] Thu, 15 March 2007 16:34 Go to next message
alore
Messages: 2
Registered: March 2007
Junior Member
We have middle tier running on windows 2003 and infrastructure on a solaris machine . All of a sudden every couple days App server stops responding. We get a blank page. When we check opmnctl
status - it says opmn may not be up. OPmn fails to start or stop. If I go to services and try to kill the oracle asmtprocess it does not respond.

Following are the error messages in the Apache error Log

(10054)An existing connection was forcibly closed by the remote host: MOD_OC4J_0087: Got an unexpected error while calling send() to send a message to oc4j and the error code is 10054.
[Sun Mar 11 10:06:40 2007] [error] [client 10.1.2.13] [ecid: 1173636400:10.1.2.13:2164:5820:519,0] MOD_OC4J_0053: Failed to call network routine to send out an ajp13 buffer message to oc4j.
[Sun Mar 11 10:06:40 2007] [warn] [client 10.1.2.13] [ecid: 1173636400:10.1.2.13:2164:5820:519,0] MOD_OC4J_0027: Failed to send out an ajp13 message to oc4j.
[Sun Mar 11 10:06:40 2007] [error] [client 10.1.2.13] [ecid: 1173636400:10.1.2.13:2164:5820:519,0] MOD_OC4J_0026: Failed to marshal a request to ajp13 message headers or send them to the web container.
[Sun Mar 11 10:16:35 2007] [error] [client 10.1.2.13] [ecid: 1173636995:10.1.2.13:2164:3108:491,0] (10054)An existing connection was forcibly closed by the remote host: MOD_OC4J_0087: Got an unexpected error while calling send() to send a message to oc4j and the error code is 10054.
[Sun Mar 11 10:16:35 2007] [error] [client 10.1.2.13] [ecid: 1173636995:10.1.2.13:2164:3108:491,0] MOD_OC4J_0053: Failed to call network routine to send out an ajp13 buffer message to oc4j.
[Sun Mar 11 10:16:35 2007] [warn] [client 10.1.2.13] [ecid: 1173636995:10.1.2.13:2164:3108:491,0] MOD_OC4J_0027: Failed to send out an ajp13 message to oc4j.
[Sun Mar 11 10:16:35 2007] [error] [client 10.1.2.13] [ecid: 1173636995:10.1.2.13:2164:3108:491,0] MOD_OC4J_0026: Failed to marshal a request to ajp13 message headers or send them to the web container.


Please advise. I have not got any solution from Oracle regarding this.

Thanks

alore
Re: OPMN Crashes every two days - 10.1.2.2.0 AS [message #225538 is a reply to message #224873] Tue, 20 March 2007 04:59 Go to previous messageGo to next message
zeshanali76
Messages: 180
Registered: January 2006
Location: Pakistan
Senior Member

Can u define these 2 dayz i mean:

-What do u do in these 2 days?
-Network goes down?
-Any Server reboots?
-DNS Server goes down?
-Servers has DHCP Based IPs or Static IPs?
-Which applications r u running like Forms/Reports or J2EE?
-Windows 2003 Server has firewall/Kerberos enabled?
-Other applications like DHCP/DNS Domain Controllers are Ok?
-Service pack No of Windows 2003?
-Check one more thing it is also important Network Connection
service on Windows 2003 Server and on Recovery tab the
actions first, second. give the actions to restart the
service.


One more question it is not related to Application Server but I would like to ask that

-Temprature of Switches are ok? I mean heatup?

Please reply of these queries.

Zeeshan Ali Awan
zesh76@msn.com

I would wait for ur reply and please do not add me in ur MSN Messenger. It is request.
Re: OPMN Crashes every two days - 10.1.2.2.0 AS [message #225853 is a reply to message #225538] Wed, 21 March 2007 14:11 Go to previous messageGo to next message
alore
Messages: 2
Registered: March 2007
Junior Member
Hello,

Thank you for your response. Here are the answers to your queries.
We have two windows 2003 servers running middle tiers running in a load balncer mode (software load balancing using web cache of one of the windows 2003 servers to act as the load balncer), infrastructure is on a solaris machine.

Exactly every 54 hrs one of the OPMN of one of the middle tier crashes (If I have just one of the middle tier servers up the result is the same, it crashes after 54 hrs). I am trying to find if there is a setting some where. "opmn startall" does not work. I have to reboot the server and everything works fine. I can then stop or restart OPMN as needed.

We are running forms 10.1.2.2.0 and reports.

Static IP, using DNS, Win 2003 Service Pack 1. There are no server reboots. I am not sure ifthis is what you mean by network connection service (JNET ?)

Not sure about the temperatur, will have to get back to you on that.

Please advise.

Regards,
alore
Re: OPMN Crashes every two days - 10.1.2.2.0 AS [message #225968 is a reply to message #225853] Thu, 22 March 2007 02:22 Go to previous messageGo to next message
zeshanali76
Messages: 180
Registered: January 2006
Location: Pakistan
Senior Member

Hmmm...
Please check that

%ORACLE_HOME%\dcm\dcm.conf was is missing from the install.

if yes then restore it from backup (Metalink Says).

and Please break the Load Balance for some days and check. Metalink also tells that there was a bug:

10.1.2.1 4389972 Web Cache crashed, OPMN unable to restart due to orphaned processes.

Disable the Load Balance and check the dcm.conf file and I would be waiting and try to create environment for u.


Zeeshan Ali Awan
zesh76@msn.com
Re: OPMN Crashes every two days - 10.1.2.2.0 AS [message #226537 is a reply to message #224873] Sat, 24 March 2007 15:21 Go to previous messageGo to next message
zeshanali76
Messages: 180
Registered: January 2006
Location: Pakistan
Senior Member

Please check one thing more my friend. Might u have used Windows XP with FireWall Enabled. I have used and it is my experience that XP stops and closes the Network Connection Service after some dayz and effects that there is no network connection shows in Network Connections folder. U please check and monitor that may be something is going to happen like this. Please check it also.

Take care


Zeeshan Ali Awan
zesh76@msn.com
Re: OPMN Crashes every two days - 10.1.2.2.0 AS [message #234471 is a reply to message #224873] Tue, 01 May 2007 13:17 Go to previous messageGo to next message
anonymk
Messages: 1
Registered: May 2007
Location: gaithersburg
Junior Member
Hello,

All of a sudden every couple days App server stops responding. When we check opmnctl status - it says opmn may not be up. OPmn fails to start or stop. If I go to services and try to kill the oracle asmtprocess it does not respond.


Exactly every 2 days OPMN of the middle tier crashes (If I have just one of the middle tier servers up the result is the same, it crashes after 54 hrs). I am trying to find if there is a setting some where. "opmn startall" does not work. I have to reboot the server and everything works fine. I can then stop or restart OPMN as needed.

We are running 10.1.2.2.0 and reports.

Static IP, using DNS, Win 2003 Service Pack 1. There are no server reboots.
i have seen a blog in this forum exactly the same problem but could not find the solution.

anybody has any idea the solution......

Please advise.



Re: OPMN Crashes every two days - 10.1.2.2.0 AS [message #235762 is a reply to message #224873] Mon, 07 May 2007 23:17 Go to previous messageGo to next message
zeshanali76
Messages: 180
Registered: January 2006
Location: Pakistan
Senior Member

I found a solution for this please try

SYMPTOMS
If you try to set up TCP connections from ports that are greater than 5000, the local computer responds with the following WSAENOBUFS (10055) error message:
An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full.


RESOLUTION
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
The default maximum number of ephemeral TCP ports is 5000 in the products that are included in the 'Applies to' section. A new parameter has been added in these products. To increase the maximum number of ephemeral ports, follow these steps: 1. Start Registry Editor.
2. Locate the following subkey in the registry, and then click Parameters:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
3. On the Edit menu, click New, and then add the following registry entry:
Value Name: MaxUserPort
Value Type: DWORD
Value data: 65534
Valid Range: 5000-65534 (decimal)
Default: 0x1388 (5000 decimal)
Description: This parameter controls the maximum port number that is used when a program requests any available user port from the system. Typically , ephemeral (short-lived) ports are allocated between the values of 1024 and 5000 inclusive.
4. Quit Registry Editor.
Note An additional TCPTimedWaitDelay registry parameter determines how long a closed port waits until the closed port can be reused.


Re: OPMN Crashes every two days - 10.1.2.2.0 AS [message #237150 is a reply to message #224873] Sat, 12 May 2007 13:49 Go to previous message
zeshanali76
Messages: 180
Registered: January 2006
Location: Pakistan
Senior Member

I am waiting for reply that problem has been solved r not yet!

Zeeshan Ali Awan
zesh@inbox.com
Previous Topic: Error:Bigger type length than Maximum
Next Topic: Setting up Tomcat with Oracle
Goto Forum:
  


Current Time: Fri Dec 02 20:37:50 CST 2016

Total time taken to generate the page: 0.08860 seconds