Home » SQL & PL/SQL » SQL & PL/SQL » Some very strange problem
icon5.gif  Some very strange problem [message #224651] Wed, 14 March 2007 23:30 Go to next message
yugamore
Messages: 23
Registered: December 2006
Junior Member
I created a table named "load2" and loaded 40 million records in this table.
When I do select * from load2; OR
desc load2;
I get an error , Object load2 does not exist.
However when I do Select * from tabs;
I can see this table. Any idea what is the problem here? I don't want to load these many records again.

Re: Some very strange problem [message #224653 is a reply to message #224651] Thu, 15 March 2007 00:00 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10677
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
you might have created the table load2 within quotes as "load2" which is just about doing things all wrong.
You need to the table as "load2" and not load2.

[Updated on: Thu, 15 March 2007 00:00]

Report message to a moderator

Re: Some very strange problem [message #224702 is a reply to message #224653] Thu, 15 March 2007 03:31 Go to previous messageGo to next message
yugamore
Messages: 23
Registered: December 2006
Junior Member
Smile Thanks ..
Re: Some very strange problem [message #224715 is a reply to message #224651] Thu, 15 March 2007 04:08 Go to previous message
gintsp
Messages: 118
Registered: February 2007
Senior Member
And to get rid of all time referencing to "load2" instead of just load2 without quotes you can issue
ALTER TABLE "load2" RENAME TO load2;


And remember that including object name in double qoutes makes your life really harder.

Gints Plivna
http://www.gplivna.eu

[Updated on: Thu, 15 March 2007 04:09]

Report message to a moderator

Previous Topic: query help
Next Topic: Is it possible to determine if a column has been updated inside a trigger
Goto Forum:
  


Current Time: Tue Aug 22 23:32:18 CDT 2017

Total time taken to generate the page: 0.01551 seconds