Home » RDBMS Server » Server Administration » Problem with AQ sys packages while upgrading from oracle 9i to oracle 10g
Problem with AQ sys packages while upgrading from oracle 9i to oracle 10g [message #224248] Tue, 13 March 2007 09:11 Go to next message
rtouze
Messages: 2
Registered: March 2007
Junior Member
Hi everyone,

I encounter some problems while upgrading from oracle 9.2.0.8.0 to oracle 10.2.0.1.0 on a Solaris 10 system.
After running rdbms/admin/catupgrd.sql scripts, following sys objects remain invalid :

DBMS_AQ_IMPORT_INTERNAL
DBMS_AQ_SYS_EXP_INTERNAL
AQ$_AQ_EVENT_TABLE_E
DBMS_AQ_SYS_IMP_INTERNAL
AQ$_AQ_SRVNTFN_TABLE_E
DBMS_AQADM_SYS
GV_$KQRPD
GV_$KQRSD
AQ_SRVNTFN_TABLE_Q
AQ_EVENT_TABLE_Q
V_$KQRPD
V_$KQRSD

When I try to recompile some of them, I get errors like :
PACKAGE BODY SYS.DBMS_AQADM_SYS
On line: 1427
PL/SQL: ORA-00904: "TIMEZONE": invalid identifier

or

PACKAGE BODY SYS.DBMS_AQ_IMPORT_INTERNAL
On line: 135
PL/SQL: ORA-00904: "QT"."TIMEZONE": invalid identifier

I believe that everything is linked with the TIMEZONE...

My question :
Do you know if there is a way to repair my 10g DB or do I have to fix something before upgrading ?

FYI :
- I've checked the db prior the upgrade with utlu102i.sql, everything is OK
- I've checked if there were TIMESTAMP WITH TIMEZONE datatype with the utltzuv2.sql script : nothing to declare Smile
- I've run catqueue.sql and utlrp.sql several times: it does nothing...
Re: Problem with AQ sys packages while upgrading from oracle 9i to oracle 10g [message #226624 is a reply to message #224248] Sun, 25 March 2007 23:10 Go to previous messageGo to next message
nmacdannald
Messages: 460
Registered: July 2005
Location: Stockton, California - US...
Senior Member
I did the same thing on the same versions and got the same invalid objects. For me it did not matter that they were invalid.
Re: Problem with AQ sys packages while upgrading from oracle 9i to oracle 10g[Fixed] [message #226655 is a reply to message #224248] Mon, 26 March 2007 02:13 Go to previous messageGo to next message
rtouze
Messages: 2
Registered: March 2007
Junior Member
Hi,

Actually I have just fixed the problem, thanks to metalink note 386260.1.

Regards,

Edit : remove content of the note since I am not allowed to write it.


[Updated on: Mon, 26 March 2007 02:27]

Report message to a moderator

Re: Problem with AQ sys packages while upgrading from oracle 9i to oracle 10g [message #226659 is a reply to message #226655] Mon, 26 March 2007 02:16 Go to previous message
Michel Cadot
Messages: 64152
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

It is allowed to post the number of the Metalink note.
It is not allowed to post its content.

So please, post its number.

Regards
Michel
Previous Topic: PAT Sample for a Database System
Next Topic: Error while executing Dbms_Stats.GATHER_TABLE_STATS
Goto Forum:
  


Current Time: Sat Dec 10 01:32:21 CST 2016

Total time taken to generate the page: 0.05900 seconds