Home » Developer & Programmer » Forms » problem with calling reports from Forms
icon5.gif  problem with calling reports from Forms [message #223945] Mon, 12 March 2007 06:30 Go to next message
karthi_smarty04
Messages: 19
Registered: January 2007
Location: COIMBATORE
Junior Member
hi
iam trying to call a oracle report from oracle from9i.iam not getting any errors but the report is not getting opened..please help me out..
the code i have written in a when-button-pressed trigger is as follows,


declare
r varchar2(100);
RID REPORT_OBJECT;
begin
RID:=FIND_REPORT_OBJECT('REPORT9');
r:=RUN_REPORT_OBJECT(RID);
end;


In the report9's(name of the report in the object navigator)property i have set the execution mode as runtime and communication mode as asynchronous.

Re: problem with calling reports from Forms [message #223989 is a reply to message #223945] Mon, 12 March 2007 10:14 Go to previous messageGo to next message
vamsi kasina
Messages: 2107
Registered: October 2003
Location: Riyadh, Saudi Arabia
Senior Member
Quote:
RID:=FIND_REPORT_OBJECT('REPORT9');
r:=RUN_REPORT_OBJECT(RID);
Debug the code using messages.

By
Vamsi
problem with calling reports from Forms [message #224192 is a reply to message #223989] Tue, 13 March 2007 06:45 Go to previous message
karthi_smarty04
Messages: 19
Registered: January 2007
Location: COIMBATORE
Junior Member
thenks a lot..i tried it..should i mention my report server name in the property of the report
Previous Topic: date problem
Next Topic: GO_BLOCK restriction in WHEN-VALIDATE-RECORD trigger
Goto Forum:
  


Current Time: Tue Dec 06 00:05:46 CST 2016

Total time taken to generate the page: 0.11788 seconds