Home » RDBMS Server » Server Administration » segment advisor oracle 10g
icon1.gif  segment advisor oracle 10g [message #223304] Thu, 08 March 2007 07:17 Go to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
HI there,
i am running this small script to create a task through pl/sql pertaining to segment advisor but when i run the script it gives me an error that the segment advisor does not exist.. what is the problem... the pl/sql is as follows

declare
task_name varchar2(100);
task_descr varchar2(100);
object_id number;
begin
task_name := '';
task_descr := 'free space in scott.emp';
dbms_Advisor.create_Task
('Segment advisor ', :task_id, task_name,task_descr,NULL);
dbms_advisor.create_object(
task_name,'TABLE', 'SCOTT','EMP',NULL,NULL,object_id);
dbms_advisor.set_Task_parameter
(task_name,'RECOMMEND_ALL','TRUE');
DBMS_ADVISOR.EXECUTE_tASK(task_name);
end;


and the error is

ERROR at line 1:
ORA-13601: The specified Advisor Segment advisor does not exist.
ORA-06512: at "SYS.PRVT_ADVISOR", line 3665
ORA-06512: at "SYS.DBMS_ADVISOR", line 102
ORA-06512: at line 8
Re: segment advisor oracle 10g [message #223417 is a reply to message #223304] Thu, 08 March 2007 16:49 Go to previous messageGo to next message
nmacdannald
Messages: 460
Registered: July 2005
Location: Stockton, California - US...
Senior Member
I would ask 'Is the segment advisor where the system thinks it is?' Given a proper chance, computers are not often wrong.
'Are your environmentals (the ones that run when the database owner logs in) set correctly?'

[Updated on: Thu, 08 March 2007 16:53]

Report message to a moderator

Re: segment advisor oracle 10g [message #223486 is a reply to message #223417] Fri, 09 March 2007 02:59 Go to previous messageGo to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
Razz yea i totally agree with you about the correctness of computers...can u guide me how to correct them and my enterprise manager 10g is not working too... i mean when eva i start the browser and put http://comptuer-name:5500/em nothing will happen
please guide me how to correct the OS environment variables.. for it..
Thankyou
Re: segment advisor oracle 10g [message #223608 is a reply to message #223304] Fri, 09 March 2007 14:33 Go to previous messageGo to next message
nmacdannald
Messages: 460
Registered: July 2005
Location: Stockton, California - US...
Senior Member
On Solaris I had to install a new browser the view the page. What o/s are you on?
Re: segment advisor oracle 10g [message #223672 is a reply to message #223608] Sat, 10 March 2007 04:07 Go to previous messageGo to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
i am using windows xp professional edition service pack 2 and i ll soon configure enterprise linex version 10 TAroon in the next week so what should i do on windows and can u tell me a bit about configure oracle on linex
Re: segment advisor oracle 10g [message #223711 is a reply to message #223486] Sat, 10 March 2007 10:42 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
mohsinali wrote on Fri, 09 March 2007 03:59
...can u guide me how to correct them and my enterprise manager 10g is not working too... i mean when eva i start the browser and put http://comptuer-name:5500/em nothing will happen
please guide me how to correct the OS environment variables.. for it..

You need to ensure that the DB Console is started with:

C:\> set oracle_sid=<sid_name>
C:\> set oracle_home=<oracle_home>
C:\> emctl start dbconsole


Re: segment advisor oracle 10g [message #224286 is a reply to message #223711] Tue, 13 March 2007 13:59 Go to previous messageGo to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
HELLO
I am continously defining is the sid but when run the command
emctcl start dbconsole then it is saying that the environment variable oracle_sid is not defining

i am using these commmands
c:\> set oracle_sid = orcl --orcl is my database sid
c:\> set oracle_home =c:\oraHome_1
c:\> emctl start dbconsole

where am i mistaking now..
Re: segment advisor oracle 10g [message #224333 is a reply to message #224286] Tue, 13 March 2007 22:10 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
You should remove the spaces around the = sign:

C:\>set oracle_sid = orcl     <---- Incorrect

C:\>echo %ORACLE_SID%
%ORACLE_SID%

C:\>set oracle_sid=orcl       <---- Correct

C:\>echo %ORACLE_SID%
orcl
Re: segment advisor oracle 10g [message #224474 is a reply to message #224333] Wed, 14 March 2007 07:13 Go to previous messageGo to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
thankx .. it works but i am having another issue its giving me another error ...

these are the commands

C:\>set oracle_sid=orcl

C:\>emctl start dbconsole
OC4J Configuration issue. C:\oracle\product\10.1.0\Db_1/oc4j/j2ee/OC4J_DBConsole
_172.16.3.235_orcl not found.

C:\>emctl start dbconsole
OC4J Configuration issue. C:\oracle\product\10.1.0\Db_1/oc4j/j2ee/OC4J_DBConsole
_172.16.3.235_orcl not found.

where 172.16.3.235 is my local area network IP... they are using an authenticantion software i need to login there to use internet services and the browser window by which we log in cannot be close down.. Smile
Re: segment advisor oracle 10g [message #224479 is a reply to message #224474] Wed, 14 March 2007 07:20 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
Are you configure your database for enterprise manager.

you can configure through DBCA or EMCA.

if you already configure and still facing problem. ( may be becuase you change your computer name)
then you should recreate emca repository.

go through below link
hope this helps



http://dbataj.blogspot.com/2007/01/oc4j-configuration-issue.html


Taj
Re: segment advisor oracle 10g [message #224484 is a reply to message #224479] Wed, 14 March 2007 07:31 Go to previous messageGo to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
well.. i ll go through the documentation but waiting for more suggestions from the experts
Re: segment advisor oracle 10g [message #224486 is a reply to message #223304] Wed, 14 March 2007 07:32 Go to previous messageGo to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
yes i am using enterprise manager 10g
Re: segment advisor oracle 10g [message #225001 is a reply to message #223304] Fri, 16 March 2007 08:44 Go to previous messageGo to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
thankyou taj the documentation you provided helps me and now my em is working ,i need to ask you help in the code segment for segmetn advisor... i am still having the same error as i had before this configuration

declare
task_name varchar2(100);
task_descr varchar2(100);
object_id number;
begin
task_name := '';
task_descr := 'free space in scott.emp';
dbms_Advisor.create_Task
('Segment advisor ', :task_id, task_name,task_descr,NULL);
dbms_advisor.create_object(
task_name,'TABLE', 'SCOTT','EMP',NULL,NULL,object_id);
dbms_advisor.set_Task_parameter
(task_name,'RECOMMEND_ALL','TRUE');
DBMS_ADVISOR.EXECUTE_tASK(task_name);
end;

ERROR at line 1:
ORA-13601: The specified Advisor Segment advisor does not exist.
ORA-06512: at "SYS.PRVT_ADVISOR", line 3665
ORA-06512: at "SYS.DBMS_ADVISOR", line 102
ORA-06512: at line 8

y the segment advisor does not exist... what can i do to sort out this...
Re: segment advisor oracle 10g [message #226395 is a reply to message #223304] Fri, 23 March 2007 08:58 Go to previous messageGo to next message
nmacdannald
Messages: 460
Registered: July 2005
Location: Stockton, California - US...
Senior Member
This is may be due to access permission of the package. Try connect as a sys user. and give the execute privilege to package. to user= your dba <user>
Re: segment advisor oracle 10g [message #226449 is a reply to message #223304] Fri, 23 March 2007 15:31 Go to previous messageGo to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
i am logging in with the sys user account but its giving the same error again...
Re: segment advisor oracle 10g [message #226533 is a reply to message #223304] Sat, 24 March 2007 14:34 Go to previous messageGo to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
hello to all the experts

can u guys plz guide me how to turn on the media recovery functionality... i am configuring the flashback database features so when i write the command
alter database flashback on;
it gives the following error

SQL> alter database flashback on;
alter database flashback on
*
ERROR at line 1:
ORA-38706: Cannot turn on FLASHBACK DATABASE logging.
ORA-38707: Media recovery is not enabled.
Re: segment advisor oracle 10g [message #226534 is a reply to message #223304] Sat, 24 March 2007 14:57 Go to previous messageGo to next message
BlackSwan
Messages: 25045
Registered: January 2009
Location: SoCal
Senior Member
Are you incapable or unwilling to use Google yourself?
Results 1 - 8 of about 31 for ORA-38707: Media recovery is not enabled.
Are you claiming that none of the responses answers your question?
Re: segment advisor oracle 10g [message #226539 is a reply to message #226534] Sat, 24 March 2007 18:04 Go to previous messageGo to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
thankx i just turned off the archive log mode because its consuming too much space on my computer... juniors makes mistakes like i did and its part of the study... thankyou...

[Updated on: Sat, 24 March 2007 18:12]

Report message to a moderator

Re: segment advisor oracle 10g [message #226540 is a reply to message #223304] Sat, 24 March 2007 18:18 Go to previous messageGo to next message
BlackSwan
Messages: 25045
Registered: January 2009
Location: SoCal
Senior Member
You're On Your Own (YOYO)!

[Updated on: Sat, 24 March 2007 18:20] by Moderator

Report message to a moderator

Re: segment advisor oracle 10g [message #226591 is a reply to message #223304] Sun, 25 March 2007 08:11 Go to previous messageGo to next message
mohsinali
Messages: 24
Registered: December 2006
Location: KARACHI PAKISTAN
Junior Member
Embarassed

[Updated on: Sun, 25 March 2007 08:16]

Report message to a moderator

Re: segment advisor oracle 10g [message #226592 is a reply to message #226591] Sun, 25 March 2007 08:14 Go to previous message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
man i use to search answer over the ... by searching the web i found the orafaq.com ... my intention is not like dat what u stated so please... if u don wana answer any question then u don
i am surprised that ur a senior member and ur doing these kinda things here....


Don't use IM SPEAK please.



archive log mode because its consuming too much space on my computer


Your disk space is more important compare archive log files. i hope if it is PRODUCTION DATABASE then your answer is NO. then please change your archive log mode.



regards
Taj

[Updated on: Sun, 25 March 2007 08:17]

Report message to a moderator

Previous Topic: best place to put archive logs
Next Topic: installation of oracle 10g database and client
Goto Forum:
  


Current Time: Wed Dec 07 18:27:13 CST 2016

Total time taken to generate the page: 0.19747 seconds