Home » Developer & Programmer » Forms » WEB.SHOW_DOCUMENT
WEB.SHOW_DOCUMENT [message #222930] Wed, 07 March 2007 00:15 Go to next message
lakshmi surya ram
Messages: 188
Registered: June 2006
Location: HYDERABAD
Senior Member

Hi folks,
The following is the code which iam using in form to call a report. But its not working.

declare
rep_url varchar2(2000);
begin
rep_url:='/dev60cgi/rwcgi60?server=rep60_apps.11i.com&report=xx_pd_report_f.rdf'||'&desformat=htmlcss&destype=cache&u serid=apps/apps@vis''&paramform=no';
WEB.SHOW_DOCUMENT(rep_url,'_blank');
end;

Please suggest in this context.

thanks in advance,
Surya

Re: WEB.SHOW_DOCUMENT [message #222981 is a reply to message #222930] Wed, 07 March 2007 02:12 Go to previous messageGo to next message
lakshmi surya ram
Messages: 188
Registered: June 2006
Location: HYDERABAD
Senior Member

Hi Folks,
I changed my code to:
DECLARE
vrepid report_object;
vrep VARCHAR2 (100);
-- 09/08/2004 DJMartin Add WEB style report.
v_show_document VARCHAR2 (2000) := 'C:\Documents and Settings\e10093\Desktop\reports?';
v_connect VARCHAR2 (30) := 'connectionName';
-- v_report_server VARCHAR2 (30) := reportsenv_pkg.f_report_server;
v_report_server VARCHAR2 (30) := 'rep60_apps.11i.com';
BEGIN
IF GET_APPLICATION_PROPERTY (user_interface) = 'WEB'
THEN
v_show_document := v_show_document
|| v_connect
-- Report server
|| '&server='
|| v_report_server
-- Report name
|| '&report=xx.rdf'
-- Reports parameters
|| '&destype=CACHE'
|| '&desformat=HTML';
web.show_document (v_show_document);
ELSE
vrepid := FIND_REPORT_OBJECT ('REPORT1');
vrep := RUN_REPORT_OBJECT (vrepid);
web.show_document
( 'http://apps/applmgr/visappl/gl/11.5.0/reports/US'
|| SUBSTR (vrep, INSTR (vrep, '_', -1) + 1)
|| '?'
|| 'server=rep60_apps.11i.com',
'_blank'
);
END IF;
END;


Its showing inavlid report id as error.

thanks,
surya
Re: WEB.SHOW_DOCUMENT [message #225411 is a reply to message #222981] Mon, 19 March 2007 22:19 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you solved your problem?

David
Previous Topic: please help ORA-01026: multiple buffers of size > 4000 in the bind list
Next Topic: URGENT!!! FORM BUILDER WITH REPORT BUILDER
Goto Forum:
  


Current Time: Sat Dec 03 04:06:43 CST 2016

Total time taken to generate the page: 0.13107 seconds