Home » Infrastructure » Windows » oracle 10g problem
oracle 10g problem [message #222835] Tue, 06 March 2007 10:50 Go to next message
ddkdhar
Messages: 68
Registered: February 2007
Member

i have just installed 10g on windows xp sp2.
i can access my database through cmd( command prompt --ms dos)
where as
in isqlplus it returns error like
-----------------------------
ERROR - ORA-12500: TNS:listener failed to start a dedicated server process
----------------
and em page(enterprise manager) opened automatically after installation
( i clicked startup icon )
oracle asking
Host Credentials

Database Credentials
what are these credentials .please explain in detail.and also jvm(java) returned error like unable to open a file ( first time).i knoe database credentials. what are host credentials.

details about my oracle 10g


SQL> select * from v$version
2 ;

BANNER
----------------------------------------------------------------
Personal Oracle Database 10g Release 10.1.0.2.0 - Production
PL/SQL Release 10.1.0.2.0 - Production
CORE 10.1.0.2.0 Production
TNS for 32-bit Windows: Version 10.1.0.2.0 - Production
NLSRTL Version 10.1.0.2.0 - Production


operating system windows xp sp2
java 2 platform standard edition
Version 1.5.0 (build 1.5.0_11-b03)

thank you all


[Updated on: Tue, 06 March 2007 11:01]

Report message to a moderator

Re: oracle 10g problem [message #222852 is a reply to message #222835] Tue, 06 March 2007 13:16 Go to previous messageGo to next message
Frank Naude
Messages: 4502
Registered: April 1998
Senior Member
Quote:
ORA-12500: TNS:listener failed to start a dedicated server process


Check you listener.log file for error details. The most likely scenario is that your server was too busy/resource constrained to start another process.
Re: oracle 10g problem [message #222919 is a reply to message #222835] Tue, 06 March 2007 23:38 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

HI,

http://dbataj.blogspot.com/2007/03/ora-12500.html


hope this helps
Taj
Re: oracle 10g problem [message #223049 is a reply to message #222835] Wed, 07 March 2007 06:38 Go to previous messageGo to next message
ddkdhar
Messages: 68
Registered: February 2007
Member

06-MAR-2007 22:18:37 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=))(SERVICE_NAME=oracle)) * (ADDRESS=(PROTOCOL=tcp)(HOST=192.168.60.95)(PORT=3171)) * establish * oracle * 12500
TNS-12500: TNS:listener failed to start a dedicated server process
TNS-12537: TNS:connection closed
TNS-12560: TNS:protocol adapter error
TNS-00507: Connection closed
32-bit Windows Error: 109: Unknown error



above errors showing inlistener.log what to do now
Re: oracle 10g problem [message #223052 is a reply to message #222835] Wed, 07 March 2007 06:55 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
what are host credentials.

You windows ( OS) HOST NAME AND PASSWORD.
and OS user you have to grant LOGON AS AN BATCH JOB privs.
start > controlpanel > administrative tools > user assignment > LOGON AS AN BATCH JOB.



TNS-12500: TNS:listener failed to start a dedicated server process
TNS-12537: TNS:connection closed
TNS-12560: TNS:protocol adapter error
TNS-00507: Connection closed
32-bit Windows Error: 109: Unknown error


In your OS you already install oracle 9i. if yes then just stop oracle 9i listener and start and use only oracle 10g listener.

TNS-12500: TNS:listener failed to start a dedicated server process
 TNS-12537: TNS:connection closed
  TNS-12560: TNS:protocol adapter error
   TNS-00507: Connection closed
    32-bit Windows Error: 109: Unknown error

I get this error when I start 9.2 TNS listener to serve a 10g database and
attempt to connect to the 10g database. The fix is simply to use 10g listener.

http://rootshell.be/~yong321/oranotes/12500.txt


REGARDS
Taj
Re: oracle 10g problem [message #223057 is a reply to message #222835] Wed, 07 March 2007 07:21 Go to previous messageGo to next message
ddkdhar
Messages: 68
Registered: February 2007
Member

this is also showing when i start lsnrctl

C:\Documents and Settings\dharanidhar>lsnrctl status

LSNRCTL for 32-bit Windows: Version 10.1.0.2.0 - Production on 07-MAR-2007 18:43
:14

Copyright (c) 1991, 2004, Oracle. All rights reserved.

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC)))
TNS-12541: TNS:no listener
TNS-12560: TNS:protocol adapter error
TNS-00511: No listener
32-bit Windows Error: 2: No such file or directory
Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=karimojj-c876e5)(PORT=15
21)))
TNS-12541: TNS:no listener
TNS-12560: TNS:protocol adapter error
TNS-00511: No listener
32-bit Windows Error: 61: Unknown error
Re: oracle 10g problem [message #223069 is a reply to message #223057] Wed, 07 March 2007 07:52 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
YOu do only one thing.

delete all configuration files.
1.listener.ora, tnsnames.ora , sqlnet.ora

and create all files through NETCA.

first create listner.ora
second create sqlnet.ora
third create tnsnames.ora

You should be take backup of all three configuration files before delete.


http://dbataj.blogspot.com/2007/02/ora-12162-on-linux-after-oracle.html

regards
Taj
Re: oracle 10g problem [message #223070 is a reply to message #222835] Wed, 07 March 2007 07:54 Go to previous messageGo to next message
ddkdhar
Messages: 68
Registered: February 2007
Member

taj please explain step by step .
i stopped my 9i listener and even now its not working. and for my os there is no password . what to do now .please explain in detail
Re: oracle 10g problem [message #223071 is a reply to message #223070] Wed, 07 March 2007 07:55 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
go through my mention link in previous post i was mention all step for how to create all configuration files.


if you have any problem please let us know.


regards
Taj
Re: oracle 10g problem [message #223090 is a reply to message #222835] Wed, 07 March 2007 08:54 Go to previous messageGo to next message
ddkdhar
Messages: 68
Registered: February 2007
Member

taj

net configuration finished successfully (test connection also).but one problem

isqlplus error again after login

Error
ERROR - ORA-12545: Connect failed because target host or object does not exist

[Updated on: Wed, 07 March 2007 09:08]

Report message to a moderator

Re: oracle 10g problem [message #223093 is a reply to message #223090] Wed, 07 March 2007 09:20 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
ERROR - ORA-12545: Connect failed because target host or object does not exist

Actually i am too luzy i know this happen... and i want to alert about this error ...but forget to mention in my last post any way.

ORA-12545 >>
Suggestion :
1.Always use IP ADDRESS instead of COMPUTER NAME.
2.Change computer name alwarid-Oa49914 to alwarid-taj.


http://dbataj.blogspot.com/2007/03/tns-12545.html


REGARDS
Taj
Re: oracle 10g problem [message #223094 is a reply to message #222835] Wed, 07 March 2007 09:25 Go to previous messageGo to next message
ddkdhar
Messages: 68
Registered: February 2007
Member

this is standalone system and my ip address is dynamic .can i add this ip to netconfig
it is asking enter valid service name if i enter 192.168.60.92
and in your blog
Suggestion :
1.Always use IP ADDRESS instead of COMPUTER NAME.
2.Change computer name alwarid-Oa49914 to alwarid-taj.

that means change computer name in my computer or change service name in oracle

[Updated on: Wed, 07 March 2007 09:32]

Report message to a moderator

Re: oracle 10g problem [message #223097 is a reply to message #223094] Wed, 07 March 2007 09:32 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
it is asking enter valid service name if i enter 192.168.60.92
You should try if not successed then use your correct computer name.

if not solve then let us know
regards
Taj
Re: oracle 10g problem [message #223103 is a reply to message #223097] Wed, 07 March 2007 09:52 Go to previous messageGo to next message
ddkdhar
Messages: 68
Registered: February 2007
Member

taj
thank a lot for giving immediate response .at last succeded
but one thing
i always changes my ip ( ie LAN Address regurly) any problem in future .and EM page automatically changed without asking host crdentials after logon as sys
this page giving brief information about database( user sys) showing invalid objects and severity.
could please drop some links to understand things in em page and it looks good



and again thank you very much taj for guiding

[Updated on: Wed, 07 March 2007 09:54]

Report message to a moderator

Re: oracle 10g problem [message #223106 is a reply to message #223103] Wed, 07 March 2007 10:06 Go to previous message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,

i always changes my ip ( ie LAN Address regurly) any problem in future

Yes it should be problem with you em respository.


you should configure permanent ip address and hostname for your computername.

and after that configure OEM repository.

go through below link about oem repository configuration.

http://www.oracle.com/pls/db102/portal.portal_db?selected=21


http://dbataj.blogspot.com/2007/01/oc4j-configuration-issue.html
http://dbataj.blogspot.com/search/label/EMCA


and again thank you very much taj for guiding
You'r most welcome !!!

regards
Taj

[Updated on: Wed, 07 March 2007 10:07]

Report message to a moderator

Previous Topic: How can I login as SYSDBA in C#
Next Topic: odbc call oracle instant client
Goto Forum:
  


Current Time: Thu Dec 08 14:12:46 CST 2016

Total time taken to generate the page: 0.07611 seconds