Home » RDBMS Server » Server Administration » dbms_stats problem
dbms_stats problem [message #221427] Mon, 26 February 2007 13:28 Go to next message
Messages: 97
Registered: June 2005
Dear All, We got a big Fact Table which is based on range partition and then subpartitioned by LIST. This table has 14 Local indexes. I can run the dbms_stats on the indexes and no problem. However when I run the dbms_stats on the table, it spits out error:

ORA-08103: object no longer exists
ORA-06512: at "SYS.DBMS_STATS", line 10502
ORA-06512: at "SYS.DBMS_STATS", line 10516

How it is possible when I can get the count(*) from the same table, describe the same table and even collect statistiscs on its indexes.

I tried to run the OLD analyze command and gets the similar error message. I did run the analyze command for validate structure and it gives also the error message. The database is running on and it is in solaris 9.0. Has any one experienced similar trouble?

Any suggestion would be appreciated.


Re: dbms_stats problem [message #221434 is a reply to message #221427] Mon, 26 February 2007 13:47 Go to previous message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
There are a few known quirks around this.
Try a higher sampling size

If this succeeds, it is a known bug. Raise a TAR.
Previous Topic: Help meee
Next Topic: How complex is Oracle 10g Server Administration
Goto Forum:

Current Time: Thu Oct 27 00:14:19 CDT 2016

Total time taken to generate the page: 0.08331 seconds