Home » Developer & Programmer » Forms » Library procedure not recognised
Library procedure not recognised [message #221330] Mon, 26 February 2007 06:00 Go to next message
oracleraj.s
Messages: 13
Registered: February 2007
Junior Member
Hi,

I have a procedure in a library which has been called somewhere in the form. Now i have compiled the form successfully. No errors were thrown. But when i run the application, the actually functionality of the library procedure is not working i.e, i think the lib proc is not called at all. Instead when i localised the lib proc, it is working fine.

Why??

Query me if my requiremen is not clear. But i face this problem in many forms n needs to be sorted out asap.

thanx in adv

[Updated on: Mon, 26 February 2007 07:12]

Report message to a moderator

Re: Library procedure not recognised [message #222362 is a reply to message #221330] Sat, 03 March 2007 05:42 Go to previous messageGo to next message
oracleraj.s
Messages: 13
Registered: February 2007
Junior Member
oracleraj.s wrote on Mon, 26 February 2007 06:00
Hi,

I have a procedure in a library which has been called somewhere in the form. Now i have compiled the form successfully. No errors were thrown. But when i run the application, the actually functionality of the library procedure is not working i.e, i think the lib proc is not called at all. Instead when i localised the lib proc, it is working fine.

Why??

Query me if my requiremen is not clear. But i face this problem in many forms n needs to be sorted out asap.

thanx in adv



Iam not getting any replies to this question?? Iam doubting whether it is as tough to answer or quite silly to ask or if the Q itself is not understandable. Pls let me know abt this...
Re: Library procedure not recognised [message #222410 is a reply to message #222362] Sun, 04 March 2007 03:19 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
You say you THINK it is not executed. First make sure you know whether or not it is executed.
Then, if you KNOW it is not, find out why. If there is no error thrown, the calling procedure in your form can find a procedure with the given name. (either in your form, or in the library or in the database), so you go debug your calling procedure to see if it gets to the point where the procedure should be called.
If you are certain the procedure is called, find out where it gets it from.
Look in your FORMS<xx>_PATH for compiled libraries (.plx), because forms first checks the entire forms-path for plx before searching for a pll.

good luck and please let us know if this solves your problem.
Re: Library procedure not recognised [message #222411 is a reply to message #222410] Sun, 04 March 2007 04:05 Go to previous messageGo to next message
oracleraj.s
Messages: 13
Registered: February 2007
Junior Member
Dear Frank,

Thanx for the efforts. But still i can say 100% that there is no such proc elsewhere other than in the library. I have tried giving some disp alert in the library procedure and run my form. But those alert are not being displayed. It means what ?? Whether that library procedure is not being executed (Even though it has been called). Rather if i pull the lib proc to my local everything goes fine.

Pls find attached the attached proc.txt file for more clarity.

I feel there is no mistake from my side, but where is the problem...

Thanx
  • Attachment: Proc.txt
    (Size: 6.12KB, Downloaded 224 times)
Re: Library procedure not recognised [message #222418 is a reply to message #222411] Sun, 04 March 2007 09:04 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
Did you check if you have a .plx?
Re: Library procedure not recognised [message #225399 is a reply to message #222418] Mon, 19 March 2007 20:03 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you solved your problem?

What version of Forms are you using? Have you recently moved from Forms 4.5 to 6i or 9i/10g? Have you added new items to the library? Did you normally do a Ctrl-K (Compile) and a Ctrl-T (Generate)? For Forms 6i and higher ALWAYS do a Ctrl-Shft-K (Compile All) and then Ctrl-T (Generate). Close form builder, open it, connect, make sure there are no object libraries being opened automatically, open the library, do Compile All and Generate, save and close the library. Open the form and do Compile All and Generate then save and close, or do a batch compile and generate.

David
Re: Library procedure not recognised [message #225761 is a reply to message #225399] Wed, 21 March 2007 05:33 Go to previous messageGo to next message
oracleraj.s
Messages: 13
Registered: February 2007
Junior Member
Hi Martin,

I tried all these scenarios, still i could not succeed. As of now i have pulled down the the procedure to my local and working out. But still the problem lies some where else???

Thanx for your time.

Rajasekaran.S
3i-infotech
Chennai
Re: Library procedure not recognised [message #225911 is a reply to message #225761] Wed, 21 March 2007 22:46 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I asked three question. Please answer them.

David
Previous Topic: Create a Form to Open Read Form
Next Topic: Customized LOGON Form
Goto Forum:
  


Current Time: Wed Dec 07 20:21:50 CST 2016

Total time taken to generate the page: 0.12238 seconds