Home » RDBMS Server » Networking and Gateways » ORA-29260: network error: TNS:lost contact
ORA-29260: network error: TNS:lost contact [message #220050] Sun, 18 February 2007 02:51 Go to next message
Messages: 5
Registered: November 2006
Location: amman
Junior Member


i'm using utl_tcp to open a connection in my code and login to that connection, then i use a loop to wait the message from the client to send the command using oracle pipes, but some times i got the error message ORA-29260: network error: TNS:lost contact, is it a network error, i need to make sure that this is a network error or some other things.

part of the code

c := UTL_TCP.open_connection (remote_host=> Pipaddress,
remote_port=> Pportnumber,

-- login
ret_val := UTL_TCP.write_line (c,'LOGIN:' || Puser|| ',' || Ppass|| ';');
DBMS_PIPE.UNPACK_MESSAGE (his_msg_params);
ret_val := UTL_TCP.write_line (c, his_msg_cmd || ':' || his_msg_params || ';');
ret_val := UTL_TCP.write_line (c, 'LOGOUT:;');
UTL_TCP.close_connection (c);

Re: ORA-29260: network error: TNS:lost contact [message #220067 is a reply to message #220050] Sun, 18 February 2007 09:38 Go to previous messageGo to next message
Messages: 24963
Registered: January 2009
Location: SoCal
Senior Member
29260, 00000, "network error: %s"
// *Cause: A network error occurred.
// *Action: Fix the network error and retry the operation.
Re: ORA-29260: network error: TNS:lost contact [message #220440 is a reply to message #220067] Tue, 20 February 2007 12:53 Go to previous message
andrew again
Messages: 2577
Registered: March 2000
Senior Member
I assume you aren't calling this thing in a loop. See if there's a time correlation between when it works and when it doesn't. Maybe a firewall timeout issue on the open connection?
Previous Topic: net8 easy configuration does not work
Next Topic: RE: ORA-03106: fatal two-task communication protocol error
Goto Forum:

Current Time: Tue Oct 25 23:57:52 CDT 2016

Total time taken to generate the page: 0.05650 seconds