Home » RDBMS Server » Server Administration » ORA-0904 after migration workbench from Sybase to Oracle HELP
ORA-0904 after migration workbench from Sybase to Oracle HELP [message #218054] Tue, 06 February 2007 10:32 Go to next message
Teresa
Messages: 36
Registered: May 2002
Member
Hi

After a oracle migration workbench from sybase to oracle some table columns have a "_" but in sybase we dont have the "_" how can I get ride of them? this is from sybase 12.0 to oracle 10gR2 on solaris 5.8
Thank You
Teresa
Re: ORA-0904 after migration workbench from Sybase to Oracle HELP [message #218114 is a reply to message #218054] Tue, 06 February 2007 20:36 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Are these objects in question Sybase temporary tables or reserved words?
Re: ORA-0904 after migration workbench from Sybase to Oracle HELP [message #218245 is a reply to message #218114] Wed, 07 February 2007 08:06 Go to previous messageGo to next message
Teresa
Messages: 36
Registered: May 2002
Member
This are permant tables from sybase, but the issue is not consistent, sometimes copies the tables with a "_" other times they are fine,
Re: ORA-0904 after migration workbench from Sybase to Oracle HELP [message #218297 is a reply to message #218245] Wed, 07 February 2007 11:48 Go to previous message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
If you can't resolve the problem during the migration, then you could simply rename the tables once they are in Oracle with:

alter table <bad_table_name> rename to <good_table_name>;

You'll have to check any of the existing code for this name change too.
Previous Topic: opatch lsinventory fails with 72
Next Topic: Oracle10g+APEX+HTTP Server
Goto Forum:
  


Current Time: Thu Dec 08 08:37:59 CST 2016

Total time taken to generate the page: 0.09096 seconds