Home » Developer & Programmer » Forms » oracle.forms.webutil.CApiFunctions bean not found.
icon4.gif  oracle.forms.webutil.CApiFunctions bean not found. [message #217893] Tue, 06 February 2007 00:32 Go to next message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

Hi all,

OS-->WinXP
Forms-->Forms 10g Release 2.

I have a form which calls dll file in which 'C' code is there, which retrieves the pdf file from database & that retrieved file(pdf) want to display, its displaying locally.
Here also i got the same problem, i saw in forum that we need to Concatenate
?Config=webutil to Application Server URL. Then it is working fine. And Here my Application Server URL was like this http://anilmk.spanservices.com:8890/forms/frmservlet @ that time giving the above error, when i changed the URL like this http://anilmk.spanservices.com:8890/forms/frmservlet?config=webutil, working fine locally.

But now we have a server in which we moved our all forms, reports & dll files but here once again i am getting same error But now the URL is like http://IP Address/forms/frmservlet?config=nnpm, here i changed to http://IP Address/forms/frmservlet?config=webutil then gave a error like
500 Internal Server Error
Forms Servlet Error.
Missing or invalid value for baseHTML parameter.
Please check the servlet configuration to make sure this value specifies a valid file.
Next i changed to http://IP Address/forms/frmservlet?config=nnpm/webutil, then it displayed some test.fmb which comes defaultly after installing the Forms 10g.
[ oracle.forms.webutil.CApiFunctions bean not found.
WEBUTIL_c_API.REGISTER_FUNCTION will not wotk ]
Are anyone know, please suggest me what should i do to work.

Thanks & Regards
Anil

[Updated on: Tue, 06 February 2007 00:36]

Report message to a moderator

Re: oracle.forms.webutil.CApiFunctions bean not found. [message #217975 is a reply to message #217893] Tue, 06 February 2007 04:42 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
What operating system is your Application Server running?

David
Re: oracle.forms.webutil.CApiFunctions bean not found. [message #217995 is a reply to message #217975] Tue, 06 February 2007 05:38 Go to previous messageGo to next message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

Server OS is Windows Server 2003

Anil

[Updated on: Tue, 06 February 2007 05:39]

Report message to a moderator

Re: oracle.forms.webutil.CApiFunctions bean not found. [message #218031 is a reply to message #217995] Tue, 06 February 2007 08:23 Go to previous messageGo to next message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

Hi david,

I don't think the problem could because of Operating System, as i said when i ran the form in address bar of explorer i saw http://anilmk.spanservices.com:8890/forms/frmservlet & gave the below error message
oracle.forms.webutil.CApiFunctions bean not found.
WEBUTIL_c_API.REGISTER_FUNCTION will not wotk

But when i changed in Forms Builder-->Preferences-->Runtime-->Application Server URL set by pressing the button Reset To Default to that address concatenated the string ( ?config=webutil) then the form worked locally i mean the form is able to use all the functions of WebUtil Package.


Now we moved all forms to Server(OS-->Windows Server 2003).
All the forms are working except the forms which are using the WebUtil functions and in address bar of explorer i am getting the address as
http://IP Address:Port/forms/frmservlet?config=some string(nnpm)

But the when i changed to
http://IP Address:Port/forms/frmservlet?config=webutil
Given an Internal Server Error 500

Then once again changed the address to
http://IP Address:Port/forms/frmservlet?config=nnpm||webutil
Then it called the Test.fmb which comes after installing the 10g
As compared with first locally there i didn't have any string after http://IP Address:Port/forms/frmservlet thats y i concatenated the ?config=webutil & i could able to call the webutil functions But in second(which has Remote Server) in that
address was http://IP Address:Port/forms/frmservlet?config=nnpm
Is there any way to attach string "webutil" to the below address
http://IP Address:Port/forms/frmservlet?config=nnpm
And here i tried
http://IP Address:Port/forms/frmservlet?config=nnpm/webutil,
http://IP Address:Port/forms/frmservlet?config=nnpm||'webutil'
None of these worked.
Please give me some suggestion to do, i will go through those & try.I am waiting for your response.


Thanks
Anil

[Updated on: Tue, 06 February 2007 08:25]

Report message to a moderator

Re: oracle.forms.webutil.CApiFunctions bean not found. [message #218103 is a reply to message #218031] Tue, 06 February 2007 18:42 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you installed webutil on the Application Server?

David
Re: oracle.forms.webutil.CApiFunctions bean not found. [message #218143 is a reply to message #218103] Wed, 07 February 2007 00:02 Go to previous messageGo to next message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

The WebUtil is in-built option which comes after installing the Forms 10g Release2 And i checked the once again in Server system.
The webutil is been already there in 10g Release, once again i checked by reading the WebUtil pdf file. I don't think something is been missed in Server.
Please suggest me, what to do next.


Anil
Re: oracle.forms.webutil.CApiFunctions bean not found. [message #218378 is a reply to message #218143] Wed, 07 February 2007 23:23 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Please review the formsweb.cfg that you have on your PC and on the AS. I think you have a typo somewhere in 'nnpm' or you do not have the webutil bits and pieces as part of its path strings.

David

Upd=mods: Lots of typos. Sorry.

[Updated on: Sun, 11 February 2007 17:28]

Report message to a moderator

Re: oracle.forms.webutil.CApiFunctions bean not found. [message #218498 is a reply to message #218378] Thu, 08 February 2007 07:56 Go to previous messageGo to next message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

Hi David,
I tried the like below
http://IP Address:Port/forms/frmservlet?form=formname&config=webutil
Now its working fine.Here all the forms are reading from Server System.
But i have been strucked into another problem, here as similar to forms in my application i am using the function WebUtil_C_Api to invoke the .dll file which will exporting the pdf file into Local System, but i want it to be exported into the Server system. Is there any other way to do it.



Thanks
Anil


[Updated on: Thu, 08 February 2007 08:18]

Report message to a moderator

Re: oracle.forms.webutil.CApiFunctions bean not found. [message #218876 is a reply to message #218498] Sun, 11 February 2007 17:48 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Are you using the 'host' command? Please post your code.

David
Re: oracle.forms.webutil.CApiFunctions bean not found. [message #219167 is a reply to message #218876] Tue, 13 February 2007 08:13 Go to previous messageGo to next message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

No, i didn't use the host command.
1==>
Here i used the Client_Host command & the way i used in my application form is like,
CLIENT_HOST('C:\Program Files\Adobe\Acrobat 7.0\Reader\AcroRd32.exe '||fname);
And AcroRd32.exe is the Acrobat Reader's .exe file to call Acrobat Reader.

2==>
And another problem as i said earlier that, i am using the WebUtil_C_Api to call 'C' function (.dll file) which connect to my database & retrieves the .PDF file contents into variable and from that variable the data will be copied into creating new file and the new file will be created on desktop of their corresponding user


But my problem is to create the file in Server System and contents of .PDF file read from database should be written into that New file created in Server System.

3==>
And another problem is .dll file read from Server System only not from Local System.
If so many users access my application from their system through web,the common file i.e. .dll file should be read from Server System only.



David if you have any solution or suggestion to the problem which i mentioned above please tell me.



Anil
Re: oracle.forms.webutil.CApiFunctions bean not found. [message #224897 is a reply to message #219167] Thu, 15 March 2007 18:54 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you solved your problem?

David
Re: oracle.forms.webutil.CApiFunctions bean not found. [message #226698 is a reply to message #224897] Mon, 26 March 2007 04:14 Go to previous messageGo to next message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

Hi David,

The problem which i mentioned above, not yet been resolved.


==>Here the problem i am facing is, when i click on a btton(Edit File), which will retrieve the .pdf file from Database, for that purpose we are using WebUtil_C_Api(which will call .DLL file And the .Dll file had a codings to check the selected file in database if present copy corresponding .pdf file onto the the desktop)
But the .DLL file i kept in Application Server. Whenever, user who wants to see the attachments, the .DLL file should be read from Application Server only, why because the there might be so many users using the application and the user might connect to my application through any system. So i want to keep the .DLL file constantly in Application Server.
Do you have any solution or suggestion to rectify the above problem.


Regards
Anil MK
Re: oracle.forms.webutil.CApiFunctions bean not found. [message #226939 is a reply to message #226698] Tue, 27 March 2007 00:16 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I just had a look at http://www.orafaq.com/forum/m/83895/67467/?srch=host+pdf#msg_83895 where it is suggested to use "WEB.SHOW_DOCUMENT('http://host/xyz.pdf')". Would this work for you?

David
Re: oracle.forms.webutil.CApiFunctions bean not found. [message #227475 is a reply to message #226939] Wed, 28 March 2007 06:03 Go to previous messageGo to next message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

Hi David,

Major problem is to call the .DLL file from Application Server.
I kept the .DLL file in some directory of Application Server & i
am calling shown below

Declare
f_handle WEBUTIL_C_API.FUNCTIONHANDLE;
args Webutil_c_api.parameterlist;
param1 Webutil_c_api.ParameterHandle;
param2 Webutil_c_api.ParameterHandle;
param3 Webutil_c_api.ParameterHandle;
Begin
f_handle := WEBUTIL_C_API.register_function('C:\Dir\file_attachment_ffi.dll','file_att_lob_export');

..........
End;
And passing some parameters
Its Working in local System(2-Tier), if i won't connect to Application Server with same calling method.

The path which i mentioned in calling .DLL file is wrong or do i need to give Application Server IP Address if so, how to give the IP Address(Ip Address bcz i tried with IP Address of Application Server also).

Please reply me if you have any idea/suggestion to be followed.


Regards
Anil MK





Re: oracle.forms.webutil.CApiFunctions bean not found. [message #227643 is a reply to message #227475] Wed, 28 March 2007 20:15 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Sorry, I have no idea.

You should consider raising a TAR with Oracle.

David
Re: oracle.forms.webutil.CApiFunctions bean not found. [message #357539 is a reply to message #227475] Wed, 05 November 2008 17:00 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Did you ever solve your problem?

David
Re: oracle.forms.webutil.CApiFunctions bean not found. [message #511804 is a reply to message #217893] Wed, 15 June 2011 03:51 Go to previous message
1983jignesh
Messages: 8
Registered: February 2010
Location: Oman
Junior Member

Hi Anil

I am facing the same problem . Can i have solution for the same.

Jignesh
Previous Topic: handle huge number of rows in data block
Next Topic: Compressed mode using text_io
Goto Forum:
  


Current Time: Sun Dec 04 18:25:59 CST 2016

Total time taken to generate the page: 0.08285 seconds