Home » Non-English Forums » Japanese » Japanese Oracle upgrade from 7 to 9i (merged)
Japanese Oracle upgrade from 7 to 9i (merged) [message #57431] Mon, 16 June 2003 01:57 Go to next message
albert cheung
Messages: 2
Registered: June 2003
Junior Member
Sirs,

I hope I am not asking a very stupid question.
I had a Japanese language Window NT4 server running Oracle 7, the server is too old and now I want to put in a new/fast server that run Japanese Language W2K with Oracle 9i, I heard that I need to convert my oracle database to 8 first and then 9i, it that true? Can I convert my Oracle Database from 7 directly to 9i to make life easier... is that any helpful web link you recommended? Any risk or I should ask how risk the job will be?

regards

albert cheung
Japanese Oracle upgrade from 7 to 9i [message #57432 is a reply to message #57431] Mon, 16 June 2003 02:12 Go to previous messageGo to next message
albert cheung
Messages: 2
Registered: June 2003
Junior Member
Dear sirs,

I had a 3 years old Japanese NT4 server with Oracle 7 and now I wish to put in a new/faster W2K server with Oracle 9i. I heard that I need to upgrade my Oracle Database from 7 to 8 first and then to 9i. Please let me know how true it is? Can I simply upgrade my Oracle database from 7 to 9i that makes life easier? is there any web link that can help me on this as well.

Please advise.

albert cheung
Re: Japanese Oracle upgrade from 7 to 9i [message #57435 is a reply to message #57431] Mon, 16 June 2003 05:02 Go to previous messageGo to next message
Maaher
Messages: 7034
Registered: December 2001
Senior Member
Do an export of the v7 database (using v7 export utility) and import in the 9i database (using 9i import utility). I believe Metalink (metalink.oracle.com) can provide more info.

MHE
Re: Japanese Oracle upgrade from 7 to 9i [message #57458 is a reply to message #57432] Tue, 17 June 2003 07:30 Go to previous message
Sanjay
Messages: 236
Registered: July 2000
Senior Member
No you cannot upgrade Oracle7 to Oracle9 directly

Read .... from Oracle Doc

Upgrade to Oracle9.2

If your old release version is 8.0.5 or less (i.e 8.0.4 or 8.0.3), then direct upgrade is NOT supported. You must first upgrade this version to 8.0.6. After the upgrade to 8.0.6 or your version IS 8.0.6 or higher, you can directly upgrade your database to 9i.

Upgrade path for Oracle 8i:
If your old release version is 8.1.5 or 8.1.6, then direct upgrade to Oracle 9.2 is NOT supported. You must first upgrade this version to 8.1.7. After the upgrade to 8.1.7 or your version IS 8.1.7, you can directly upgrade your database to Oracle 9.2. However, if your target release is 9.0.1, direct upgrade from 8.1.5 and 8.1.6 is supported.

If your old release is 8.0.5 or less, look at [[NOTE:133920.1]] for manual upgrading the database to 8.0.6 or higher.

Table 2-1 in Chapter 2: Preparing to Upgrade, Section 'Determine Your Upgrade Path to the New Release" of the Oracle 9i Database Migration Guide Release 2 (9.2) also summarises information about supported direct upgrade paths.
Previous Topic: SQL*plus behaviour with Japanese data
Next Topic: Japanese Speaking PL/SQL Developer needed
Goto Forum:
  


Current Time: Sat Apr 19 13:19:58 CDT 2014

Total time taken to generate the page: 0.08073 seconds