Home » SQL & PL/SQL » SQL & PL/SQL » Databae connecting problem after creating the trigger-reg
Databae connecting problem after creating the trigger-reg [message #216099] Thu, 25 January 2007 00:27 Go to next message
sambaponnekanti
Messages: 9
Registered: January 2007
Location: Hyderabad
Junior Member



Dear friends

I created one trigger "after logon on database" trigger was created successfully. After that i exit from all the users & again i am trying to connect any user.At that time my trigger was fired and it won't accept to logon any user.

now how to connect database to drop that trigger.

plz reply immediatly .

Thanks & Regards
Samba


Re: Databae connecting problem after creating the trigger-reg [message #216104 is a reply to message #216099] Thu, 25 January 2007 00:36 Go to previous messageGo to next message
Barbara Boehmer
Messages: 8635
Registered: November 2002
Location: California, USA
Senior Member
Connect as SYS or SYSTEM. Such triggers do not apply to those, for just this reason, so you can fix things, if you end up in such a situation.
Re: Databae connecting problem after creating the trigger-reg [message #216106 is a reply to message #216104] Thu, 25 January 2007 00:41 Go to previous messageGo to next message
sambaponnekanti
Messages: 9
Registered: January 2007
Location: Hyderabad
Junior Member


Hi

Already ready i am tried to connected to both the users friend


actually i am giving the following condition in trigger.

if username='SCOOT' and upper(program) like 'SQL%' then
Raise_application_error(-20001,'some message');
end if;


Thanks & regards,
Samba.

Re: Databae connecting problem after creating the trigger-reg [message #216109 is a reply to message #216106] Thu, 25 January 2007 00:54 Go to previous messageGo to next message
Barbara Boehmer
Messages: 8635
Registered: November 2002
Location: California, USA
Senior Member
Did you try to connect SYS AS SYSDBA?
Re: Databae connecting problem after creating the trigger-reg [message #216110 is a reply to message #216109] Thu, 25 January 2007 01:01 Go to previous messageGo to next message
sambaponnekanti
Messages: 9
Registered: January 2007
Location: Hyderabad
Junior Member



yes
Re: Databae connecting problem after creating the trigger-reg [message #216111 is a reply to message #216110] Thu, 25 January 2007 01:05 Go to previous message
vamsi kasina
Messages: 2107
Registered: October 2003
Location: Riyadh, Saudi Arabia
Senior Member
What is the database version?
8 or 8i check 33rd point.


Edit: If not PLEASE post the commands, you have tried. You can hide the password.

By
Vamsi

[Updated on: Thu, 25 January 2007 01:08]

Report message to a moderator

Previous Topic: indexes
Next Topic: alter materialized view
Goto Forum:
  


Current Time: Thu Dec 08 10:46:57 CST 2016

Total time taken to generate the page: 0.07995 seconds