Home » RDBMS Server » Server Administration » Need Help Setting up Streams getting ORA-26687 error
Need Help Setting up Streams getting ORA-26687 error [message #215756] Tue, 23 January 2007 15:15 Go to next message
Rustican
Messages: 51
Registered: July 2006
Member
Trying to set up streams between two databases following the example below:
http://www.oracle.com/technology/oramag/oracle/04-nov/o64streams.html#S4

I've been getting this error in my apply capture process.
ORA-26687: no instantiation SCN provided for "FLEET_MOD"."PARAMETER" in source database "ORCL3.REGRESS.RDBMS.DEV.US.ORACLE.COM"

I'm not sure why i'm getting it since i set the instantiation System Change Number (SCN) following the example.

DECLARE
source_scn NUMBER;
BEGIN
source_scn := DBMS_FLASHBACK.GET_SYSTEM_CHANGE_NUMBER();
DBMS_APPLY_ADM.SET_TABLE_INSTANTIATION_SCN@orcl02(
source_object_name => 'myDatabase.myTable',
source_database_name => 'orcl01',
instantiation_scn => source_scn);
END;
/

can anyone help?
Re: Need Help Setting up Streams getting ORA-26687 error [message #215774 is a reply to message #215756] Tue, 23 January 2007 19:18 Go to previous message
BlackSwan
Messages: 25036
Registered: January 2009
Location: SoCal
Senior Member
Note:223000.1
Streams Apply Process Fails with ORA-26687 or "Missing Streams multi-version data dictionary"
Previous Topic: Enterprise Manager Question
Next Topic: Temp tablepace max size question
Goto Forum:
  


Current Time: Sun Dec 04 06:42:36 CST 2016

Total time taken to generate the page: 0.14617 seconds