Home » RDBMS Server » Networking and Gateways » running 9i and 10g on same server
running 9i and 10g on same server [message #214274] Mon, 15 January 2007 11:14 Go to next message
schin
Messages: 3
Registered: July 2006
Junior Member
I installed oracle 10g release 10.2.0.1 on a redhat server version 4.2 which was already running Oracle 9i database.

I added the 10g instance details into listener for 9i and I was able to connect to the database on the server itself using sqlplus. however I cant connect to the database from a client pc even after adding the details to the TNSNAMES.ora file on the client PC.

the error message I am getting is 12500 failing to create a dedicated server process.

i tried to configure the Oracle 10g listener on the same server using a different port.

the message TNS error i was getting is address already in use and a Linux error 98 Connection refused.

How do i get the database to run on this server?
Re: running 9i and 10g on same server [message #214279 is a reply to message #214274] Mon, 15 January 2007 11:23 Go to previous messageGo to next message
BlackSwan
Messages: 22839
Registered: January 2009
Senior Member
>How do i get the database to run on this server?
As you said the V10 database IS running; otherwise you could not connect to it using SQL*Plus.
You should configure the V10 listener to service both databases; shutdown the V9 listener & use the V10 for both.

[Updated on: Mon, 15 January 2007 11:23] by Moderator

Report message to a moderator

Re: running 9i and 10g on same server [message #214280 is a reply to message #214274] Mon, 15 January 2007 11:23 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
You can use the 10g listener to serve both the 9i database and the 10g database. Ensure that the 9i listener is stopped and the entries in the 10g listener.ora file accommodate both the 9i & 10g databases and restart the listener. If you are still having problems, please post your listener.ora file.
Re: running 9i and 10g on same server [message #214414 is a reply to message #214280] Tue, 16 January 2007 06:15 Go to previous messageGo to next message
schin
Messages: 3
Registered: July 2006
Junior Member
I managed to get both listeners to run

the 9i listener is running and i can connect to 9i and 10g databases.

the 10g listener is also running and i can connect to both databases as well.

Since I am trying to test the upgrade.
Can i have both listeners running without any issues?

are there any effects to having both listeners running at the same time?

Re: running 9i and 10g on same server [message #214431 is a reply to message #214414] Tue, 16 January 2007 07:40 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
No effects having both listeners running.
Re: running 9i and 10g on same server [message #339354 is a reply to message #214274] Thu, 07 August 2008 06:06 Go to previous messageGo to next message
Darshan_s
Messages: 1
Registered: August 2008
Location: Mumbai
Junior Member
hi,

How u manage it could u pls send me steps by step solution.

I am facing same problem.
I installed Oracle 10 g first & SAP ECC6 on it. now i installed oracle 9i in seperate directory for SAP4.7. Now I am connecting to 9i default by SQLPLUS / NOLOG

& I want to connect to 10g how to connect.

Regards,
Darshan..
Re: running 9i and 10g on same server [message #339552 is a reply to message #339354] Thu, 07 August 2008 18:03 Go to previous message
sunil_v_mishra
Messages: 506
Registered: March 2005
Senior Member

set your ORACLE_SID of 10g DB in another session
Previous Topic: lsnrctl start error
Next Topic: apex home page not response
Goto Forum:
  


Current Time: Wed Oct 01 04:17:01 CDT 2014

Total time taken to generate the page: 0.07385 seconds