Home » RDBMS Server » Server Administration » Getting an "ORA-01031: insufficient privileges" error occasionally
Getting an "ORA-01031: insufficient privileges" error occasionally [message #214204] Mon, 15 January 2007 07:15
Messages: 3
Registered: January 2007
Location: Boston, MA
Junior Member
We have a web application (Perl/CGI, DBI, DBD:Oracle) that will, on rare occasions, produce an ORA-01031.

Once we get this error, through a particular path in the web application, it can be reproduced and does not go away until the Oracle instance is restarted.

A little more background on the issue:
1. The offending SQL statement can be run (once we've seen the issue using our web application but prior to restarting Oracle) from SQL*Plus without issue.
2. We've seen the issue when the connection is performed using the schema owner (how can there possible be permissions issues) and when using another Oracle account with the proper privileges.
3. We currently have 50 schemas running in a production and test environments and have only seen this issue a few times.
4. The issue only surfaces when calling a particular stored function, we've never seen it on a stored procedure, other stored functions or any other SQL (select, insert, update, delete).
5. We are running Oracle Standard Edition on Windows Server 2003. Our web application is served via Activestate Perl under IIS.

We've tried the statement with and without binds to see if that was the issue but have seen it happen both ways.

Any ideas/suggestions would be greatly appreciated.

Previous Topic: error in materialized view refresh path
Next Topic: Resize datafile - Problem
Goto Forum:

Current Time: Mon Oct 24 15:56:56 CDT 2016

Total time taken to generate the page: 0.11056 seconds