Home » RDBMS Server » Server Administration » ORA-12560
ORA-12560 [message #213659] Thu, 11 January 2007 14:26 Go to next message
swamy99
Messages: 30
Registered: June 2006
Member
Hi,
I have a clean install of EM Grid Control with a new database option on a new server. Also installed with the database, are the OMS as well as the Agent on the same server. I am able to connect and perform all the operation from the Grid Control including discovering targets, setting up backups etc etc. I am also able to connect to the database from sqlplus session and perform all the sql operations without any problem to the repository database.

But, when I try to connect to the database from command line, I am getting "ORA-12560 TNS:protocol adapter error". When verified the sqlnet.log file, I noticed that the SID is pointing to ORCL and the sqlplus PROGRAM is being run from bin directory of OMS10g. We specified the SID as "EMREP" and not "ORCL" during the initial setup.
There is only one tnsnames.ora file which is residing in db10g home and has only one entry for the EMREP database.
Does anyone have a clue as to why the SQLPLUS program from command line is looking into OMS10g home instead of DB10g home?
Thanks for your help.
Re: ORA-12560 [message #213668 is a reply to message #213659] Thu, 11 January 2007 15:37 Go to previous messageGo to next message
joy_division
Messages: 4640
Registered: February 2005
Location: East Coast USA
Senior Member
and what happens when you try to use a fully qualified connect string like scott/tiger@EMREP?
Re: ORA-12560 [message #213670 is a reply to message #213668] Thu, 11 January 2007 16:09 Go to previous messageGo to next message
swamy99
Messages: 30
Registered: June 2006
Member
When issued with scott/tiger@emrep I get,

SQL*Plus: Release 10.1.0.4.2 - Production on Thu Jan 11 14:06:47 2007

Copyright (c) 1982, 2005, Oracle. All rights reserved.

ERROR:
ORA-12154: TNS:could not resolve the connect identifier specified

I tried with sys user and get the same error as above.
Re: ORA-12560 [message #213888 is a reply to message #213670] Fri, 12 January 2007 12:25 Go to previous messageGo to next message
swamy99
Messages: 30
Registered: June 2006
Member
Any updates?
Re: ORA-12560 [message #213890 is a reply to message #213888] Fri, 12 January 2007 12:43 Go to previous messageGo to next message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
Quote:
Does anyone have a clue as to why the SQLPLUS program from command line is looking into OMS10g home instead of DB10g home?



Well, what IS the $ORACLE_HOME envirionment variable set to in the session where sqlplus is run?

Re: ORA-12560 [message #213949 is a reply to message #213888] Fri, 12 January 2007 22:41 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
ORA-12560 TNS:protocol adapter error

Are you check your oracle services is start ? if services is stop then start first.

and problem still exists then post tnsnames.ora , listener.ora files.


regards
Taj
Re: ORA-12560 [message #214041 is a reply to message #213659] Sat, 13 January 2007 21:11 Go to previous message
ora10g
Messages: 7
Registered: July 2006
Junior Member
First check oracle env variables,(ORACLE_SID,ORACLE_HOME)

http://www.easywebtech.com/artical/ORACLE_environment_variables.html

If that is correct , check tns and listener,

http://www.easywebtech.com/artical/TNScouldnotresolve.html
Previous Topic: OraInventory is gone cant install patch
Next Topic: oracle installation problem
Goto Forum:
  


Current Time: Sat Dec 03 05:43:18 CST 2016

Total time taken to generate the page: 0.22365 seconds