Home » RDBMS Server » Performance Tuning » Different OPtimizer behaviour on Ora9iR2 ( patch 7 )-Shared server
Different OPtimizer behaviour on Ora9iR2 ( patch 7 )-Shared server [message #213626] Thu, 11 January 2007 09:57 Go to next message
snow-runner
Messages: 7
Registered: December 2006
Location: Maribor,Slovenia
Junior Member
Under shared server connection architecture ( MTS ) the optimizer is behaving totally unlogical.
This is not the problem if I switch the optmizer mode to rule based with backward compatibility to 8i (init.ora parameters ).

But on the other way the same queries work perfectly also with cost based optimized If I switch to dedicated mode!

What should I do:
1. to switch whole production database instance to dedicated mode
- I am afraid of consuming more memory and swapping

2. to switch the optimizer mode back to 8i
- this doesn't sounds great because of future upgrades where
we'll have get to use on cost based

3. Would upgrade to patch 8 ( 9.2.0.8 ) do any help on
behaviour of cost based optimizer on shared server ( previous MTS )

Thanx in advance,
Re: Different OPtimizer behaviour on Ora9iR2 ( patch 7 )-Shared server [message #213864 is a reply to message #213626] Fri, 12 January 2007 10:12 Go to previous message
michael_bialik
Messages: 611
Registered: July 2006
Senior Member
Check it with Oracle support.
(Hopefully) they will know something.
Previous Topic: Insert all vs Forall
Next Topic: Tuning an oracle view to increase the speed of the view
Goto Forum:
  


Current Time: Wed Dec 07 12:54:35 CST 2016

Total time taken to generate the page: 0.09941 seconds