Home » RDBMS Server » Server Administration » Archive/nonarchive mode
Archive/nonarchive mode [message #213174] Tue, 09 January 2007 13:26 Go to next message
cidu
Messages: 5
Registered: May 2002
Junior Member
In one of the instance,

SQL> archive log list;
Database log mode Archive Mode
Automatic archival Disabled
Archive destination /opt/oracle/product/9.2.0.6/dbs/arch
Oldest online log sequence 2
Next log sequence to archive 5
Current log sequence 5

This is a development instance which is created using the online backup of production instance which is in archive log mode. But the development instance is setup to noarchive mode based on the init.ora.

Why the development instance is in archive mode?


Thanks a lot!


# Create database from hot backup
/opt/oracle/product/9.2.0.6/bin/sqlplus "/ as sysdba" <<EOF
@/opt/oracle/admin/scripts/infxxx_control
recover database using backup controlfile
/qtprd/.snapshot/${SNdate}_${SNtime}/oradata/infyyy/log1.log
recover database using backup controlfile
/qtprd/.snapshot/${SNdate}_${SNtime}/oradata/infyyy/log2.log
recover database using backup controlfile
/qtprd/.snapshot/${SNdate}_${SNtime}/oradata/infyyy/log3.log
recover database using backup controlfile
/qtprd/.snapshot/${SNdate}_${SNtime}/oradata/infyyy/log4.log
recover database using backup controlfile
/qtprd/.snapshot/${SNdate}_${SNtime}/oradata/infyyy/log1.log
recover database using backup controlfile
/qtprd/.snapshot/${SNdate}_${SNtime}/oradata/infyyy/log2.log
recover database using backup controlfile
/qtprd/.snapshot/${SNdate}_${SNtime}/oradata/infyyy/log3.log
recover database using backup controlfile
/qtprd/.snapshot/${SNdate}_${SNtime}/oradata/infyyy/log4.log
ALTER DATABASE OPEN RESETLOGS;
ALTER TABLESPACE TEMP ADD TEMPFILE '/qttst/oradata/infxxx/temp.dbf'
SIZE 100M REUSE AUTOEXTEND ON NEXT 100M MAXSIZE 6000M;
alter database rename global_name to INFXXX.TTT.TTT;
commit;
EOF



Re: Archive/nonarchive mode [message #213191 is a reply to message #213174] Tue, 09 January 2007 14:29 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
You are in ARCHIVELOG mode, just not AUTOMATIC archivelog mode. Check the spfile or init file that is being used to start the database for LOG_ARCHIVE_START, this should be set equal to TRUE.

[Updated on: Tue, 09 January 2007 14:30]

Report message to a moderator

Re: Archive/nonarchive mode [message #213192 is a reply to message #213191] Tue, 09 January 2007 14:37 Go to previous messageGo to next message
cidu
Messages: 5
Registered: May 2002
Junior Member
But I want the database to be in noarchive mode. That's why I used

log_archive_start = false

in the init.ora. My confusion is : why the development DB started as archive log mode?

Thanks for replying!!


Re: Archive/nonarchive mode [message #213204 is a reply to message #213174] Tue, 09 January 2007 16:11 Go to previous messageGo to next message
cidu
Messages: 5
Registered: May 2002
Junior Member
I got it. The reason the DB started in Archivelog mode: the script to re-create the control file as :

STARTUP NOMOUNT
CREATE CONTROLFILE SET DATABASE "DMMAS" RESETLOGS ARCHIVELOG

Now I chanegd to

CREATE CONTROLFILE SET DATABASE "DMMAS" RESETLOGS NOARCHIVELOG;

Now it looks like following:

Database log mode No Archive Mode
Automatic archival Disabled
Archive destination /opt/oracle/product/9.2.0.6/dbs/arch
Oldest online log sequence 0
Current log sequence 0


Thanks !
Re: Archive/nonarchive mode [message #213205 is a reply to message #213204] Tue, 09 January 2007 16:16 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Good catch cidu. Glad you got it resolved.
Re: Archive/nonarchive mode [message #213679 is a reply to message #213174] Thu, 11 January 2007 18:15 Go to previous messageGo to next message
gkrishn
Messages: 506
Registered: December 2005
Location: Putty a dark screen
Senior Member
cidu,
Did u recreated the database,just to change the archive log mode ?
Re: Archive/nonarchive mode [message #213860 is a reply to message #213174] Fri, 12 January 2007 09:44 Go to previous message
cidu
Messages: 5
Registered: May 2002
Junior Member
I just shutdown the DB, startup mount, alter database noarchivelog; alter database open. Now everything seems ok. Thanks
Previous Topic: Problem about extents
Next Topic: oracle prevent
Goto Forum:
  


Current Time: Sat Dec 03 06:00:19 CST 2016

Total time taken to generate the page: 0.09650 seconds