Home » RDBMS Server » Server Administration » error in import
error in import [message #211758] Tue, 02 January 2007 03:10 Go to next message
kamragulshan
Messages: 63
Registered: May 2005
Location: Delhi
Member
Hi..

I have oracle 9i running on Solaris 8 and i have created the same database on another machine running Solaris 10 with the same version of Oracle 9i.
Now the problem is that i have taken the user level export from our production database and while importing the data into testing database running on Solaris 10. I found that it was not importing the data into the system due to some problem in importing the index. Then i have taken the export with indexes. It then has imported all the data and when i am trying to create required indexes on the tables through script, it gets hanged means like the script has 500 indexes to be created but it create only 113 indexes and then hanged on 114 index, then i have commented that index then again it gets hanged on 143. It is not showing any error at sql prompt nor it is showing any error in alert log. There is not any problem of space issue.
The same dump when i have tried to import (having indexes also) on Windows XP machine, it imported successfully without any error.
Now i am not able to trace out the problem. Please help.

Thanks

Gulshan
Re: error in import [message #211806 is a reply to message #211758] Tue, 02 January 2007 06:31 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
Oracle installation on solaris 10 is successfully done.
found that it was not importing the data into the system due to some problem in importing the index.

can you post here what error you got.

regards
Taj
Re: error in import [message #211893 is a reply to message #211806] Wed, 03 January 2007 00:12 Go to previous messageGo to next message
kamragulshan
Messages: 63
Registered: May 2005
Location: Delhi
Member
Hi..

Oracle is successfully installed and the required patches are also installed. The problem is coming when importing the dump taken at user level, when importing upto a certain table it hanged and does not showing any error. I have traceout the table on which it is showing error. That is why i have taken the export at user level excluding index and creating indexes after importing the complete data. When creating indexes it doesn't through any error and hanged. I am not able to understand why it is not throughing any error.

Thanks

Gulshan
Re: error in import [message #211895 is a reply to message #211893] Wed, 03 January 2007 00:25 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

hi,
you import all required tables from export dump files.
if your not getting any error during creating index and it was hang may be some tables are missing ...?

regards
Taj
Re: error in import [message #211910 is a reply to message #211895] Wed, 03 January 2007 01:17 Go to previous message
kamragulshan
Messages: 63
Registered: May 2005
Location: Delhi
Member
Hi..

Thanks for your quick response. I have checked that each and every table has imported. No table is missing. I have found that a table have 5 indexes. Then i have tried to create all the indexes and it successfully created 4 indexes but hanged on one index.

Thanks

Gulshan
Previous Topic: Turn off Archive log mode in oracle 9i
Next Topic: Max redo size
Goto Forum:
  


Current Time: Tue Dec 06 10:37:39 CST 2016

Total time taken to generate the page: 0.08514 seconds