Home » Developer & Programmer » Forms » Call Report 6i from Form 6i wih parameter
Call Report 6i from Form 6i wih parameter [message #210955] Sun, 24 December 2006 02:48 Go to next message
shakti_goyal
Messages: 60
Registered: November 2006
Location: India
Member


Sir
I'm new to Oracle.I want to call a report from Form.. I m using Form 6i & Report 6i.
I'm using RUN_REPORT_OBJECT and passing a Parameter list to call report but I'm not able to get the Output in the report(header is getting generated but no data is being displayed) as parameter defined in report not getting mapped with the parameter in the paranmeter list

My code is As:

par:=create_parameter_list('JAGGA');
Add_Parameter(par,'p_salary',TEXT_PARAMETER,'1000');
SET_REPORT_OBJECT_PROPERTY(report_id,REPORT_OTHER,'PARAMFORM=NO');
report_job_id := RUN_REPORT_OBJECT(report_id,par);

I've already defined a parameter named p_salary in report

If I modify my code as following I'm getting the correct Output

SET_REPORT_OBJECT_PROPERTY(report_id,REPORT_OTHER,'PARAMFORM=NO'||' p_salary=500');
report_job_id := RUN_REPORT_OBJECT(report_id);

I'm also getting the output from the report If I'm calling report using RUN_PRODUCT function the code is as:


par:=create_parameter_list('JAGGA');
Add_Parameter(par,'p_salary',TEXT_PARAMETER,'1000');
Add_Parameter(par,'PARAMFORM',TEXT_PARAMETER,'NO');

run_product(reports, 'c:\shakti_goyal.rdf', synchronous, runtime, filesystem, par, null);


Sir I want to know where I'm making mistake in writing code using
RUN_REPORT_OBJECT first code or I'm missing something in code or setting wrong properties. I'm not using any report server. Report is being generated through Report Background Engine...

Thanks in advance
Regards Shakti Goyal






Re: Call Report 6i from Form 6i wih parameter [message #210957 is a reply to message #210955] Sun, 24 December 2006 03:36 Go to previous messageGo to next message
saadatahmad
Messages: 452
Registered: March 2005
Location: Germany/Paderborn
Senior Member

hi,

I think this will be helpful.

http://www.orafaq.com/forum/t/52330/67693/

regards,
Saadat Ahmad
Re: Call Report 6i from Form 6i wih parameter [message #210963 is a reply to message #210957] Sun, 24 December 2006 06:17 Go to previous messageGo to next message
shakti_goyal
Messages: 60
Registered: November 2006
Location: India
Member


Thanks sadat
for your quick reply.......
This link is very helpful to me .....
But I m still waiting for my answer.......

Regards
Shakti.....
Re: Call Report 6i from Form 6i wih parameter [message #212107 is a reply to message #210963] Wed, 03 January 2007 17:39 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you solved your problem?

David
Re: Call Report 6i from Form 6i wih parameter [message #212362 is a reply to message #212107] Thu, 04 January 2007 21:52 Go to previous message
shakti_goyal
Messages: 60
Registered: November 2006
Location: India
Member

I have solved my problem...
By using Run_product Built-in......

Thanks for reply.....

Regards
Shakti
Previous Topic: Need help with a message alert
Next Topic: text highlighted when page up and down in multiple records block?
Goto Forum:
  


Current Time: Sun Dec 04 10:28:12 CST 2016

Total time taken to generate the page: 0.06046 seconds