Home » SQL & PL/SQL » SQL & PL/SQL » sqlplpus Connect behaviour on 10g
icon5.gif  sqlplpus Connect behaviour on 10g [message #210350] Wed, 20 December 2006 08:12 Go to next message
coolbalaga
Messages: 24
Registered: September 2006
Junior Member
Need your help for the below error :

I have oracle 10g and database is in the shutdown state. when i perform the below operation, I get the
<--
$ sqlplus /nolog
SQL> conn sys/dba@TEST as sysdba;
ERROR:
ORA-01031: insufficient privileges
--->

But if I do the same in this sequence, it goes thru fine:
<--
1. conn / as sysdba;
2. startup mount;
3. conn sys/dba@TEST as sysdba;
-->
everything is fine.

It is amazing to know that the connect with the net_service_name fails when the database is in the shutdown state. Can anyone help me to understand the problem ?

-- sqlnet.ora
NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)
---



Re: sqlplpus Connect behaviour on 10g [message #210359 is a reply to message #210350] Wed, 20 December 2006 08:36 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Do you have a orapwTEST file in $ORACLE_HOME/dbs directory for the database ?
Re: sqlplpus Connect behaviour on 10g [message #210464 is a reply to message #210359] Wed, 20 December 2006 22:27 Go to previous message
coolbalaga
Messages: 24
Registered: September 2006
Junior Member
So i installed the oracle 10g on other system and facing similar problem but getting the different error text:

<----
SQL> connect sys/dba@TEST as sysdba;
ERROR:
ORA-28547: connection to server failed, probable Oracle Net admin error
--->

Pl. help to understand the problem.
Previous Topic: Decode function (merged)
Next Topic: sqlplus problem with a procedure
Goto Forum:
  


Current Time: Fri Dec 09 05:59:57 CST 2016

Total time taken to generate the page: 0.14038 seconds