Home » Developer & Programmer » Forms » I have a little problem with the default exit button..
I have a little problem with the default exit button.. [message #208573] Mon, 11 December 2006 07:09 Go to next message
EtaiA
Messages: 6
Registered: December 2006
Junior Member
The default exit button('X') doesn't seem to work with one of my forms.
When I try exiting in an other way (like pressing a button that exits the form) it works..
I tried debugging the key-exit trigger and when a press the exit button theres no response..
its the only key-exit in the form so theres no trigger overriding it..

any idea what can cause this?
Re: I have a little problem with the default exit button.. [message #208582 is a reply to message #208573] Mon, 11 December 2006 07:31 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
How does the KEY-EXIT trigger look like? Do you really need it? Form would exit without it anyway.
Re: I have a little problem with the default exit button.. [message #208591 is a reply to message #208582] Mon, 11 December 2006 08:16 Go to previous messageGo to next message
EtaiA
Messages: 6
Registered: December 2006
Junior Member
Theres no logic in the trigger,
and I tried removing it.. didnt help
Re: I have a little problem with the default exit button.. [message #208632 is a reply to message #208591] Mon, 11 December 2006 10:45 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Well, if you removed the KEY-EXIT trigger attached to a button and then pressed that button to exit the form, no wonder nothing happened Smile

What I really meant was to exit the form using standard "Exit" button at the toolbar.

If you really need a home- made "Exit" button, try to put this code into the KEY-EXIT trigger:
exit_form (no_validate);

What happens then?
Re: I have a little problem with the default exit button.. [message #208658 is a reply to message #208632] Mon, 11 December 2006 16:47 Go to previous messageGo to next message
EtaiA
Messages: 6
Registered: December 2006
Junior Member
I tried to put the exit_form command in the KEY-EXIT trigger..
but when i press the exit button it doesnt seem to get to the trigger.. not in debug mode too
Re: I have a little problem with the default exit button.. [message #208682 is a reply to message #208658] Mon, 11 December 2006 21:32 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Put 'message / pause' pairs into your code and see if it is getting into the trigger.

David
Re: I have a little problem with the default exit button.. [message #208754 is a reply to message #208682] Tue, 12 December 2006 02:26 Go to previous messageGo to next message
EtaiA
Messages: 6
Registered: December 2006
Junior Member
tried that already,
it doesn't get to the trigger...
weird Confused
Re: I have a little problem with the default exit button.. [message #208826 is a reply to message #208573] Tue, 12 December 2006 05:49 Go to previous message
EtaiA
Messages: 6
Registered: December 2006
Junior Member
hurray I found how to solve this (tiny) problem!
here if anyone is interested.
thanks anyways for the help guys.
Previous Topic: Where to validate a foreign key?
Next Topic: HOST function in forms 9i
Goto Forum:
  


Current Time: Sun Dec 04 20:45:44 CST 2016

Total time taken to generate the page: 0.08889 seconds