Home » Infrastructure » Windows » ERROR:ORA-12154: TNS:could not resolve service name
ERROR:ORA-12154: TNS:could not resolve service name [message #207730] Wed, 06 December 2006 16:26 Go to next message
silvermoon
Messages: 5
Registered: December 2006
Junior Member
I upgrade my computer with a new mother board. And I have to reinstall Oracle 10g and Oracle developement suite 10g.

After I installed Oracle 10g on my computer, I can login using the +SQLPlus from program list, but when I input Dos command: sqlplus scott/tiger@orcldd, "ORA-12154: TNS:could not resolve service name" showed up.

I installed Oracle develope suite, I ran Forms builder, when I tried to connect database orcld with scott and tiger, same error message showed up.

I check Net Manager, orcld's host name is: mycomputer_name:gateway:2wire.net, I don't understand why is this. anyway, I test orcld and it was sucessfully connected.

I used only mycomputer_name for the host name in Net Manager before, and it worked. I changed it to only mycomputer_name as the hostname for service name orcld in Net manager, but end up same thing. I can login into the Database Orcld with windows application SqlPlus, but not from the command line or Forms builder.

Anybody can give me some clue or solution?

Thanks very much!

Kathy

[Updated on: Wed, 06 December 2006 16:38]

Report message to a moderator

Re: ERROR:ORA-12154: TNS:could not resolve service name [message #207742 is a reply to message #207730] Wed, 06 December 2006 18:20 Go to previous messageGo to next message
anurag078
Messages: 34
Registered: May 2006
Location: West Des Moines
Member


Please run the below command at command prompt and let us know the results.

tnsping orcldd
Re: ERROR:ORA-12154: TNS:could not resolve service name [message #207744 is a reply to message #207742] Wed, 06 December 2006 18:29 Go to previous messageGo to next message
silvermoon
Messages: 5
Registered: December 2006
Junior Member
Thank you very much!

I just tried: tnsping orcldd

result: TNS-03505: failed to resolve name.

my sqlnet.ora file:

it was:
# sqlnet.ora Network Configuration File: D:\oracle_10g\network\admin\sqlnet.ora
# Generated by Oracle configuration tools.

SQLNET.AUTHENTICATION_SERVICES= (NTS)

NAMES.DIRECTORY_PATH= (TNSNAMES, EZCONNECT)

then I tried to change it to below(still same error), is this file somewhere wrong?

# sqlnet.ora Network Configuration File: D:\oracle_10g\network\admin\sqlnet.ora
# Generated by Oracle configuration tools.

SQLNET.AUTHENTICATION_SERVICES= (NTS)

NAMES.DIRECTORY_PATH= (LDAP, TNSNAMES, ONAMES, HOSTNAME)

DEFAULT_SDU_SIZE = 8761

[Updated on: Wed, 06 December 2006 18:32]

Report message to a moderator

Re: ERROR:ORA-12154: TNS:could not resolve service name [message #207745 is a reply to message #207742] Wed, 06 December 2006 18:43 Go to previous messageGo to next message
silvermoon
Messages: 5
Registered: December 2006
Junior Member
I just set oracle_sid and set TNS_ADMIN location, and now I can sqlplus from Dos. And tnsping works now. Great!

Then I start developer, still couldn't resolve the service name. I changed the .ora files. Maybe I can change them back to see if it works.
Re: ERROR:ORA-12154: TNS:could not resolve service name [message #207746 is a reply to message #207744] Wed, 06 December 2006 18:47 Go to previous messageGo to next message
silvermoon
Messages: 5
Registered: December 2006
Junior Member
I just ran Forms builder, still can't resolve the service name. Sad
Re: ERROR:ORA-12154: TNS:could not resolve service name [message #207752 is a reply to message #207746] Wed, 06 December 2006 20:42 Go to previous message
silvermoon
Messages: 5
Registered: December 2006
Junior Member
Ok, everything seems working now. I didn't change anything. I guess the evironment settings was causing all the problem.

Still there is one more strange thing that OracleDBConsoleorcldd shows starting instead of started. And it seems tangled with ORACLEseviceORCLDD, when both starting, I have to stop ORACLEservice than ORACLEservice showed started! and OracleDBConsole is still starting, but property says it's started.

Anyway and luckly, the problem solved. Yeah!

[Updated on: Wed, 06 December 2006 20:44]

Report message to a moderator

Previous Topic: problem installing oracle 8i in win XP
Next Topic: Oracle 9.2 client, Active Directory & windows xp limited rigths
Goto Forum:
  


Current Time: Sat Dec 10 01:16:02 CST 2016

Total time taken to generate the page: 0.09451 seconds