Home » Developer & Programmer » Forms » Focus lost navigating forms in web deployment of forms 6i
Focus lost navigating forms in web deployment of forms 6i [message #206400] Wed, 29 November 2006 22:38 Go to next message
jyotiweb
Messages: 7
Registered: March 2005
Junior Member
I have developed an application using forms6i rel 2

The forms server is installed on windows 2000 and all necessary set up is done on the forms server. Patch 18 is also applied.
On the client side I am using IE 6 and JRE Java 2 Ver 1.5.0_9-b03

Everything works fine. But when I navigate from one form to another, the cursor focus is lost. This also happens when I navigate from one block to another block within the same form.

In such situation when I press Windows button on the key board twice, the cursor reappears. It seems the problem is because the applet window where the forms is running is not refreshed while navifating to different forms.

Can anybody guide me to solve this problem.

Thanks
Kamlesh
Re: Focus lost navigating forms in web deployment of forms 6i [message #206616 is a reply to message #206400] Thu, 30 November 2006 18:07 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Please confirm that this is happening when you swap between two forms which are ALREADY open. That is, you have used Open_Form to open the second form and you are using Alt-Tab to navigate between the two forms. If yes, then perhaps you need a 'Synchronize' in the When-Window-Activated trigger.

By any chance would these fields be numeric?

David
Re: Focus lost navigating forms in web deployment of forms 6i [message #206628 is a reply to message #206616] Thu, 30 November 2006 21:24 Go to previous messageGo to next message
jyotiweb
Messages: 7
Registered: March 2005
Junior Member
No actually my situation is different.
I have opened one form say A. The cursor is on one of the fields on this form. This form now CALL another form say B. After finishing work with form B,when I EXIT from this forn B, it returns back to form A. But when it returns to this form A the cursor focus is lost. I have to press Windows button on the keyboard twice to bring the cursor focus.

Kamlesh
Re: Focus lost navigating forms in web deployment of forms 6i [message #206634 is a reply to message #206628] Thu, 30 November 2006 22:32 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Please try putting a 'synchronize' after the 'call_form' to Form B and see if that changes anything.

David
Re: Focus lost navigating forms in web deployment of forms 6i [message #206880 is a reply to message #206634] Fri, 01 December 2006 22:31 Go to previous messageGo to next message
jyotiweb
Messages: 7
Registered: March 2005
Junior Member
NO It does not work by putting synchronize
Re: Focus lost navigating forms in web deployment of forms 6i [message #206891 is a reply to message #206634] Sat, 02 December 2006 00:51 Go to previous messageGo to next message
jyotiweb
Messages: 7
Registered: March 2005
Junior Member
I have found the solution for this problem.
Instead of using JRE Java 2 Ver 1.5.0_9-b03 we used JInitiator 1.3.1.25.

Thanks
Kamlesh
Re: Focus lost navigating forms in web deployment of forms 6i [message #207040 is a reply to message #206891] Mon, 04 December 2006 00:20 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I thought that only fixed this problem in Forms 9i! Its nice to see that it fixed it in 6i as well.

David
Previous Topic: WebUtil_C_API(Urgent)
Next Topic: validate item on varchar
Goto Forum:
  


Current Time: Mon Dec 05 11:17:50 CST 2016

Total time taken to generate the page: 0.24662 seconds