Home » Developer & Programmer » Forms » WebUtil_C_API..Invoke_Int Not Working ( Urgent )
WebUtil_C_API..Invoke_Int Not Working ( Urgent ) [message #206177] Wed, 29 November 2006 01:18 Go to next message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

Hi,
Every Buddy
Version->Forms 10g + WebUtil Installed + Windows

I need to interface with C from oracle forms by using .DLL file which will call C functions in 10g.
For 10g i tried old methods which were in Forms 6i by using ORA_FFI.load_library but these functions did not work.
Then i gone through Webutil_C_API where it is able to register WEBUTIL_C_API.register_function, then WEBUTIL_C_API.add_parameter
but when it come to invoke "C" function by using WEBUTIL_C_API.Invoke_Int, it is going to struck here only.

Here i tried the example which is in below address
http://www.oracle.com/technology/products/forms/htdocs/webutil/howto_ffi.html(i.e.http://www.oracle.com/technology/products/forms/htdocs/webutil/webutil_c_api_test.zip)

I downloaded the MODULE1.fmb which has two buttons C/S FFI, WEB FFI,when clicked on button C/S FFI its working fine which internally call the ORA_FFI functions, but when i click WEB FFI it create the parameter, add argument & then @ the time of invoking Webutil_C_API.Invoke_Int strucking.



So plz if any one know the solution, let me know as early as possible.







Re: WebUtil_C_API..Invoke_Int Not Working ( Urgent ) [message #206382 is a reply to message #206177] Wed, 29 November 2006 18:13 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you considered using 'ole2'? There is a good recent example in http://www.orafaq.com/forum/t/72811/67467/

David
Re: WebUtil_C_API..Invoke_Int Not Working ( Urgent ) [message #206407 is a reply to message #206177] Wed, 29 November 2006 23:11 Go to previous messageGo to next message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

Martin
My doubt was regarding Calling "C Language" functions in Oracle Forms. If is use the Forms 6i its working fine, but when i use the Forms 10g either by using ORA_FFI or WebUtil_API_C is not working, is there any other solution to call C From Forms 10g
Re: WebUtil_C_API..Invoke_Int Not Working ( Urgent ) [message #206409 is a reply to message #206407] Wed, 29 November 2006 23:16 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I have a feeling that your environment is not set up correctly. Please verify that the directory holding the C programs is adressable by the 10g system.

David
Re: WebUtil_C_API..Invoke_Int Not Working ( Urgent ) [message #206415 is a reply to message #206409] Thu, 30 November 2006 00:16 Go to previous messageGo to next message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

Its Correct only because its working if i use ORA_FFI for some C functions and for some functions its not, if i get the information regarding that i how to call 'C' & how to pass parameter exactly, i would able to call those C functions.


Thanks
Anil MK
Re: WebUtil_C_API..Invoke_Int Not Working ( Urgent ) [message #206419 is a reply to message #206415] Thu, 30 November 2006 00:22 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have a look at http://forums.oracle.com/forums/thread.jspa;jsessionid=8d92200830dea575e0fa1818455aa3ecb941ea760850.e34QbhuKaxmMai0MaNeMb3aTchf0?mess ageID=1024628&#1024628

Is this the problem that you are having?

Please confirm that you are trying to perform the actions detailed in http://www.oracle.com/technology/products/forms/htdocs/webutil/howto_ffi.html and that it is THIS form that is not working for you.

David

PS: Also have a look at http://forums.oracle.com/forums/thread.jspa?messageID=783790&#783790

[Updated on: Thu, 30 November 2006 00:27]

Report message to a moderator

Re: WebUtil_C_API..Invoke_Int Not Working ( Urgent ) [message #206423 is a reply to message #206419] Thu, 30 November 2006 00:33 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
The link http://www.it-eye.nl/weblog/category/oracle/database/ has an entry "Calling c from plsql" which looks as though it could be a good way of getting around your problem. The author creates a PL/SQL wrapper around the DLL and addresses it as a function instead of using ora_ffi.

David
Re: WebUtil_C_API..Invoke_Int Not Working ( Urgent ) [message #206478 is a reply to message #206423] Thu, 30 November 2006 04:27 Go to previous message
anil_mk
Messages: 137
Registered: August 2006
Location: Bangalore, India
Senior Member

Thank You David

I am trying to perform similar actions which were in http://www.oracle.com/technology/products/forms/htdocs/webutil/howto_ffi.html ,
but with Some other C functions which are in .DLL file, i don't know y its not working, i will try those what you gave the links if any problem once again i will ask for help to you





Previous Topic: Calling a block in a form
Next Topic: Creating form Text Feild with Validation as..it should Only have Numbers...
Goto Forum:
  


Current Time: Fri Dec 09 00:25:30 CST 2016

Total time taken to generate the page: 0.12318 seconds