Home » Developer & Programmer » Forms » Calling a block in a form
icon6.gif  Calling a block in a form [message #206063] Tue, 28 November 2006 08:31 Go to next message
Messages: 30
Registered: February 2005
Hello All,
I'm trying to call a particular block in a form. The actual call is done via fnd_function.execute. This brings up 2 blocks:

1) a find/search block
2) the block I want with the correct information based on the parameters I have passed in.

Everything so far is OK with the exception of not wanting the 'find' block to appear. I've tried to hide the associated window by using the hide_window function but this doesn't work. Anyone got any new ideas I can try ?

Thanks in advance

Re: Calling a block in a form [message #206116 is a reply to message #206063] Tue, 28 November 2006 18:04 Go to previous messageGo to next message
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Quick answer - You can't hide a window/canvas while an item on that winbdow/canvas still has 'focus'. Make sure that an item on the window/canvas you want displayed has 'focus' before trying to hide the other one.

Longer answer - What are you REALLY trying to do? I believe that you are calling a form while passing parameters. Then, in the called form, you are testing to see if parameters have been passed, and if they have, you are to execute that query and only display the answer without first asking the user to enter the search elements. Is this correct? If correct, then in the When-New-Form-Instance instead of doing the 'go_item' to the 'search' area then assign the values to the 'search' items, do the 'go_item' to the 'results' area, and then do the 'execute_query'.

Re: Calling a block in a form [message #206466 is a reply to message #206116] Thu, 30 November 2006 03:37 Go to previous message
Messages: 30
Registered: February 2005
David... That's exactly what I'm trying to do - thanks for the feedback. Much Obliged. Sandy
Previous Topic: check box in form
Next Topic: WebUtil_C_API..Invoke_Int Not Working ( Urgent )
Goto Forum:

Current Time: Sun Oct 23 03:37:27 CDT 2016

Total time taken to generate the page: 0.22466 seconds