Home » Developer & Programmer » Reports & Discoverer » Detail line is changing my summary results to zero
Detail line is changing my summary results to zero [message #205819] Mon, 27 November 2006 15:23 Go to next message
rhakan
Messages: 4
Registered: June 2006
Junior Member
Hey all,

I hope you can help. I've been working with this for days and am making no headway. I have an existing report which works fine, but I need to add a couple of columns to the detail line. Currently I have a three row detail followed by a full page summary and I have a set of parameters which returns about six thousand results.

I'm trying to add the two columns by making it a four row detail line. I have been able to expand the frame and the report still works, but as soon as I add a column, or even move an existing one, the report run with my set parameters returns zero results and my totals drops to zero.

My summary totals are not dependent on the detail lines but even if they were, why on earth would moving a field in the detail line change my results?

If you need any more information to help me, just let me know and I shall provide it with the utmost will.

Many thanks in advance for your help here and in previous conundrums.

Robin
Re: Detail line is changing my summary results to zero [message #205845 is a reply to message #205819] Mon, 27 November 2006 21:53 Go to previous messageGo to next message
ab_trivedi
Messages: 460
Registered: August 2006
Location: Pune, India
Senior Member
Hi Robin,

If you can then send me the .rdf and tell me where exactly the problem coming. I will try to solve the problem .

bye
Ashu
Re: Detail line is changing my summary results to zero [message #205897 is a reply to message #205819] Tue, 28 November 2006 01:26 Go to previous messageGo to next message
dawood
Messages: 5
Registered: November 2006
Junior Member
If you can then send me the .rdf. I will try to solve the problem .

Re: Detail line is changing my summary results to zero [message #205927 is a reply to message #205819] Tue, 28 November 2006 03:03 Go to previous messageGo to next message
javed.khan
Messages: 340
Registered: November 2006
Location: Banglore
Senior Member

Hi ,
Can you send the .rdf and Screenshot of both of the Outputs.. So that i can try it .
Re: Detail line is changing my summary results to zero [message #206095 is a reply to message #205845] Tue, 28 November 2006 13:53 Go to previous message
rhakan
Messages: 4
Registered: June 2006
Junior Member
I've attached the rdf. When I went to run an example, I found that the "generate to file" option doesn't work with either version of the report (both show zero results). The report I included is the existing working version. My goal was to expand the detail repeating frame to show four lines of detail instead of three. I am able to expand the frame, but even moving a column within the frame causes the results to drop to zero.

Unfortunately, this is a rather complex report. Generally, for speed's sake, we use a pl/sql package which does most calculations and stores line displays for complex matrix reports. This data is stored in a temporary table and the layout runs from that temp table.

Let me know if you need any further information and I shall provide it asap.

Thanks much!
Robin
Previous Topic: order by problem
Next Topic: Oracle Report Printing Authorization Problem
Goto Forum:
  


Current Time: Sat Dec 10 16:46:11 CST 2016

Total time taken to generate the page: 0.07503 seconds