Home » Infrastructure » Windows » Error while during installation of patch set 9.2.0.7 in silent mode
Error while during installation of patch set 9.2.0.7 in silent mode [message #205094] Thu, 23 November 2006 05:12 Go to next message
yonieilon
Messages: 13
Registered: October 2006
Junior Member
I have successfully installed oracle server 9.2.0.1 on a laptop in silent mode, and now I'm trying to install patch set 9.2.0.7 in the same manner.

I run the installation from the command line like this:
setup.exe -silent -responseFile c:\temp\patchset.rsp ORACLE_HOME="c:\oracle" ORACLE_HOME_NAME="HOME1"


This opens a new CMD window for "Oracle Universal Installer",
but I get an error:
"You have specified a non-empty directory to install this product. It is recommended to specify either an empty or a non-existent directory".

Does anyone have an idea what I'm doing wrong?


Re: Error while during installation of patch set 9.2.0.7 in silent mode [message #205118 is a reply to message #205094] Thu, 23 November 2006 06:26 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Did you check the installation guide? It seems that
Quote:
"You have specified a non-empty directory to install this product. It is recommended to specify either an empty or a non-existent directory"

Re: Error while during installation of patch set 9.2.0.7 in silent mode [message #205120 is a reply to message #205118] Thu, 23 November 2006 06:33 Go to previous messageGo to next message
yonieilon
Messages: 13
Registered: October 2006
Junior Member
But doesn't that sound peculiar?

Isn't the whole idea of a patch set the fact that it is installed over an existing oracle installation and ORACLE_HOME directory?
Re: Error while during installation of patch set 9.2.0.7 in silent mode [message #205137 is a reply to message #205120] Thu, 23 November 2006 07:29 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I agree; it sounds reasonable.

Did you try to install it NOT using silent mode?
Re: Error while during installation of patch set 9.2.0.7 in silent mode [message #205144 is a reply to message #205137] Thu, 23 November 2006 08:08 Go to previous messageGo to next message
yonieilon
Messages: 13
Registered: October 2006
Junior Member
Yes, I did, and it worked fine.
Re: Error while during installation of patch set 9.2.0.7 in silent mode [message #205168 is a reply to message #205144] Thu, 23 November 2006 13:31 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
As a conclusion: you, finally, patched Oracle to 9.2.0.7. Right?
Re: Error while during installation of patch set 9.2.0.7 in silent mode [message #205559 is a reply to message #205168] Sun, 26 November 2006 01:37 Go to previous message
yonieilon
Messages: 13
Registered: October 2006
Junior Member
Yes, I did.
But the installation of the patch must be in silent mode,
because it is part of an automated installation with minimum intervention by the user.
Previous Topic: Oracle 9i driver does not appear in DSN list
Next Topic: 10g on Win2000 Pro Installation Problem
Goto Forum:
  


Current Time: Sun Dec 04 14:24:49 CST 2016

Total time taken to generate the page: 0.04420 seconds