Home » Developer & Programmer » Forms » FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your run ti
FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your run ti [message #204976] Wed, 22 November 2006 23:52 Go to next message
amritava
Messages: 13
Registered: September 2006
Location: Kolkata
Junior Member
Hi all,
I've installed Oracle 10g DS successfully in my compueter.
It is in a LAN.I want to run forms, forms can be connected to database server.I've also configured the preference in Forms.
Also started oc4j instance.
In command line netstat -a shows that listener is established in 8889 port.
But when i try to run form the above said error message shown.
What may be the problem?
I'm confused..please suggest me what's the problem?
Regards
Amritava
Re: FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your ru [message #204983 is a reply to message #204976] Thu, 23 November 2006 00:04 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Full message is "FRM-10142 HTTP listener is not running on computer_name at port 888n." What is the number in your message?

Have a look at http://www.orafaq.com/forum/t/31266/2/

Have you printed off the installation manual and verified that you have done all installation steps?

Do you have spaces in any of your directory names? (This is a no-no.)

David
Re: FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your ru [message #204988 is a reply to message #204983] Thu, 23 November 2006 00:22 Go to previous messageGo to next message
amritava
Messages: 13
Registered: September 2006
Location: Kolkata
Junior Member
Hi david
the full message is
Re: FRM-10142 The HTTP Listener is not running on VISITOR00136.IN.nam.pwcinternal.com:8889. Please start the listener or check your run time preference.
What to do please suggest.While typing netstat -a in command line i can see that it is established in the port no 8889. In portlist file in install directory the http port is 8889 also.
regards
Amritava
Re: FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your ru [message #204989 is a reply to message #204988] Thu, 23 November 2006 00:26 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I repeat:
Have you printed off the installation manual and verified that you have done all installation steps?

Do you have spaces in any of your directory names?

David
Re: FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your ru [message #204992 is a reply to message #204989] Thu, 23 November 2006 00:28 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
During the installation of Forms was the port number displayed? Have you only installed Forms once?

David
Re: FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your ru [message #204998 is a reply to message #204992] Thu, 23 November 2006 00:31 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Another suggestion is to use Note:197481.1 from Metalink.

David
Re: FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your ru [message #204999 is a reply to message #204989] Thu, 23 November 2006 00:32 Go to previous messageGo to next message
amritava
Messages: 13
Registered: September 2006
Location: Kolkata
Junior Member
Hi david
Yes i follow every steps printed in installation manual and there is no space in any directory name
Regards
Amritava
Re: FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your ru [message #205002 is a reply to message #204999] Thu, 23 November 2006 00:35 Go to previous messageGo to next message
amritava
Messages: 13
Registered: September 2006
Location: Kolkata
Junior Member
Dear David
Yesterday I've seach for 197481.1 from Metalink in( probably HGrueneklee suggests that ) metalink.oracle.com.
but no entry found there.
can u provide me the exact url?
regards
Amritava
Re: FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your ru [message #205004 is a reply to message #205002] Thu, 23 November 2006 00:43 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
You asked for it - https://metalink.oracle.com/metalink/plsql/f?p=130:14:8568319751386165528::::p14_database_id,p14_docid,p14_show_header,p14_show_help, p14_black_frame,p14_font:NOT,197481.1,1,1,1,helvetica

Basically, whenever I installed Forms 9i or 10g I have used port 8888. The documentation says to modify some of the files in the 'config' directories. You could search the various files and look for '8888' and then change them one by one until it works. The notes state that the file of interest is <HOME>\j2ee\...\config\default-web-site.xml and then in the Form Builder you need to change the Runtime option to use your machine and domain and the new port number.

I don't have Forms in front of me so give these tips a go and I will continue searching google for a 'public' link.

David
Re: FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your ru [message #205006 is a reply to message #205004] Thu, 23 November 2006 00:48 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Did you ever get the 'test' form to work?

Also have a look at http://www.databasejournal.com/features/oracle/article.php/3322591

David
Re: FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your ru [message #205009 is a reply to message #205006] Thu, 23 November 2006 00:51 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have a look at the note in http://www.oracle.com/technology/tech/webservices/htdocs/quickstart/quickstart902.html

David
Re: FRM-10142 The HTTP Listener is not running on server. Please start the listener or check your ru [message #205020 is a reply to message #205009] Thu, 23 November 2006 01:33 Go to previous message
amritava
Messages: 13
Registered: September 2006
Location: Kolkata
Junior Member
Thank You daid.Let me go through the documents..i'll inform you about result later.
Regards
Amritava
Previous Topic: Basic trigger question
Next Topic: when-remove-record
Goto Forum:
  


Current Time: Tue Dec 06 04:39:36 CST 2016

Total time taken to generate the page: 0.06130 seconds