Home » RDBMS Server » Networking and Gateways » DB Link Problem from 9i Database to 8i Database
DB Link Problem from 9i Database to 8i Database [message #203122] Mon, 13 November 2006 23:40 Go to next message
DeepakT
Messages: 2
Registered: November 2006
Junior Member
Hi all,

Briefing the problem:

When I m going to connect database from 9i to 8i through DB link
I m getting an error like " The Database link is not active"

Please give me solution.

Thanks & Regards
DeepakT
Re: DB Link Problem from 9i Database to 8i Database [message #203178 is a reply to message #203122] Tue, 14 November 2006 03:35 Go to previous messageGo to next message
tahpush
Messages: 961
Registered: August 2006
Location: Stockholm/Sweden
Senior Member

Has it been created properly ?

Have you just tried

select 'x' from dual@dblinkname

Also can you select * from v$dblink ?
Re: DB Link Problem from 9i Database to 8i Database [message #203378 is a reply to message #203178] Tue, 14 November 2006 23:50 Go to previous messageGo to next message
DeepakT
Messages: 2
Registered: November 2006
Junior Member
Hi,

I think, it's not created properly.

If I use "select * from v$dblink", it shows no result.
Re: DB Link Problem from 9i Database to 8i Database [message #203391 is a reply to message #203378] Wed, 15 November 2006 00:15 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
So how did you create a database link? Did you provide correct credentials (username, password and database alias (can be found in TNSNAMES.ORA))?
Re: DB Link Problem from 9i Database to 8i Database [message #203441 is a reply to message #203391] Wed, 15 November 2006 02:53 Go to previous message
tahpush
Messages: 961
Registered: August 2006
Location: Stockholm/Sweden
Senior Member

Show us the create statement for the databaselink and an "extraction" of your tnsnames.ora for that particular database you are trying to connect to.

Might be easier to help you then.
Previous Topic: ORA-12520 when performing simultaneous requests
Next Topic: insufficient priveleges
Goto Forum:
  


Current Time: Sun Dec 04 08:43:07 CST 2016

Total time taken to generate the page: 0.10085 seconds