Home » Applications » Oracle Fusion Apps & E-Business Suite » Custom PLL disrupting Form
Custom PLL disrupting Form [message #202622] Fri, 10 November 2006 10:08 Go to next message
Messages: 220
Registered: April 2006
Senior Member
I am very new to using the CUSTOM.pll to customize forms, but I thought I would start off with something nice and simple just to kind of see what is going on and get a feel for what I want to be doing.

I am working with one form: PAXTREPE, so I inserted the following code at the end on our CUSTOM.pll file, compiled and placed the plx in the correct location.

if form_name = 'PAXTREPE' then
end if;

form_name and event_name are variables defined at the beginning of our custom pll and their meaning is pretty obvious.

I log into the instance and attempt to open the form and get the message :'WHEN-NEW-FORM-INSTANCE' Looks good, only that's it I get nothing else, form doesn't open, nothing.

The only time I get any more messages is when I try to do something else, or try to open the form again. Then I get a 'WHEN-FORM-NAVIGATE' followed by another 'WHEN-NEW-FORM-INSTANCE' if I was trying to open the same form again If it was another form that form displays normally.

I have tried using set_string/show instead of debug in fnd_message and that didn't seem to change anything. Am I just doing something really stupid wrong here? This just seems like the most basic of actions I could take and it doesn't work.

Any help would be greatly appreciated.


[Updated on: Fri, 10 November 2006 10:08]

Report message to a moderator

Re: Custom PLL disrupting Form [message #202656 is a reply to message #202622] Fri, 10 November 2006 13:01 Go to previous message
Messages: 220
Registered: April 2006
Senior Member
I have been working on this, and it looks like if you display a window as part of a when-new-form it seems to prevent the form from ever getting displayed. Same thing seems to happen if you use

HELP-->Diagnostic-->Custom Code-->Show Custom Events from the main forms menu. You will get notified when you try to open the form notifying you of the when-new-form event, but the form never opens.

Very weird stuff.

What I am actually trying to do is implement some validation that gets fired when the user presses the submit button in Pre-Approved Expenditure Entry Screen in the Grants Module. I was hoping I could just grab the when button pressed trigger and validate there, but that does not seem to work. Any ideas from other forms/modules on way to do validation after a specific button has been pressed?

I found someone's idea of looking for the when new item trigger on the the Submit Button, this does not seem like it would work because if someone was submitting more than one batch this button could get pressed more than one time and it would only get created the first time. After that there would be no new item trigger.

Any ideas would be appreciated,

Previous Topic: How to record these kind of transactions...
Next Topic: Auto invoice
Goto Forum:

Current Time: Mon Oct 24 11:06:06 CDT 2016

Total time taken to generate the page: 0.20446 seconds