Home » Server Options » Text & interMedia » problem using wildcard...
icon7.gif  problem using wildcard... [message #202186] Wed, 08 November 2006 11:35 Go to next message
Marias
Messages: 1
Registered: November 2006
Junior Member
Sorry for my bad english.
I have a problem using wildcard characters for a query into an Xmltable (DB Oracle 10g).

If i write (using \_ and _ wildcard):

select count(*) from TABLE x where contains( value(x), 'Ms.ACB.IX.100\_03_' ) > 0

i have 11 records (correct!!!)

But if i write (using \_ and % wildcard)

select count(*) from TABLE x where contains( value(x), 'Ms.ACB.IX.100\_03%' ) > 0

i have error ORA-29902/DRG-51030...

I don't know why it's different...
Please help me. Thank you so much.
Marias
Re: problem using wildcard... [message #202201 is a reply to message #202186] Wed, 08 November 2006 13:39 Go to previous message
Barbara Boehmer
Messages: 8635
Registered: November 2002
Location: California, USA
Senior Member
The underscore returns limited results, but using the percent sign might return many more results. Your error message indicates that your query has exceeded the wildcard expansion limit. You need to either modify your query to retrieve more limited results or increase the wildcard_maxterms attribute of your word list associated with your context index.


Previous Topic: Problim inserting pdf file with special characters
Next Topic: ordimage problem
Goto Forum:
  


Current Time: Thu Dec 08 18:47:04 CST 2016

Total time taken to generate the page: 0.10733 seconds