Home » Developer & Programmer » Forms » Fonts Change When Running
Fonts Change When Running [message #201146] Thu, 02 November 2006 16:02 Go to next message
whatfur
Messages: 29
Registered: July 2006
Junior Member
While in the 6.0 forms designer I modify a text label
that is something like Bold/Helvetica/17, adding just
additional text. I am doing this from the Canvas0 and
on the canvas I get what I want but when I run it it changes
to some unbolded, currior smaller font.

Whats going on?

Re: Fonts Change When Running [message #201165 is a reply to message #201146] Thu, 02 November 2006 17:41 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
This is probably because you 'appended' it to the 'end' of the prompt. If you had 'inserted' it in front of the 'last character' then it probably would have been okay. Try it and see.

David
icon13.gif  Re: Fonts Change When Running [message #201372 is a reply to message #201165] Fri, 03 November 2006 14:53 Go to previous messageGo to next message
whatfur
Messages: 29
Registered: July 2006
Junior Member
Not sure I am fully understanding, but you seemingly are saying
that I usurped the hidden font stylings. I don't think so..as
I can create a brand new Text item with a big bold font that shows up as desired on the designer canvas but it
too reduces to something small and pale when actually running the form ...even from right within the design tool.

This is unix running the f60desm.

Actually all text items on the form switch to the same font even
ones I did not modify. Seems to me like the fonts are getting overridden by some form default font. Is that possible...if so how does one prevent.?????

[Updated on: Fri, 03 November 2006 15:00]

Report message to a moderator

Re: Fonts Change When Running [message #201551 is a reply to message #201372] Sun, 05 November 2006 18:45 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
From your original post I assumed it was only happening to some of the text in some of the prompts. Now you say ALL text in ALL prompts. A quite different problem.

Have any of your forms given the prompt font that you expected? What was this font? Is this a new application that you are building or are you converting a suite of programs? If you said you were having this problem with your reports I would say that you have changed the font to 'Arial/10' which in the Windows environment is 'default/default' which will give rise to 'Helvetica/8' on the Unix box.

Please try changing your font to 'Courier' (not Courier New) and size '9' or '11' and see if that makes any difference.

Try searching this forum or the reports forum for 'res'. There are threads concerning this type of problem in Oracle Reports.

David
Re: Fonts Change When Running [message #201561 is a reply to message #201551] Sun, 05 November 2006 19:29 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
have a look at:
Font problems and keyboard mappings - Oracle? Forms Developer and Oracle Forms Services 6i (Patch 7)
http://www.oracle.com/technology/documentation/forms/6idocs/a92103_01.pdf

David
Re: Fonts Change When Running [message #201571 is a reply to message #201561] Sun, 05 November 2006 21:50 Go to previous messageGo to next message
whatfur
Messages: 29
Registered: July 2006
Junior Member
The Oracle patch document you sent me has a heading title
that had promise but the actual problem it describe is something
totally different than mine.

And I did try the suggested insertion of a courier text field
and it too changed to the same font as everything else when
actually running the form.




[Updated on: Sun, 05 November 2006 21:51]

Report message to a moderator

Re: Fonts Change When Running [message #201587 is a reply to message #201571] Sun, 05 November 2006 23:51 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Please answer the other questions:
Have any of your forms given the prompt font that you expected? What was this font? Is this a new application that you are building or are you converting a suite of programs?

David
Re: Fonts Change When Running [message #201755 is a reply to message #201587] Mon, 06 November 2006 10:39 Go to previous messageGo to next message
whatfur
Messages: 29
Registered: July 2006
Junior Member
I am moving forms from a different system to a new system
and making changes. So these are existing forms and on the
system I sourced them from things work just fine (as in I have
made the same changes I am attempting on this new system on the
old and the fonts work just fine).

They are seemingly running the same version...which is why I keep leaning towards thinking it is some sort of parameter file that is different.

[Updated on: Mon, 06 November 2006 13:02]

Report message to a moderator

Re: Fonts Change When Running [message #201839 is a reply to message #201755] Tue, 07 November 2006 01:02 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Did you read about the frmweb.res and frmpcweb.res files in that document to which I referred you. I believe it will solve your problem. You just have to define the '.res' files on the new machine.

David
Previous Topic: Auto Login in Forms
Next Topic: how to move a file and overwrite the original automatically?
Goto Forum:
  


Current Time: Wed Dec 07 18:18:02 CST 2016

Total time taken to generate the page: 0.09507 seconds