Home » RDBMS Server » Server Administration » Net configuration files
Net configuration files [message #200243] Sun, 29 October 2006 23:35 Go to next message
khushi2006
Messages: 13
Registered: October 2006
Junior Member
I have oracle server 9.2 installed on my machine. I have moved the tnsnames.ora, sqlnet.ora and listener.ora to c:\.
But when i connect to my database, it connects without giving any error message. I guess i need to set the tns_admin variable first and then only it should connect!!! Sqlnet.ora contains the following:
SQLNET.AUTHENTICATION_SERVICES= (NTS)
NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)
Please clarify.Khushi
Re: Net configuration files [message #200245 is a reply to message #200243] Sun, 29 October 2006 23:54 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

You connect from Server or Client

or in Server

like : cmd>sqlplus "scott/tiger" -- without host string
cmd>sqlplus / as sysdba
Re: Net configuration files [message #200246 is a reply to message #200243] Mon, 30 October 2006 00:02 Go to previous messageGo to next message
khushi2006
Messages: 13
Registered: October 2006
Junior Member
i am connecting from server using sqlplus with connect string scott/tiger.
Re: Net configuration files [message #200247 is a reply to message #200246] Mon, 30 October 2006 00:05 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Then Now try to connect like this.
cmd>sqlplus "scott/tiger@<db name>"

let us know what error you got.
Re: Net configuration files [message #200248 is a reply to message #200243] Mon, 30 October 2006 00:32 Go to previous message
khushi2006
Messages: 13
Registered: October 2006
Junior Member
It is still connecting.Also, i did the following:-

1)Using Net Manger, i created alias "Test1" to connect to same database.tnsname.ora is still in c:\. It created successfully but no entry was created in the tnsname.ora file.

2)i used the connect string scott/tiger@test1 to check wich gave the following error:
ORA-12154: TNS:could not resolve service name

3) Then i manually made an entry in tnsnames.ora in c:\ and rechecked, it worked.

For scott/tiger@<db_name> it is working .

[Updated on: Mon, 30 October 2006 00:33]

Report message to a moderator

Previous Topic: ProfileCreatedDate
Next Topic: How to configure RAC on 9.2 database
Goto Forum:
  


Current Time: Mon Dec 05 09:17:31 CST 2016

Total time taken to generate the page: 0.18020 seconds