Home » RDBMS Server » Server Utilities » Location of SQL*Loader required
Location of SQL*Loader required [message #199701] Wed, 25 October 2006 21:36 Go to next message
islandfong
Messages: 2
Registered: September 2006
Location: Singapore
Junior Member
I am using TOAD8.5.3 connecting to Oracle10g. I use the SQL*LOADER to import data from dat/CSV file to Oracle database. I follow the procedures as:
1. Select DBA -> SQL*Loader Wizard
2. Click Next and specify input files.
3. Click Add to add an input file.
4. Set the Record format as Stream and CLick Ok.
5. Click Next and select the destination table name.
6. Type a comma (,) in the All Fields Delimited by. (A drop down)
7. Click Next and specify the location of a control file name.
8. Click Save Settings to save the settings.
8. Click Next and select Execute Now with Watch Process.
9. Click Finish to execute.
Then I get the following error "Location of SQL*Loader required".
Can somebody tell me what's wrong with my procedure or any problem with my SQL*LOADER?
Re: Location of SQL*Loader required [message #199715 is a reply to message #199701] Thu, 26 October 2006 00:11 Go to previous messageGo to next message
Littlefoot
Messages: 19302
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Go to View - Options - Executables. Insert path to SQL*Loader utility (and any other you need/use), for example "C:\Oracle\Ora10DevSuite\bin\imp.exe".

However, it won't work if you didn't install SQL*Loader first. It comes, by default, with Oracle server, but not with client (if I'm not wrong about it).
Re: Location of SQL*Loader required [message #199800 is a reply to message #199715] Thu, 26 October 2006 04:16 Go to previous messageGo to next message
islandfong
Messages: 2
Registered: September 2006
Location: Singapore
Junior Member
Ok, thanks. That solves my problem.
Re: Location of SQL*Loader required [message #414003 is a reply to message #199800] Mon, 20 July 2009 01:55 Go to previous messageGo to next message
Uwe
Messages: 260
Registered: February 2003
Location: Z├╝rich, Switzerland
Senior Member
Hi all,

I got the same problem with my TOAD 9.1
But I have only a client installation on this PC. I tried to figure out which exe to build in, but i only found a loadsp.exe in the installed ORACLE_HOME/bin but it doesn't work.
Anytime i start the SQL-LOader Wizzard the message pops up. The tool starts, but the message is still up.

any suggestion welcome
Uwe
Re: Location of SQL*Loader required [message #414013 is a reply to message #414003] Mon, 20 July 2009 02:20 Go to previous messageGo to next message
Michel Cadot
Messages: 58496
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
1/ Get rid of TOAD
2/ Install Oracle admin tools in addition to baic client

Regards
Michel
Re: Location of SQL*Loader required [message #589517 is a reply to message #414013] Mon, 08 July 2013 03:38 Go to previous messageGo to next message
krissumanjaya
Messages: 5
Registered: July 2013
Location: Jakarta
Junior Member
Hi all,

I got the same problem with my Toad for Oracle 11.5.
I get the following error "location of sql*loader required".

is the solution for my problem the same with previous solution here?

Re: Location of SQL*Loader required [message #589519 is a reply to message #589517] Mon, 08 July 2013 03:59 Go to previous messageGo to next message
Michel Cadot
Messages: 58496
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Read my previous answer.

Regards
Michel
Re: Location of SQL*Loader required [message #589526 is a reply to message #589517] Mon, 08 July 2013 04:35 Go to previous messageGo to next message
Littlefoot
Messages: 19302
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
krissumanjaya

is the solution for my problem the same with previous solution here?

Only you can answer that question (after trying what's been suggested previously).
Re: Location of SQL*Loader required [message #589579 is a reply to message #589526] Mon, 08 July 2013 22:24 Go to previous messageGo to next message
krissumanjaya
Messages: 5
Registered: July 2013
Location: Jakarta
Junior Member
I am using Toad for Oracle 11.5 connecting to Oracle11g
on my data C:\ i not found IMP.exe or SQLLDR.EXE
Re: Location of SQL*Loader required [message #589580 is a reply to message #589579] Mon, 08 July 2013 22:27 Go to previous messageGo to next message
BlackSwan
Messages: 22481
Registered: January 2009
Senior Member
>on my data C:\ i not found IMP.exe or SQLLDR.EXE

only you can actually invoke OS File Search.
It depends upon what has or has not actually been installed on your system & we don't know that; but you should know.
Re: Location of SQL*Loader required [message #589584 is a reply to message #589580] Tue, 09 July 2013 00:10 Go to previous messageGo to next message
Littlefoot
Messages: 19302
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Do you have any kind of Oracle software installed on your computer (any database - including XE, or Client)? If not, then you don't have SQL*Loader either which, in turn, means that you should install it.
Re: Location of SQL*Loader required [message #589612 is a reply to message #589584] Tue, 09 July 2013 03:03 Go to previous messageGo to next message
krissumanjaya
Messages: 5
Registered: July 2013
Location: Jakarta
Junior Member
My problem has been resolved.
but i must reinstall my Oracle.
Thanks.
Re: Location of SQL*Loader required [message #589616 is a reply to message #589612] Tue, 09 July 2013 03:12 Go to previous messageGo to next message
Littlefoot
Messages: 19302
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Are you sure? Maybe you just need to run the Universal Installer again and install what's missing.
Re: Location of SQL*Loader required [message #589621 is a reply to message #589616] Tue, 09 July 2013 03:25 Go to previous messageGo to next message
krissumanjaya
Messages: 5
Registered: July 2013
Location: Jakarta
Junior Member
yes i'm sure. even i must downgrade oracle11g be oracle10g
Re: Location of SQL*Loader required [message #589628 is a reply to message #589621] Tue, 09 July 2013 04:17 Go to previous messageGo to next message
Littlefoot
Messages: 19302
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Just being curious: why do you have to downgrade it?
Re: Location of SQL*Loader required [message #589675 is a reply to message #589628] Tue, 09 July 2013 23:37 Go to previous messageGo to next message
krissumanjaya
Messages: 5
Registered: July 2013
Location: Jakarta
Junior Member
because when I reinstall the same version of the results are not affected, but after using another version successfully.
tx.
Re: Location of SQL*Loader required [message #589676 is a reply to message #589675] Tue, 09 July 2013 23:46 Go to previous message
Littlefoot
Messages: 19302
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator

What results are not affected?[ 1 vote ]
1. SQL*Loader doesn't do its job correctly 1 / 100%
2. You can't make it work with TOAD 0 / 0%
3. There's no SQL*Loader in Oracle version you are installing 0 / 0%
4. Other (please specify) 0 / 0%

(I'm not sure it makes much sense to insist on it any more, but ... curiosity killed the cat, hopefully it won't kill me)

[Updated on: Tue, 09 July 2013 23:47]

Report message to a moderator

Previous Topic: previleges error
Next Topic: how to add date/time in export dump file in Linux
Goto Forum:
  


Current Time: Wed Jul 23 05:19:22 CDT 2014

Total time taken to generate the page: 0.06187 seconds