Home » RDBMS Server » Security » database link
database link [message #197794] Thu, 12 October 2006 14:00 Go to next message
sweetgeegee27
Messages: 107
Registered: June 2005
Senior Member
I have a database link to query a view created of an external source, but they keep on getting error message: a table or view does not exist. Please note that the link use to work fine in Oracle 8i but we have just migrated to 10g. THe link is as follows:

CREATE SHARED PUBLIC DATABASE LINK ASYDB_GENESIS.SIGTAS
CONNECT TO IRD_CUSTOM IDENTIFIED BY IRD_CUSTOM
AUTHENTICATED BY IRD_CUSTOM IDENTIFIED BY IRD_CUSTOM
USING 'ASYDB_GENESIS';


Can anybody tell me what may be wrong? Thanks in advance
Re: database link [message #197797 is a reply to message #197794] Thu, 12 October 2006 14:34 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Does the tnsconnect string ASYDB_GENESIS still exists?
Check tnsnames.ora. Are you using ORACLE_SID or SERVICE_NAME?
Re: database link [message #197800 is a reply to message #197797] Thu, 12 October 2006 14:55 Go to previous messageGo to next message
sweetgeegee27
Messages: 107
Registered: June 2005
Senior Member
I am using oracle_sid
Re: database link [message #197801 is a reply to message #197800] Thu, 12 October 2006 14:57 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Did you try switching to SERVICE_NAME?
Re: database link [message #197802 is a reply to message #197801] Thu, 12 October 2006 15:02 Go to previous messageGo to next message
sweetgeegee27
Messages: 107
Registered: June 2005
Senior Member
What would be the service_name?
Re: database link [message #197808 is a reply to message #197801] Thu, 12 October 2006 15:39 Go to previous messageGo to next message
sweetgeegee27
Messages: 107
Registered: June 2005
Senior Member
Ok. I know that the service name is ASYDB_GENESIS. but when I test the link it returns ORA-12154: TNS:could not resolve the connect identifier specified.
Re: database link [message #197810 is a reply to message #197808] Thu, 12 October 2006 15:51 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
post your tnsnames.ora (relevant contents only).
Before doing anything with database link,
first see whether you can reach the remote database from your machine/wherever the dblink was created.

sqlplus user/pass@ASYDB_GENESIS
if this works,
then the problem is with the dblink.


Re: database link [message #198551 is a reply to message #197810] Tue, 17 October 2006 10:19 Go to previous message
sweetgeegee27
Messages: 107
Registered: June 2005
Senior Member
Thanks for help but I was able to fix the database link by using a different service name (apparently the current name was incorrect) and then granting the user select permission on the view used for the link.
Previous Topic: Oracle Password History
Next Topic: Can I alter my own expired password from application level?
Goto Forum:
  


Current Time: Mon Dec 05 14:38:39 CST 2016

Total time taken to generate the page: 0.24779 seconds