Home » Developer & Programmer » Forms » nls_numeric_characters
nls_numeric_characters [message #196688] Fri, 06 October 2006 09:07 Go to next message
Messages: 310
Registered: May 2005
Senior Member

i have an application runing an english french interface,
numbers in english use dot for decimal point ex: 123.45
if the user choose french as a language the number should display 123,56

so after some research i was directed to use
dbms_ddl('alter session set nls_numeric_characters=,.)

what is wird is that the alter session works fine within sqlplus but never within toad or form builder, there it says 'session altered' but the numbers are still displayed with a dot . as a decimal separator, while in sqlplus it works
i dont want to change the registery value each time
any help ?
Re: nls_numeric_characters [message #196721 is a reply to message #196688] Fri, 06 October 2006 15:11 Go to previous messageGo to next message
Messages: 20847
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
The answer might be in characters you use to display thousands separator and decimal point. If you use , and . in format mask, there's a good chance that the result won't be as expected. If you, on the other hand, use D as a decimal point character and G as thousands separator, you might get a better result.

In other words: don't use

TO_CHAR(some_number, '99,990.00')


TO_CHAR(some_number, '99G990D00')
Re: nls_numeric_characters [message #196862 is a reply to message #196721] Sun, 08 October 2006 13:59 Go to previous message
Messages: 104
Registered: December 2005
Location: Netherlands - IJmuiden
Senior Member

I run also in this problem in Toad. I found out that there is a parameter in the 'Options' that overrules your session settings:

General / Numeric Characters.


Rob Zijlstra
Next Topic: question from all the experts: Did we the change the key stroke?
Goto Forum:

Current Time: Fri Oct 28 11:32:47 CDT 2016

Total time taken to generate the page: 0.16569 seconds