Home » RDBMS Server » Server Administration » Problems in compiling invalid objects
Problems in compiling invalid objects [message #194936] Tue, 26 September 2006 04:46 Go to next message
M.Shakeel Azeem
Messages: 226
Registered: September 2006
Senior Member
When i run the query to find invalid objects
SELECT owner,
object_type,
object_name,
status
FROM dba_objects
WHERE status = 'INVALID'
ORDER BY owner, object_type, object_name;
85 rows selected
After that run the utlrp.sql and ran the above mentioned query then i got
49 rows selected
i ran the script again and still i found
49 rows selected
and i use
EXEC DBMS_UTILITY.compile_schema (schema => 'SCOTT');
and still invalid objects are 49
and i also use
EXEC UTL_RECOMP.recomp_serial();
and still invalid objects are 49

it is very confusing why we are still having invalid objects after trying all of the possibilities?
can anybody help me in this regard?

thanx in advance
Re: Problems in compiling invalid objects [message #194944 is a reply to message #194936] Tue, 26 September 2006 05:00 Go to previous message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
how about the other schemas/owners?
are all the invalid objects only in scott?
Sometimes you will have many in sys/system/other oracle installed scheams becuase of the options you chose.
Other reason might be, the objects are really invalid becuase of lost dependendices or erraneous code.
You are just compiling schema. It will try to compile the objects. If any error is found,the object will be left in invalid state
Previous Topic: Invalid Objects
Next Topic: How to jump over a trigger
Goto Forum:
  


Current Time: Sat Dec 10 16:57:00 CST 2016

Total time taken to generate the page: 0.09463 seconds