Home » Developer & Programmer » Reports & Discoverer » D2K Report Builder (6.0) printing problem on Windows XP machines
D2K Report Builder (6.0) printing problem on Windows XP machines [message #193251] Fri, 15 September 2006 07:34 Go to next message
himesh.chaudhari
Messages: 3
Registered: September 2006
Location: Mumbai
Junior Member
Hi,

We currently have windows 98 machnies on which we run and print reports from D2K (Reports 6.0). Printer if connected to windows 98/95 machine prints as can be seen on screen. But as we connect printer to other OS like NT/2000/XP with existing PRT(one of the PRT we are using pls see below )files the printer starts skipping extra line or skips page feed and prints continuously.
Pls help me as we need to switch to XP machines. Thanks in advance.

printer "COMPRESSED-240"

height 66
width 245
code "1" esc "G"
code "2" esc "H"
code "3" control(O)
code "4" control(R)
code "5" control(N)
code "6" control(T)
code "7" esc "M"
code "8" esc "N"
code "9" esc "-1"
code "10" esc "-0"


after page control(L)

return control(M)
linefeed control(J)

Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #193458 is a reply to message #193251] Sun, 17 September 2006 04:20 Go to previous messageGo to next message
simple_ora
Messages: 50
Registered: September 2006
Location: UAE
Member
I Have the same problem; when i am printing from Win98 mechene
its printing nicely as character fromat,but when i am trying to printer in Win-Xp Mechene its printing Double line and bitmap format,Plz help me
Thanks in Advance
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #193567 is a reply to message #193251] Mon, 18 September 2006 05:25 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member

Try these setting when printing on XP machine

In Windows Printer property ( go via control pannel\printers) set Advance Features off. If it still not printing fine then set Direct printing on rather than spooling.

Sandy
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #193715 is a reply to message #193567] Tue, 19 September 2006 02:11 Go to previous messageGo to next message
prameshgupta
Messages: 5
Registered: September 2006
Location: Mumbai
Junior Member
Hi Sandy,

Thanks in advance,

i had done the printer settings but again giving the same problem,
the printer is dotmatrix printer

Regards,

Ram
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #193716 is a reply to message #193715] Tue, 19 September 2006 02:17 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member

is it still printing in BITMAP mode?

if yes, please answer below question.

Are you getting printed some ractangles like charater printed on report before heading or the text you are applying the code?

If yes then You need to check your printer settings, else
your PRT files are not on right location.

Sandy
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194019 is a reply to message #193716] Wed, 20 September 2006 08:01 Go to previous messageGo to next message
simple_ora
Messages: 50
Registered: September 2006
Location: UAE
Member
Hi Guys,
Its Worked for me ,thank u sandy and others...
I changed my printer settings( disabled advanced printing mode),
Thank you once again...

But there is other problem ,in my report some headers i have designed bold and increased the font size,and its displaying the same i designed,but while printing all the characters are same size and no bold headings...
Wat's the problem ,should i change prt file..
Regards
Shefeeq.
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194137 is a reply to message #194019] Wed, 20 September 2006 23:17 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member

Quote:

But there is other problem ,in my report some headers i have designed bold and increased the font size,and its displaying the same i designed,but while printing all the characters are same size and no bold headings...
Wat's the problem ,should i change prt file..


Use printer code on the text you want to make bold or any other formating. And put the same code in same PRT file too. which printer you are using to print report?

Sandy

Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194183 is a reply to message #193567] Thu, 21 September 2006 02:18 Go to previous messageGo to next message
himesh.chaudhari
Messages: 3
Registered: September 2006
Location: Mumbai
Junior Member
Hi sandy,

Tried disabling the advance printing featues. Even check the PRT file path. But the problem continues. Can you tell me what is right location for PRT file and what is direct printing(where to set?)
Thanks in Advance

Regards,

Himesh
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194184 is a reply to message #194183] Thu, 21 September 2006 02:25 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member

PRT should be in default path that is
$oracle_home$\REPORT60\PRINTERS\

Direct printing is feature of printer. The file that should be printed will not spooled first, it will be directly printed to the printer. You will find this on printer property.

can you send your problem in detail. Are reports are printing fine on other O/P system like on 98.

Sandy
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194208 is a reply to message #194184] Thu, 21 September 2006 03:31 Go to previous messageGo to next message
simple_ora
Messages: 50
Registered: September 2006
Location: UAE
Member
hi Sandy
How to give bold characters in the report...?,I Just Make bold the font in report and its displaying the same...,

And how to give these characters in PRT file

Thanks for quick respnse
Reagrds
Shefeeq
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194209 is a reply to message #194208] Thu, 21 September 2006 03:37 Go to previous messageGo to next message
simple_ora
Messages: 50
Registered: September 2006
Location: UAE
Member
Hi Sandy I am using Epson Lq 870 and Lq1170
Its given the code below in Epson Manual

Ascii Dec Hex Descri

ESC E 69 45 Select Bold Font
SO 14 0E Double Width printing

How to attch these code in Report and prt file...?

Thanks & Regrads
Shefeeq
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194214 is a reply to message #194209] Thu, 21 September 2006 03:50 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member

add these code to your PRT file and call this code to your report's feilds. open property of feild and put code on PRINTER CODE BEFORE to bold on and put code on PRINTER CODE AFTER to bold off.

eg if you have place code "11" for bold on and "12" for bold off. then
put &11 at PRINTER CODE BEFORE and &12 at PRINTER CODE AFTER.

sandy
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194217 is a reply to message #194214] Thu, 21 September 2006 03:58 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member

what the codes are given in manual of printer to make bold on/off, doublewidth on/off in ascii.

Sandy
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194240 is a reply to message #194217] Thu, 21 September 2006 04:58 Go to previous messageGo to next message
simple_ora
Messages: 50
Registered: September 2006
Location: UAE
Member
Hi Sandy
In The Epson Manual Its given as
Asii Dec Hex Descrotption
Esc E 69 45 Select Bold Font
Esc F 70 46 Cancel Bold Font

Now I have given Decimal Value 69 & 70 Given Before & after Printing report in header item's property
But its not working

Thank u once again for ur quick response
Shefeeq
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194241 is a reply to message #194240] Thu, 21 September 2006 05:03 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member

make entry in ur PRT like

code "1" esc "E"
code "2" esc "F"


and pass &1 to make bold on and &2 to make bold off.

Sandy
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194244 is a reply to message #194241] Thu, 21 September 2006 05:07 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member

You can also use this in your PRT

code "1" "E" -- for BOLD on
code "2" "F" -- for BOLD off


Sandy
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194403 is a reply to message #194184] Fri, 22 September 2006 00:22 Go to previous messageGo to next message
himesh.chaudhari
Messages: 3
Registered: September 2006
Location: Mumbai
Junior Member
Hey Sandy,

Thanks a ton. This solution(Direct printing) worked. One small query :-
without setting Direct printing all reports were skipping the page break and hence were printing pages continuously without page break and after setting this Direct Printing option printer started giving proper page break. Can u pls write in more detail on this.
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194616 is a reply to message #194403] Sat, 23 September 2006 00:54 Go to previous messageGo to next message
simple_ora
Messages: 50
Registered: September 2006
Location: UAE
Member
Hi sanady
I am giving Desname = Printer_share_Name ,and its hard coded.
If i print to local print its not working,
Is there any way to give only LPT1 as the desname instead of printer name.
Thanks in Advance
Shefeeq
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194690 is a reply to message #194616] Sun, 24 September 2006 03:43 Go to previous messageGo to next message
simple_ora
Messages: 50
Registered: September 2006
Location: UAE
Member
Hi Guys,
How we can change the page settings from the report
I am prinitng a voucher using dotmatrix printer.
Its of size A5, but its printing A5 and skipping the rest to full page..,Any idea...
Thanks & Regards
Shefeeq
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #194965 is a reply to message #194616] Tue, 26 September 2006 05:53 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member

Quote:

I am giving Desname = Printer_share_Name ,and its hard coded. If i print to local print its not working,
Is there any way to give only LPT1 as the desname instead of printer name.


Don't pass printername in desname, make it blank. When you will run your report, destype as printer, then it will automatically be printed on Default printer from defined group of printer at you machine.


Sandy

[Updated on: Tue, 26 September 2006 05:54]

Report message to a moderator

Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #197973 is a reply to message #193251] Fri, 13 October 2006 09:34 Go to previous messageGo to next message
issbwc
Messages: 4
Registered: June 2006
Junior Member
Laughing
hellow Guys,


Its Worked for me ,thank u sandy and others...
I changed my printer settings( disabled advanced printing mode),
and direct printing to printer

vijay kant sharma
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #199922 is a reply to message #193251] Thu, 26 October 2006 23:46 Go to previous messageGo to next message
akchng
Messages: 5
Registered: October 2006
Location: HK
Junior Member

Hi Guys,

I encountered the same problem in direct printer to a dot-matrix printer. I followed the advise posted but doesn't work. I want to make the font size smaller. I put &123 at PRINTER CODE BEFORE and added the following lines separately into the .prt .

code "123" esc "g" --To print in 15cpi
or
code "123" esc "M" --To print in 12cpi

The output of the printout have <-g or <-M in front of every line. My dot-matrix printer is Epson LQ-2080 and it is a local printer of WinXP. My application is running on 10g AS in win2003 and send the output to winXP to print.

Please advise and thanks in advance.

Rgds
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #200186 is a reply to message #199922] Sun, 29 October 2006 00:42 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member


Quote:
code "123" esc "g" --To print in 15cpi
or
code "123" esc "M" --To print in 12cpi



Try with followind codes...

code "01" "P" -- pica PITCH 10
code "02" "M" -- Elite PITCH 12
code "03" "g" -- PITCH 15


Sandy
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #200741 is a reply to message #193251] Wed, 01 November 2006 02:40 Go to previous messageGo to next message
akchng
Messages: 5
Registered: October 2006
Location: HK
Junior Member
Sandy,

I don't know whether I just copy your coding to my .prt is fine or not because I have no idea of how to type the left arrow.
Please advise.

Rgds
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #200914 is a reply to message #193251] Wed, 01 November 2006 21:24 Go to previous messageGo to next message
akchng
Messages: 5
Registered: October 2006
Location: HK
Junior Member
Sandy,

I copied and pasted the coding you provided into my .prt file and added the &03 code in the Printer Code Before properties, the report font size did not change. The printer control character does not show up in the front of each line this time.

Rgds
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #200925 is a reply to message #200741] Wed, 01 November 2006 22:57 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member

Hi,
Generate a txt file as output to your report. And check if printer control characters is before the Field text on which you have used the printer code. If not then please make sure that this Field should not be oevrlaped. If printer control characters are present in your generated txt file then check the printer settings.
Hope this will solve your problem.

Sandy
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #200926 is a reply to message #200741] Wed, 01 November 2006 23:04 Go to previous messageGo to next message
sandeepk7
Messages: 137
Registered: September 2006
Senior Member

code "03" "g" -- PITCH 15
Character "" represents the left arrow as printer control character.

Sandy
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #200976 is a reply to message #193251] Thu, 02 November 2006 02:00 Go to previous messageGo to next message
akchng
Messages: 5
Registered: October 2006
Location: HK
Junior Member
Sandy,

I find that when I use the &123 in report and .prt, the printer control character display in front of every line. But when I changed the code to &03 or &3 in the report, no printer control character display or view by text editor. Neither did the font change during printing.

Rgds
Re: D2K Report Builder (6.0) printing problem on Windows XP machines [message #305600 is a reply to message #193251] Tue, 11 March 2008 06:11 Go to previous message
sanjivpune
Messages: 2
Registered: March 2008
Location: pune
Junior Member
We currently have windows 98 machnies on which we run and print reports from D2K (Reports 6.0). Printer if connected to windows 98/95 machine prints as can be seen on screen. But as we connect printer to other OS like NT/2000/XP with existing PRT(one of the PRT we are using pls see below )files the printer starts skipping extra line or skips page feed and prints continuously.
Pls help me as we need to switch to XP machines. Thanks in advance.

Previous Topic: Want to Generate excel report form Pdf directly
Next Topic: create trigger
Goto Forum:
  


Current Time: Sun Dec 11 06:03:48 CST 2016

Total time taken to generate the page: 0.07054 seconds